Jump to content

CRJ SU5 speed issue


davidnorfolk96
 Share

Recommended Posts

I repeated the process of deleting the files and this time worked. The aircraft is flyable again for me with this temp fix. Thanks for the effort on the update, will wait for it while flying :)

Link to comment
Share on other sites

Thank you Mathijis. We know you are all trying your best.  But are you able to advise on the temporary fix for the speed tape. The fix worked for both the 500 and 700 before todays msfs hotfix, but is not working after the hotfix (only tried on the 700 so far). So the question is should we delete the m files again and redo that process to restore the quick fix?

Link to comment
Share on other sites

  • Developer

Guys, I'm sorry that this happens. Please understand that we (Aerosoft and myself) really can't do anything about it.

 

For those who are interested, here's what's going on:
You all know the beloved 10 minute wait when the CRJ is loaded for the first time. During these 10 minutes, the .WASM file in the aircraft's panel folder is compiled into a Windows DLL (Dynamic Link Library) which then is loaded by Flight Simulator. The wait was annoying but the process worked (except for some who used older CPUs). With the 1.18.13.0 update, an additional compiler option ("-fast-math") was introduced to make the WASM code even faster. Unfortunately this option has a nasty side effect: it causes decreased calculation precision (faster execution = lower precision; slower execution = higher precision) with the effect that values close can become zero. This happens in a sub-term of the indicated airspeed calculation with the result that the whole formula becomes zero. As a consequence, all three airspeed indicators are stuck at zero.

The "Fast WASM compilation" option disables -fast-math and as a result, the airspeed indicator works. Once I started using this option, the problem was gone for me. But of course I didn't know that was the reason.

Being able to track this down was like a win in the lottery. I only found out by pure because after installing the release 1.18.13.0, the airspeed indicator was stuck again and when I went into the dev mode menu, "Fast WASM Compilation" was disabled. I enabled it and the airspeed indicator worked. So, I tried switching fast compilation on and off a few more times and also asked the CRJ beta testers to give it a try. They confirmed that my finding was right and so I reported it to Asobo who, after some more testing confirmed it and gave me the technical information that I told you above.

 

The bottom line is: It is now known what the problem is and how to fix it. All that is needed is an MSFS update where the fix is deployed. This brings us to the question that all of you want to ask me: "When?". Unfortunately, my answer is: I don't know. Sorry.

  • Like 7
  • Thanks 1
  • Upvote 1
Link to comment
Share on other sites

Thanks @Hans Hartmann for the explanation -- much appreciated. If the issue is entirely with Asobo's code as it seems, and there's an easy workaround for it for the time being, is it possible to make 1.0.6 available now? It seems like that would at least leave everyone in better shape for the time being than the current build, with the unfortunate trade-off of people not reading instructions to toggle the Fast WASM compilation setting and blaming Aerosoft that the aircraft is still broken. I know you could literally put that instruction in place of the current message indicating that the first load can take up to ten minutes and many people still won't read it.

Link to comment
Share on other sites

Thanks Hans, also much appreciated and your detailed information is also helpful and interesting.  Until asobo fix the problem, can you advise if you are aware of any downside in using the fast wasm compilation?  Someone seemed to report a loss of fps, but I cannot be sure about this.  Thanks.

Link to comment
Share on other sites

On 7/28/2021 at 12:05 PM, Hans Hartmann said:

So, we were able to track down the cause of the issue this morning and we can offer a temporary workaround which brings the airspeed indicators back to life. Please check out the attached PDF. Any feedback is of course very welcome.

 

 

Workaround the stuck airspeed indicator issue.pdf 330.38 kB · 252 downloads


This is not working for me after today's update. Worked fine yesterday. 

Link to comment
Share on other sites

2 hours ago, g5crj said:

I repeated the process of deleting the files and this time worked. The aircraft is flyable again for me with this temp fix. Thanks for the effort on the update, will wait for it while flying :)


Will try again tomorrow morning!

Link to comment
Share on other sites

3 minutes ago, Moridin said:


This is not working for me after today's update. Worked fine yesterday. 

try again it should work.  I deleted the m files and turned on the fast wasm and then loaded in the 700 and then the 500 and both temporary fixes were working.  I hope this stays for tomorrow!

Link to comment
Share on other sites

1 hour ago, Hans Hartmann said:

Guys, I'm sorry that this happens. Please understand that we (Aerosoft and myself) really can't do anything about it.


Don’t be. Not your fault. I don’t believe anyone here is blaming you guys. Keep us posted and we’ll be happy. And we will try things out in the meantime since we just want to fly the CRJ.

 

Oh btw had a funny bug today…

 

Was flying LFMN to LIRQ and when programming the FMS, the aircraft would freeze when I set the Arrival procedure. After selecting STAR, transition and runway, it would freeze. I could still move my mouse and switch switches but the FMS was frozen. 

Link to comment
Share on other sites

4 minutes ago, RF pilot said:

try again it should work.  I deleted the m files and turned on the fast wasm and then loaded in the 700 and then the 500 and both temporary fixes were working.  I hope this stays for tomorrow!


So I had Fast WASM enabled from the past few days. Deleted m* files, started MSFS, went into Dev mode to confirm Fast WASM was on, loaded aircraft. Twice. Should I try to turn Fast WASM off, restart, and then do the procedure? Or should that not make a difference?

Link to comment
Share on other sites

1 hour ago, Hans Hartmann said:

Guys, I'm sorry that this happens. Please understand that we (Aerosoft and myself) really can't do anything about it.

 

For those who are interested, here's what's going on:
You all know the beloved 10 minute wait when the CRJ is loaded for the first time. During these 10 minutes, the .WASM file in the aircraft's panel folder is compiled into a Windows DLL (Dynamic Link Library) which then is loaded by Flight Simulator. The wait was annoying but the process worked (except for some who used older CPUs). With the 1.18.13.0 update, an additional compiler option ("-fast-math") was introduced to make the WASM code even faster. Unfortunately this option has a nasty side effect: it causes decreased calculation precision (faster execution = lower precision; slower execution = higher precision) with the effect that values close can become zero. This happens in a sub-term of the indicated airspeed calculation with the result that the whole formula becomes zero. As a consequence, all three airspeed indicators are stuck at zero.

The "Fast WASM compilation" option disables -fast-math and as a result, the airspeed indicator works. Once I started using this option, the problem was gone for me. But of course I didn't know that was the reason.

Being able to track this down was like a win in the lottery. I only found out by pure because after installing the release 1.18.13.0, the airspeed indicator was stuck again and when I went into the dev mode menu, "Fast WASM Compilation" was disabled. I enabled it and the airspeed indicator worked. So, I tried switching fast compilation on and off a few more times and also asked the CRJ beta testers to give it a try. They confirmed that my finding was right and so I reported it to Asobo who, after some more testing confirmed it and gave me the technical information that I told you above.

 

The bottom line is: It is now known what the problem is and how to fix it. All that is needed is an MSFS update where the fix is deployed. This brings us to the question that all of you want to ask me: "When?". Unfortunately, my answer is: I don't know. Sorry.

 

We were able to get around this issue for the A32NX by writing our own custom implementations of pow() and exp() - which (at least in our case), were the cmath functions that were returning erroneous values as a result of the --fast-math compiler option forced in SU5.

  • Like 1
  • Thanks 2
  • Upvote 6
Link to comment
Share on other sites

All was going so well with MSFS and CRJ. Then this nasty update came out. Degraded my visuals … made CRJ unpredictable….wasted my experience… I hope  console players are cheering 

Link to comment
Share on other sites

1 hour ago, Moridin said:


So I had Fast WASM enabled from the past few days. Deleted m* files, started MSFS, went into Dev mode to confirm Fast WASM was on, loaded aircraft. Twice. Should I try to turn Fast WASM off, restart, and then do the procedure? Or should that not make a difference?

Yes I think you should turn off fast wasm, close msfs, delete the m files, open msfs and then turn on fast wasm and then load the crjs

Link to comment
Share on other sites

  • Developer
13 hours ago, RF pilot said:

can you advise if you are aware of any downside in using the fast wasm compilation?

I am not aware of any downside. I was told that other developers reported a drop in performance but so far, I didn't notice anything like that for the CRJ.

Link to comment
Share on other sites

15 hours ago, Hans Hartmann said:

Guys, I'm sorry that this happens. Please understand that we (Aerosoft and myself) really can't do anything about it.

 

For those who are interested, here's what's going on:
You all know the beloved 10 minute wait when the CRJ is loaded for the first time. During these 10 minutes, the .WASM file in the aircraft's panel folder is compiled into a Windows DLL (Dynamic Link Library) which then is loaded by Flight Simulator. The wait was annoying but the process worked (except for some who used older CPUs). With the 1.18.13.0 update, an additional compiler option ("-fast-math") was introduced to make the WASM code even faster. Unfortunately this option has a nasty side effect: it causes decreased calculation precision (faster execution = lower precision; slower execution = higher precision) with the effect that values close can become zero. This happens in a sub-term of the indicated airspeed calculation with the result that the whole formula becomes zero. As a consequence, all three airspeed indicators are stuck at zero.

The "Fast WASM compilation" option disables -fast-math and as a result, the airspeed indicator works. Once I started using this option, the problem was gone for me. But of course I didn't know that was the reason.

Being able to track this down was like a win in the lottery. I only found out by pure because after installing the release 1.18.13.0, the airspeed indicator was stuck again and when I went into the dev mode menu, "Fast WASM Compilation" was disabled. I enabled it and the airspeed indicator worked. So, I tried switching fast compilation on and off a few more times and also asked the CRJ beta testers to give it a try. They confirmed that my finding was right and so I reported it to Asobo who, after some more testing confirmed it and gave me the technical information that I told you above.

 

The bottom line is: It is now known what the problem is and how to fix it. All that is needed is an MSFS update where the fix is deployed. This brings us to the question that all of you want to ask me: "When?". Unfortunately, my answer is: I don't know. Sorry.

 

Great explanation, much appreciated! They've basically re-written half the base code so it was expected that a lot may be broken or affected by this update and whilst frustrating, you are clearly sharing that frustration with us too in trying to fix it for us so we can return to enjoying the fabulous CRJ!

 

We appreciate all the work you and the team are doing, and continue to do! 

  • Like 2
Link to comment
Share on other sites

14 hours ago, RF pilot said:

Yes I think you should turn off fast wasm, close msfs, delete the m files, open msfs and then turn on fast wasm and then load the crjs


It worked this time! All good. Had two flights without issue this morning.

Link to comment
Share on other sites

3 hours ago, Hans Hartmann said:

I am not aware of any downside. I was told that other developers reported a drop in performance but so far, I didn't notice anything like that for the CRJ.

 

Hans, I noticed using this work around that performance appears to decrease. I mentioned this in a previous post where my fps dropped a fair amount after doing this. I uninstalled, deleted all folders, and reinstalled to find my performance increased (speed tape was stuck again). Have you seen this?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...