Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
Branimir

CRJ Pro started to stutter with low FPS with AC power ON

Recommended Posts

Hello!. When 

My CRJ Pro started to stutter a day ago. A have 15FPS in the cockpit with a very bad stuttering. It starts when I turn on the ground power (AC power, also happes with APU). When remaining four MFDs come alive my FPS drops from 30-40FPS to 15FPS with bad stuttering. This is the problem with MFD displays. If I disable FO side frame rate rises to 20FPS and if I also disable the captain side it rises to 30-40FPS. CRJ Pro was working completely fine few days ago. 

I had the same problem less than a month ago. I did a CRJ reinstall, P3D v4 reinstall and nothing helped. I bought a NVME SSD less months ago and I decided not to move (clone) the old SSD to NVME but to reinstall whole Windows 10 and P3D and start from the beginning because that should 100% fix the problem - and it did! But it was a pain to reinstall all addons, reconfigure whole system, P3D ...

And now I have the same problem and complete Windows 10 reinstall is not an option for me because it is very time consuming to have the CRJ working properly for less than a month. All other planes are working perfectly. The problem also exists while in the outside view - frame rate is dropping to 15FPS and rising to 80FPS every second. I have just reinstalled my P3D and CRJ and I also deleted the .cfg file and there is no difference.

It is also interesting that frame rate stays at 15FPS even if in move all settings sliders to full left position. The only thing I did before this problem started is installing an Air Manager Plugin that connects P3D and Air Manager software (home cockpit gauges for my C172 home cockpit project) together but I am sure that this should not cause this problem. I also reinstalled the plugin (deleting the .dll and removing an entry in dll.xml file) and it did't fix it.

 

My PC specs:

i7-7700 (HT enabled, running at 4.2GHz)

16GB DDR4

Gigabyte RTX 2070 SUPER GAMING OC

Gigabyte 750W 80 Plus Gold

 

Prepar3D V4.5 Hotfix 2

AS CRJ Pro 2.0.0.3

 

Do you know how to fix the problem because it is unflyable and I really want to continue flying this beautiful addon?

 

Thank you!

Share this post


Link to post
Share on other sites

I have also just found out that it works very randomly. After many restarts of P3D it worked and after another restart I am having the same problem. I have spent my entire day restarting and figuring out what is wrong and it worked fine on two occasions but I have this problem 99% of the time. I don't know what to do :(

Share this post


Link to post
Share on other sites

i have stutters when taxing and tried everything performance is not great on this AC .

Share this post


Link to post
Share on other sites

The same trouble. I cut off the engines after wjen i get FL230 and FPS got rise. I don`t know why.

Share this post


Link to post
Share on other sites

We have looked at this issue from every possible side and simply have no idea what causes it. As we have three customers who see this issue and no other reports we have to conclude it is something specific on those three machines that is not on the thousands of others. But what that is? As said we simply have no idea. Sorry.

Share this post


Link to post
Share on other sites

Hello. But there are many people who has a troubles with low FPS on great computers. All the reinstallation (Windows and so on) didn`t help.

And It is sad.

Will wait for the next update for the CRJ.

Share this post


Link to post
Share on other sites

Also get this problem, any plane runs over 60FPS. AEROSOFT CRJ GOES UNDER 20FPS WHEN AC ON,  REALLY FRUSTRUATING, I THINK IT HAS TO BE FIXED. There is no way the problem is on our machines, due to the fact that I run anyplane with over 60 FPS. 

  • Like 1

Share this post


Link to post
Share on other sites

I've noticed something similar. I get massive fps fluctuations once the displays come on. I have a very strong PC and yet still it causes the FPS to dip down into 20fps and below. This also happened even on my old PC. I've tried tons of settings limiting and unlimiting fps to no avail. It seems there is something quite wrong.

Share this post


Link to post
Share on other sites

Hello Mathijs Kok.

+2 users who has the same trouble.

Guys, everyone who has the same trouble, put "+" here. Do not be indifferent.

 

Thank you.

Share this post


Link to post
Share on other sites

I still can't reproduce that. I have three PCs (i9-9900K/32 GB/RTX 2080ti, i7-5820K/32GB/GTX 1070, Notebook Ryzen 7-3750H/24GB/GTX1160. All with Windows 10 64-bit (1909, the i9 has 2004) and latest nvidia drivers) but I don't see any fps change on any of them. The only significant difference to you is that I use the latest almost-beta version of the CRJ Pro and not 2.0.0.3.

Share this post


Link to post
Share on other sites

Last update didn`t fix a problem with low FPS. But i think, I found a reason of low FPS. It is not depends on AC ON, it`s connected with displays. So, when you push on the displays looks like on the picture, displays becomig dark.

When displays are dark, FPS rises. Just try it.

111.jpg

Share this post


Link to post
Share on other sites

Of course the displays have an impact on the framerate. Every additional display increases the number of drawing operations up to the point where rendering one frame takes longer than the time scheduled for each frame. The result of this is a dropping framerate. This is why I added the option to switch off the first officer displays. Removing those helps a lot.

Share this post


Link to post
Share on other sites

Just installed the CRJ Pro, and I'm running into the same issue.  This matches the behavior of the original CRJ but no other aircraft in my hangar.  I ripped my hair out trying to isolate it on the original.  For me, displays have no impact unfortunately. 

 

(i7 7700k @ 4.8, 1080 Ti with utilization only ~50-70%, Win 10 P3D v4.5 and default shaders; use ActiveSky & ChasePlane but disabling those has no effect.)

Share this post


Link to post
Share on other sites

I'm having the same problem. Lots of stuttering in during ground movement. Other aircraft like the QW 787 with a lot of video displays and the QW RJ85 run smooth as silk using the same scenery and graphic settings. Is there a way to adjust the display refresh rate in the .cfg?

 

Nvidia RTX 2080 with 8GB GDDR6
Intel Eight Core i-9 9900KF @ 5.0GHz
Intel Z390 Chipset Motherboard
32 Gigabytes of DDR-4 3600MHz RAM (supports up to 64GB)
2 Terabyte Solid State Hard Drive at 1800MB/s (SSD)

Share this post


Link to post
Share on other sites

No, there's no configuration setting for this. After some experimenting I'm pretty sure now that the problem isn't related to the display refresh rate.

Share this post


Link to post
Share on other sites

+... This makes it what?  7, 8 out of 1000's with this problem. Come on Aerosoft! How about a little more quality customer support for all of us LOYAL Customers throughout the years (I'm Talking big $$$). We deserve a more positive support explanation and outcome than ..."As we have three customers who see this issue and no other reports we have to conclude it is something specific on those three machines"...Maybe the other 1000's of customers, who you claim must not experience this issue, just couldn't be bothered reporting it because they lack confidence that anything can or will be done about it. It is frankly, very frustrating and disappointing that the performance of this product is consistently poor during most stages of a flight in terms of FPS & stuttering.

 

There, I got that off my chest.  have a good one.

Share this post


Link to post
Share on other sites

I'm still working to figure out what exactly causes the problem. The fact that it doesn't occur here, doesn't make it easier. It is being worked on and there will be a solution eventually.

Share this post


Link to post
Share on other sites

i7-10700 (upgraded from i7-7700) fixed the isssue. Now there are almost no stutters and framerate is always between 40 and 60.

Share this post


Link to post
Share on other sites

My FPS temporarily drops shortly after takeoff, then goes back up. This is presumably because the sim is loading distant scenery. Most of my cores go up to 100% which coincides with the drop in FPS. Perhaps the CRJ is just that resource intensive that simultaneous sim functions overload the CPU, which causes the drop?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...