Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content

Archived

This topic is now archived and is closed to further replies.

maydayc

LUA Script zum anpassen des LOD per Mausklick

Recommended Posts

Neue Version 0.7.

Anbei die neue Version 0.7 des FPS_LOD Scripts.

Neuerung:

- Es gibt jetzt einen HDR Regler unter der LOD Anzeige. Beim Click mit der Maus auf diesen Regler wird der HDR antialiasing (Kantenglättung) Wert verändert.

Die 4 Werte sind (beginnend von ganz Links): FXAA - 2xSSAA+FXAA - 4xSSAA - 4xSSAA+FXAA

Vorteil:

1. "on the fly" können noch einmal FPS gewonnen werden ohne die LOD zu verändern.

2. Auf Flughäfen mit vielen Objekten in der Nähe bringt die Veränderung der Kantenglättung mehr als die LOD zu vergößern

3. Den HDR Wert zu ändern im Flug ist einfacher als das im Menü Setting die Änderungen zu machen.

Installation wie immer im FlyWithLUA\Scripts Verzeichnis und am besten die alte Version sicheren (z.B. umbenennen in xxxxxx.lu_).

Nicht vergessen!!!!:

a.) Falls Joystick Buttons im alten Script definiert wurden ... diese Werte auch im neue Script eintragen. Die Stellen haben sich nicht verändert

b.) Ggf. den Standard Wert für die LOD (bei mir ist der Default im Script 1.2) anpassen.

Viel Spaß beim ausprobieren !!!!

P.S: Danke Kaito164 für den Beta Test :)

FPS_LOD_0_7.zip

Share this post


Link to post
Share on other sites

Hallo Mayor, vielen dank für das neue fps_lod_07. habe es sofort probiert und es arbeitet super. leider kann ich es für meinen alten rechner nicht verwenden, da ich HDR nicht verwenden kann, habe denn nur noch eine dia-show. wäre es möglich, dein neues fps_lod so zu modifizieren, das das screen antialising im lua script "on the fly" verändert werden könnte?. ich verwende dein fps 0.5 und möchte es nie mehr missen. noch mals vielen Dank

Share this post


Link to post
Share on other sites

P.S: Danke Kaito164 für den Beta Test :)

Immer wieder gerne das Tool ist Klasse und ich möchte es nicht mehr missen.

Egal wo ich war ich konnte schnell den Wert anpassen und hatte immer mindestens 25 fps beim Start und Anflug.

Ich bin schon auf das nächste Update gespannt ;)

PS: Nicht wundern wegen die vielen Werten die eingeblendet sind, benutze Sie zum Test meines Home-Cockpit was ich am Bauen bin. B)

Share this post


Link to post
Share on other sites

Hilfe, Ich stehe hier aufm Schlauch.

Weil das FPS_LOD Script bei der ersten Installation nicht funzte, habe ich das zum Anlass genommen mein X-Plane endlich von 10.25 auf 10.32 upzudaten.

Aber das PlugIn wird immer noch nicht erkannt. Da fiel mir das mit dem DataRefsEditor ein, wo man die Wolkenschatten wieder herstellen kann.

http://forum.aerosoft.com/index.php?/topic/78273-der-datarefseditor-dre-im-x-plane-10/ Der wird auch erkannt und funktioniert.

Ich habe auch andere Ordnerstukturen wie die in deiner Anleitung im ersten Post ("\X-Plane 10\Resources\plugins\FlyWithLua\Scripts") versucht, aber nix zu machen.

Habe ich da einfach was übersehen oder fehlt da noch etwas. Eine Anleitung in der Zip wäre beim Nächsten Update ganz nett.

Danke & Gruss, Meik

Share this post


Link to post
Share on other sites

Ja Heureka, Asche auf mein Haupt - jetz geht es! :dumb_me_s:

Danke für den Tip :bow_down2_s:

Mal eine Frage am Rande an maydayc.

Wäre es möglich so ein Script auch für die Bodentexturauflösung zu schreiben? Oder gibt es da schon etwas von anderen Quellen?

X-Plane verringert Diese zwar auch in Abhängigkeit der Entfernung aber da ist bestimmt auch noch "Luft" für mehr FPS.

Genauso mit zunehmender Höhe. oberhalb von 800 - 1000m üGND macht ZL17 nicht mehr viel Unterschied zu ZL16.

Mit den Knöpfen auf dem Bildschirm wirklich einfach zu Handhaben. :clap_s:

Gruss, Meik

Share this post


Link to post
Share on other sites

Wäre es möglich so ein Script auch für die Bodentexturauflösung zu schreiben? Oder gibt es da schon etwas von anderen Quellen?

X-Plane verringert Diese zwar auch in Abhängigkeit der Entfernung aber da ist bestimmt auch noch "Luft" für mehr FPS.

Hmmmm .... das wird glaube ich nicht gehen. Die Aufösung der Bodentexturen lässt sich nicht dynamisch verändern.

Die sind statisch und werden jeweils neu geladen ...

Share this post


Link to post
Share on other sites

Hallo Freunde!

Angeregt durch "maydayc"s Script hab ich mal ein wenig experimentiert und was Neues geschrieben.

Dieses Script ändert nur den LOD im Bereich zwischen 0.0 und 9.9 und zeigt die fps an. Das macht es aber auf Wunsch auch automatisch :-)

Für das Umschalten auto/manuell-Mode und das Ändern des LOD können in X-Plane Buttons oder Tasten definiert werden.

@ maydayc: Ich kenn mich mit den anderen datarefs zu wenig aus. Wenn Du mir ein wenig hilfst, können wir das ev. auch noch integrieren.

Installation:

  • Wie gehabt, "FlyWithLUA" installieren.
  • Dieses Script in den Ordner "Resources/Plugins/FlyWitchLUA/Scripts" kopieren (das Script von maydayc bitte umbenennen auf z.B.: "xxx.lu_" oder in den "Scripts (disabled)" Ordner von FlyWithLUA verschieben.
  • Script mit Texteditor öffnen, Anleitung lesen, Werte konfigurieren.
  • X-Plane starten oder die LUA-Scripts neu laden (wie, steht in der Anleitung).

Ich freu mich über Rückmeldungen, wie es bei Euch funktioniert, meine Testflüge mit GAs, HeavyMetals und Helis waren recht ansprechend.

vlG

Gerhard

Auto_LOD 1.0.zip

Share this post


Link to post
Share on other sites

Hallo Gerhard, habe sofort dein Auto_lod 1.0 ausprobiert.. Schaut ja viel versprechend aus. leider ist der Lod Startwert bei bei 2.5. Ein Startwert von 0.5 wäre am besten für meinen Rechner. Stelle ich mit dem Mausrad eine Wert von 0.5 ein, habe ich ca. 35 FPS. dieser wert hält sich auch lange. gehen die FPS zurück, wird der LOD-Wert erhöht un bleibt dann oben, obwohl die FPS wieder bei ca. 30 sind. die automatische anpassung nach unten scheint noch nicht richtig zu funktionieren. Aber ich habe ja auch einen alten Rechner.. Villeicht liegt es daran.

Habe die Werte auf 22 min und 32 max geändert, nun funktioniert die automatische lod anpassung

Share this post


Link to post
Share on other sites

Steht ja in der Anleitung: muss individuell an den Rechner, Grafikkarte, installierte Szenerien, ..... angepasst werden.

Und ich setze keinen "Startwert". Ich korrigiere ihn nur, wenn er nach dem Laden nicht zwischen 0 und 9.9 ist :-)

Eckwerte:

Mind.-FPS: 20 (darunter krieg ich den Wert nicht)

Max.-FPS: mindestens um 10 höher als Mind.-FPS (sonst kommt es trotz Zeitverzögerung zum "Pumpen" der Werte)

Nicht passende Werte passt das Script an diese Werte an.

Share this post


Link to post
Share on other sites

Hallo Gerhard, dein Script gefällt mir. Die Idee mit dem Timer finde ich gut. :)

Share this post


Link to post
Share on other sites

Moin zusammen,

das Thema veränderbare Boden-Texturauflösung hat mir keine Ruhe gelassen. Also ab in den Flieger, DataRefEditor aufgerufen und gesuch, gesucht, gesucht...

Und gaaaaanz unten bei "Show Art Controls" gibt es 3 Zeilen für Texturen die standartmässig so aussehen:

tex/distance_pad=0.000000
tex/ortho_boost_factor=1.000000
tex/preload_dist=56325.000000

Ich habe zu Erst mit der Oberen und der Unteren Einstellung gespielt. Aber ohne sichtbare Veränderung. Da tut sich wohl nur etwas, wenn eine Kachel komplett neu geladen wird.

Aber die mittlere Einstellung "tex/ortho_boost_factor=1.000000" hat es in sich. Hier ändert sich in Abhängigkeit der Entfernung tatsächlich die Auflösung (0.000000 - 1.000000).

Allerdings mit einigen Sekunden Verspätung. In der Nahsicht, wie auf den Screenshots, macht das nur ein Paar FPS aus. Aber in der Weite schon mehr. Gerade bei ZL17 oder mehr.

Vielleicht klappt es ja doch noch mit dem passenden Script dazu. :)

post-81044-0-23743700-1423045282_thumb.j

Share this post


Link to post
Share on other sites

Sorry klappt irgendwie nicht it 4 grossen Screenshots untereinander. Desswegen habe ich alle zusammengefügt.

Aber man kan es so schon erkennen. Die Werte: links-oben 0.000000, rechts oben 0.200000, links unten 0.300000

und rechts unten 0.500000

Share this post


Link to post
Share on other sites

Das AUTO_LOD Script gefällt mir sehr gut. Im File steht das min und max FPS mindestens 10fps auseinander liegen müssen. Könnte man das etwas vermindern... sagen wir mal 5 oder 8 fps auseinander?!

Share this post


Link to post
Share on other sites

Das AUTO_LOD Script gefällt mir sehr gut. Im File steht das min und max FPS mindestens 10fps auseinander liegen müssen. Könnte man das etwas vermindern... sagen wir mal 5 oder 8 fps auseinander?!

Kannst du machen, musst dazu weiter unten im Script den Wert dann aber auch anpassen.

Schafft aber nicht wirklich was weg, weil die Darstellung dann sehr sichtbar pumpt, weil das Script den LOD-Wert ständig anpasst.

Sieht blöd aus, wenn in der näheren Darstellung die Häuser mal da sind und in der nächsten halben Sekunde weg, nur um in der nächsten wieder zu erscheinen. ;)

if LOD_fps_max <= LOD_fps_min + 5 then LOD_fps_max = LOD_fps_min + 5 end -- set max-value

Share this post


Link to post
Share on other sites

Kannst du machen, musst dazu weiter unten im Script den Wert dann aber auch anpassen.

Schafft aber nicht wirklich was weg, weil die Darstellung dann sehr sichtbar pumpt, weil das Script den LOD-Wert ständig anpasst.

Sieht blöd aus, wenn in der näheren Darstellung die Häuser mal da sind und in der nächsten halben Sekunde weg, nur um in der nächsten wieder zu erscheinen. ;)

if LOD_fps_max <= LOD_fps_min + 5 then LOD_fps_max = LOD_fps_min + 5 end -- set max-value

Danke. Dachte mir schon das es noch diese zwei Zeilen sind... Habe es mal kurz ausprobiert mit nur 5fps Abstands und zwischen 25-30 im Ziel auf meinem Rechner.. Funktioniert sehr gut muss ich sagen und da ich bei 25fps noch bei LOD0.4 bin (guter PC hier), sind die Darstellungsschwankungen kaum zu erkennen. Nur bei sehr kleinen Objekten oder ganz ganz in der Ferne.

Gefällt mir sehr sehr gut. Danke euch für dieses tolle Extrafeature...

Share this post


Link to post
Share on other sites

habe dis werte für Lod_min auf 20 und für Lod_max auf 25 gesetzt und wie oben angeführt : auf auf 5 gesetzt. Ich finde, für meinen alten Rechner funktioniert bis jetzt diese LOD Anpassung super. Also nochmals vielen Dank für dieses Lua-script

Share this post


Link to post
Share on other sites

Seltsam, ich habe jetzt schon einige Einstellungsversuche bei dem AUTO_LOD-Script gemacht, aber irgendwie ist die Grundperformanz deutlich schlechter als bei maydacyc´s Version.

Z.B bei mir über Köln: Entweder die Automatik schafft eine FPS von mindetens 15-20, aber mit kaum noch Gebäuden. Oder ich muss von Hand die LOD soweit verstellen,

dass ich bei 15 FPS fast nur flache Landschaft habe. Bei maydayc´s FPS_LOD_0_7 sehe ich bei einer LOD von 1.2 weit über den Stadtrand hinaus noch Gebäude bei gerade noch 15 FPS

Share this post


Link to post
Share on other sites

Vielen Dank Gerhard für dieses tolle Script!

Gerne, macht ja Spass!

Seltsam, ich habe jetzt schon einige Einstellungsversuche bei dem AUTO_LOD-Script gemacht, aber irgendwie ist die Grundperformanz deutlich schlechter als bei maydacyc´s Version.

Z.B bei mir über Köln: Entweder die Automatik schafft eine FPS von mindetens 15-20, aber mit kaum noch Gebäuden. Oder ich muss von Hand die LOD soweit verstellen,

dass ich bei 15 FPS fast nur flache Landschaft habe. Bei maydayc´s FPS_LOD_0_7 sehe ich bei einer LOD von 1.2 weit über den Stadtrand hinaus noch Gebäude bei gerade noch 15 FPS

Klar, das Script muss ja bei jedem Frame die Anzeige neu zeichnen und zwischendurch ein wenig rechnen. Kostet natürlich Performance.

Übrigens: Hab eine neue version (1.2) auf http://www.x-plane.at/drupal/node/385 gestellt. Einige kleinere Bugfixes und:

jetzt versucht das Script die FPS nahe dem FPS_min-Wert zu halten, so dass die maximal mögliche Anzahl der Objeke angezeigt werden können. Bis jetzt erfolgte keine Anpassung mehr, wenn die FPS zwischen FPS_min und FPS_max waren.

Bitte testen. Freu mich schon auf Eure Kritik.

Gerhard

Share this post


Link to post
Share on other sites

Hallo! Tolle idee das Script!

Ich habe aber noch einen Verbesserungsvorschlag:

bitte im auto-Modus

sim/time/paused

berücksichtigen. Im Moment passiert nämlich, wenn X-Plane pausiert wird, "FPS: inf" und LOD geht dementsprechend auf 0. Wenn die Pause beendet wird dauert es dann eine Weile bis der LOD wieder auf einen vernünftigen Wert ansteigt.

Seltsamer Nebeneffekt: nach der Pause scheint der MIN/MAX Wert nicht mehr zu gelten, die FPS schwankt nun dauernd zwischen 30 und ca. 5. Ich muß dann das Script neu laden.

Grüße

Jens

Share this post


Link to post
Share on other sites

Ja, das mit der Pause wollte ich auch noch anmerken. Im Pausen-Modus reagiert X-Plane verzögert auf Eingaben, das Script stellt alles auf max und die FPS gehen in den einstelligen Bereich.

Noch was Anderes: Die Empfehlung "Flying fast and high: use lower values for "LOD_fps_min" (> 20) and "LOD_fps_max" (e.g. 30)" funktioniert im ländlichen Bereich ganz gut und pendelt schön ein.

Wobei die eigentlich besser ist für langsamen Tiefflug.Bei "Flying low and slow (e.g. Heli): use higher values for "LOD_fps_min" (e.g. 30) and "LOD_fps_max" (e.g. 40)" werden zu wenig Gebäude geladen

Aber über grossen Städten fängt der Auto-Mode an zu "Pumpen" Die Gebäude verschwinden langsam und peng - ist wieder alles da und es geht nochmal von vorn los.

Ich habe auch versucht die Zeilen "if LOD_fps_min <= 20 then LOD_fps_min = 20 end -- set min-value" & "if LOD_fps_max <= LOD_fps_min + 10 then LOD_fps_max = LOD_fps_min + 10 end -- set max-value" anzupassen aber nix hilft. Als langsamer VFR-Flieger reichen mir 20-25 FPS und über grossen Städten ist die absolute Schmerzgrenze bei 15 FPS damit ich noch genügend Gebäude sehe.

Aber unter 20 kann ich den Auto-Mode nicht einstellen, dann wird es noch schlimmer. Der Manuell-Mode klappt aber ganz gut.

Gruss, Meik

Share this post


Link to post
Share on other sites

Habe gerade noch eine andere Merkwürdigkeit festgestellt: Bin im mittleren Westen mit HDMesh und w2xp unterwegs, tolles Wetter, sehr weite Sicht. Selbst in menschenleeren Gebieten (kaum Objekte, Bäume, Straßen) bleiben die FPS bei 30. Nun hatte ich im Script MIN=20 und MAX=30 definiert. Führt dazu daß das LOD immer mehr reduziert bis sogar die paar Flughafen-Häuschen verschwunden waren obwohl keine Verbesserung der FPS eintritt. die FPS waren mit LOD 2 genau so bei 30 wie mit LOD 9

Weiß aber auch nicht wie darauf reagiert werden könnte. Man müßte wohl schauen ob die verringerung des LOD was bringt und wenn nicht den Wert nicht mehr verändern.

Grüße

Jens

Share this post


Link to post
Share on other sites

×
×
  • Create New...