Jump to content

Solution for Dark Cockpits after Restart


Recommended Posts

On 3/20/2021 at 5:35 AM, Hans Hartmann said:

Uwe sent me his old Simconnect.cfg and I got the problem already on the first start, so it really seems to be the cause!


I compared the Simconnect.cfg with the documentation in the SDK and found that it is slightly malformed. Changing [Simconnect] to [Simconnect.0] fixes the problem without having to delete the file. This allows you to use both, the CRJ and Kinetic Assistant.




I'm going to wait for a few confirmations that the problem is really gone and then move this into the FAQ section.

SimConnect.cfg 60 B · 9 downloads


EDIT: I just talked to the developer of Kinetic Assistant and he said that the latest version doesn't use a SimConnect.cfg anymore. So, the better solution is to get an update from here: https://msfs.touching.cloud/mods/kinetic-assistant




What if I dont have Kinetic Assistant installed?  Should the simconnect be left at .1 or .0

  • Upvote 1
Link to comment
Share on other sites

  • Mathijs Kok unpinned this topic
  • 1 month later...
On 20.3.2021 at 17:22, vale_decano sagte:

And what happen if i havent nothing??

I also have no simconnect.cfg file in my document folder. But I also have the issue with the dark cockpit. My guess is, that I caused the issue when setting EFB to start with "ready for taxi". After the next load and starting the 550 on a parking position, the cockpit stayed dark. Then I changed to the 700 and the EFB startup state was set to "ready for startup". The 700 worked so far. Then I changed again to the 550 and after loading Flightsimulator crashed. After reloading all the same as before 550 works again.
Question to the developers: where is the startup setting of the EFB stored?

Link to comment
Share on other sites

  • 2 weeks later...

Suddenly, both CRJ 550 and 700 are dark. Battery on, EFB is dark and cannot be turned on. 

I don't have simconnect.cfg file.


Any help will be appreciated. 



  • Like 1
Link to comment
Share on other sites

Same problem here, Screens are dark, Switches are moving but nothing happens.

I dont own Kinetic Assistant. Also reinstalling the CRJ does not solve the issue.

Do I need to put the SimConnect.cfg somewhere, and if so - where?



Link to comment
Share on other sites

I experienced this error for the first time.
I first started the sim, made my settings on the CRJ, but noticed that I had switched on the "All Player Mode". 
However, the wrong aircraft were displayed for online flights (VATSIM).


So I switched back to the "Welcome" screen, made the change and reset the flight.
By default it should start in "Tournaround Mode", but this time the instruments stayed dark, only the backlight of the buttons, switches was on.
No further reaction to switches or buttons.


Shutting down and restarting the sim did not work.
Shutting down the PC and restarting the sim did not work either.


As a last idea, I selected another livery variant of the CRJ7 in the SDK menu - Windows - Aircraft Selector, and suddenly everything worked as usual again.


Note: I did not find any simconnect.cfg via scan.


Link to comment
Share on other sites

On 25.5.2021 at 20:23, Secondator sagte:

Have you tried reseting the aircraft as per the instructions provided here: 



I can confirm this fixes the bug.

Also I can reproduces this bug when getting a CTD or ALT-F4 out the game - maybe this helps.

Link to comment
Share on other sites

  • Deputy Sheriffs

Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.

Link to comment
Share on other sites

  • Herman locked this topic
This topic is now closed to further replies.

  • Create New...