If you want a Honeycomb Alpha for Christma you better order fast because we are quickly running out of stock!

Jump to content

Recommended Posts

7 hours ago, snoopy531 said:

habe in JOSM ein Patchfile erzeugt (die Höhe für ein Gebäude hinzugefügt). Dieses File habe ich in Ortho (v1.30) unter "...\Patches\+40+000\+48+007\test.patch.osm" gespeichert. Soll ein Patch für die Kachel +48+007 sein. In Ortho müsste es doch im Schritt 1, also Assemble Vector Data, die Verarbeitung des Patches anzeigen. Da tut sich aber nix. Ist das Patchfile an der richtigen Stelle in Ortho v1.30 abgelegt?

 

Der Pfad sollte stimmen.

Evt. mal Verbosity erhöhen.

Und ansten das Patch-File mal hier reinhängen.

Share this post


Link to post

Bei mir gings jedenfalls erst als ich die OSM Daten gelöscht hatte und dann neu eingelesen hatte. 

 

Share this post


Link to post

Hallo zusammen,

 

ich habe die Gebäude nur zum Testen erhöht. Wollte nur sehen, ob überhaupt ein Patchfile eingelesen wird. Unabhängig von der Sinnhaftigkeit. habe beim IKEA mal die Gebäudehöhe auf 20m gesetzt. Wie gesagt, nur zum Test der Patchfunktion. Der Pfad ist aber so korrekt, muss also erst die übergeordnete Region und dann die eigentliche Kachel als Ordner angelegt werden?

Im Video zum Patchfile (https://www.youtube.com/watch?v=6x7GpOHzxKA) wurden auch keine OSM-Daten gelöscht, nur das Patchfile eingelesen.

 

Anbei das Patchfile. Ist alles unverändert, nur der IKEA eben "etwas" höher ;-)

 

Grüße Andi

Test.Patch.osm

Share this post


Link to post

mit dem Patchfile wirst du nicht viel anfangen können, du hast ja im wahrsten Sinne des Wortes nur die Gebäudehöhe bearbeitet wenn ich das richtig sehe. (height=20)

 

Damit kann Ortho4XP aber nix anfangen. Hier gehts nur um Gelände. Du müsstest also wenn du beim IKEA was anheben willst ein eigenes Polygon zeichnen und dem die Höhe übergeben (altitude=*** (in Metern))

Das nächste Problem ist das du kein Patchfile erstellt hast sondern einen OSM Kartenausschnitt.

Für ein Patchfile lade die entsprechenden Daten in JOSM, wähle ein Hintergrundbild aus, erstelle eine neue Ebene und lösche die Ebene mit den Kartendaten.

Dann gehst du in die neu erstelle Ebene, baust dein Polygon mit der Höhenangabe (altitude=). Diese Ebene dann speichern als Patchfile.

 

Die Höhe aber über NN - mit 20 Meter dürfte der IKEA in Freiburg sonst in einem tiefen Loch verschwinden 🙂

 

Share this post


Link to post

Hallo Frithjof,

 

vor lauter Videoschauen das mit der neuen Ebene und dem Polygon völlig durcheinander gebracht. Danke für deine Erklärung: Werde das auf diese Art versuchen, um dann "sinnvollere" Dinge auf diese Art patchen zu können.

 

Grüße

Andi

Share this post


Link to post

Hallo Frithjof,

 

es geht immer noch nicht. Mal abgesehen davon, ob ich später was in X-Plane sehen würde, zumindest das Patch-File sollte in Ortho eingelesen werden. Habe mir das Video nochmal angeschaut und meiner Meinung nach alles genauso gemacht. Aber im Step 1 wird in Ortho kein Patch-File dazu geladen, so wie es im Video erkennbar ist. Verzweifle langsam...

 

Noch Ideen?

 

Anbei das File.

EDTF.patch.osm

Share this post


Link to post

Auf alle Fälle stehen da schon wieder zu viele Sachen drin. building, height, und levels sind  Tags mit denen Ortho4xp nix anfangen kann. 

Aber die Datei wird ausführt, direkt vor dem auto patching der 30 runways.

Share this post


Link to post

Hallo Frithjof,

ja ich weiß, dass da Zuviel für Ortho drin war. Aber auch mit der abgespeckten (EDTF2.patch.osm) tut sich bei mir anscheinend nichts. Oder wie sieht bei dir der Ausgabetext zu Step 1 aus?

 

In welches Verzeichnis hast du mein Patch-File bei dir gelegt, dass es eingelesen wird? Kann doch nicht an meinem Ortho-Programm liegen.

Ortho1.PNG

Ortho2.PNG

EDTF2.patch.osm

Share this post


Link to post

Das Patchfile liegt unter Ortho4Xp/Patches/+40+000/+48+007/

 

 

Share this post


Link to post

Zwischenablage02.jpg

Interessanterweise scheint er aber nun nicht mehr den Platz selbst zu patchen denn es werden nur 30 Runways automatisch gepatcht.

Share this post


Link to post

Aber immerhin liest er bei dir die Datei ein. Bei mir kommt ja gar nicht erst der Hinweis "Patching EDTF.patch.osm". Gibt es ein Update von Ortho, sonst werf ich das nun in die Tonne. Kann doch nicht sein, dass bei dir das File eingelesen wird und bei mir nicht. Habe die exakt selbe Ordnerstruktur.

Share this post


Link to post

Hallo Frithjof,

manches muss man nicht verstehen. Hab Ortho runtergeworfen und neu installiert: läuft! Patched einwandfrei den IKEA. Klar, nicht ganz so "sinnvoll", aber es ging ja nur um das Prinzip, ob und wie ein Patchfile eingelesen wird.

 

Danke für deine Geduld und Hilfe. Anbei das "Ergebnis" ;-)

b738 - 2019-08-12 22.16.43.png

Share this post


Link to post

Und nun hab ich ne Frage: In Ortho4XP 1.20 wurden Plätze ja geflattet es sei denn man hat per "do not flatten this" den Airport ausgespart. Gibts in Ortho4XP 1.30 eine Funktion die das flatten für bestimmte Plätze einschaltet? Ein Flatten per apt.dat bringt nix da dort zuviel geflattet wird!

 

 

Share this post


Link to post
11 minutes ago, Frithjof said:

Gibts in Ortho4XP 1.30 eine Funktion die das flatten für bestimmte Plätze einschaltet?

 

Nein, eine solche Funktion gibt es leider nicht. Der einzige Weg führt über eine entsprechende Modifikation von ./OSM_data/*/*_airports.osm.bz2 in JOSM.

 

Was du suchst ist aber vermutlich sowas wie bflat.

Share this post


Link to post

Na ja, ich behelf mir dann weiterhin mit OSM Patches...

Share this post


Link to post

Hallo,

ich habe ein Problem beim starten von X-Plane nachdem ich eine Kachel in Ortho4XP erstellt habe, dieses lautet wie folgt:

Bei mir kommt beim starten von X-Plane eine Fehlermeldung, welche sagt: Could not locate Image file ....

Ich habe keinen Plan was ich jetzt machen soll.

Kann mir wer von euch bitte helfen!

 

Danke

Share this post


Link to post

Du hast vermutlich entweder vergessen die DDS Texturen zu erstellen (skip_converts und skip_downloads sollten beide auf "False" stehen) oder die Konvertierung nach DDS hat aus anderen Gründen nicht funktioniert (dazu gibt's auf x-plane.org zahlreiche Diskussionen mit Hilfestellungen, u.a. hier)

Share this post


Link to post

Hallo,

 

ich habe mir heute Ortho4XP 1.30 geholt und auch schon meine erste "Kachel" gebaut. Es ist alles gut gelaufen. Leider habe ich an der Küstenline etwas weisse Farbe beim Übergang in das Wasser. Ich weiß, dass ich - um das zu minimieren - die "width" in den Orto4XP-Einstellungen nicht auf 100 lassen darf, aber hier beginnt mein Problem: Wenn ich die Weite auf z.B. 25 ändere und weiterhin noch den Pfad für die Speicherung der Tiles angebe, zeigt Ortho4XP nach einem Neustart wieder den Standardwert (100)  und der Pfad zum Verzeichnis ist leer , obwohl ich nach den Änderungen "Apply" gedrückt hatte. Wisst Ihr, woran das liegen könnte?

 

Viele Grüße

Jan

Share this post


Link to post

"Write Tile Cfg" bzw. "Read Tile Cfg" schreibt/liest die Konfig in/aus das/dem Kachel-Verzeichnis.

 

Weiss nicht, welchen "Pfad zum Verzeichnis" du meinst. Die Einstellungen im Hauptfenster werden beim Schliessen von Ortho4XP in die Datei .last_gui_params.txt geschrieben und beim nächsten Start ausgelesen.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...