Jump to content
Mathijs Kok

Framerate issues, revisited again

Recommended Posts

I've desactivated the "Force Ecam Software Rendering" button and my FPS increased (4 fps more than before, for example on Madeira Scenery from 18 to 22fps).With a good graphic card it seems a good idea to switch off this button.

Correct. The option is enabled by default as its fail safe.

Share this post


Link to post
Share on other sites

I have the latest version installed of the 318 and 319

I have reduced the number of waypoints etc to 50, I have enabled the config line to switch off the radar, yet I still see 10 FPS drops on a regualr basis.

with my FSX settings I can comfortably maintain 28-30 FPS even with complex addons.

This 318/319 regualry knocks my FPS down to 16-19 with seemingly no obvious reason.

Its dissapointing. The last version of the Airbus Extended (320/321) ran much better. Why?

Share this post


Link to post
Share on other sites

9FPS on average IN CRUISE. Terrible. I'm going to try this fix, but no other add on does this to my setup, so I know it's not on my end. Here goes nothing. I'll update.

With ASN I get between 3 and 10fps, without it I get 30, which is what I have FSX locked to! This is crazy. Does anyone have any specific recommendations for use with active sky?

Share this post


Link to post
Share on other sites

With ASN I get between 3 and 10fps, without it I get 30, which is what I have FSX locked to! This is crazy. Does anyone have any specific recommendations for use with active sky?

- Follow the suggestions in the 1st post in this topic

- Regarding ASN read this: http://forum.aerosoft.com/index.php?/topic/86844-change-weather-scanning-options-solved/

Share this post


Link to post
Share on other sites

9FPS on average IN CRUISE. Terrible. I'm going to try this fix, but no other add on does this to my setup, so I know it's not on my end. Here goes nothing. I'll update.

And you have read the starting post of this topic?

Share this post


Link to post
Share on other sites

If you're using ASN uncheck the Repeating Overcast Texture Pattern Fix, under Visual Fixes in Settings. I had similar problems (10fps in cruise EGCC-EGLL at FL190), unchecking that option solved it for me.

This is referenced in Mathijs' opening post of course, a good place to start usually.

  • Upvote 1

Share this post


Link to post
Share on other sites

I dont't use ASN, and I am still getting bad FPS... jumping around from 5-35. With the PMDG 737/777for exsample no problems whatsoever. I tryed the "fix" for not scanning the weather, but it didnt have any effect. PC Specs, AMD BE 965 @ 3,5 GhZ, 8Gigs, GTX 660 TI 2 GB.

Share this post


Link to post
Share on other sites

Will try Airbus on clear install of FSX SE. it was advised that sim reinstall could help.

Be advised, that FSX Steam is currently not officialy supported!

Share this post


Link to post
Share on other sites

I dont't use ASN, and I am still getting bad FPS... jumping around from 5-35. With the PMDG 737/777for exsample no problems whatsoever. I tryed the "fix" for not scanning the weather, but it didnt have any effect. PC Specs, AMD BE 965 @ 3,5 GhZ, 8Gigs, GTX 660 TI 2 GB.

That's surprising. Although the CPU is a bad one for FSX I would have expected far better FPS. As your is so low it is certain that there is something non standard in your FSX that is causing the problem. The issue is of course finding out what.

Share this post


Link to post
Share on other sites

My last version of the airbus 319 (v1.20) also run much better than the v1.21, I have to say framerates were never an issue. With v1.21 (A320 and A319) I have good framerates in FSX native weather, with ASN SP1 and FSGRW it is between 15 and 20 fps without weather radar turned on and at ca. 9 fps with weather radar turned on. My spec are Win 7, i5-4670K @ 4,0 Ghz, RAM 16GB, GTX 770 OC 4096 MB, Flusi auf separater Samsung 250GB SSD. Thus I have no framerate issues with other addons like PMDG under the same conditions.

I tried the following tips without sucess:

What can you do to increase FPS (when it is abnormally low)?

  1. We find that a lot of problems are caused by silly tweaks to FSX.cfg. We advise only the highmem tweak. All other tweaks might have an effect but will have side effects!
  2. In our experience almost all means of limiting frame-rates are counterproductive. The one inside FSX is just silly and the external ones all seem to reduce possible FSP with 25 to 50%. Try without and you could be seriously surprised.
  3. Almost all people who have problems use ASN. Now that is a super weather tool but it can create weather patterns that are very very complex and that are hard to scan. Now this is NOT a incompatibility between ASN and our bus. We do not read any data from ASN as we scan the actual weather in FSX (that is why it works with any weather tool or even default FSX weather). Some ASN users have reported that switching off the "repeating overcast pattern fix" in ASN's visual fixes tab helps.
  4. On a few systems the Weather Radar has shown to cause severe drop in frame rates combined with some advanced settings in weather tools. It is now possible to edit some functions via the AB_ND_GDI.ini (to be found in MyDocuments\Aerosoft\Airbus. The options are explained in the comments in that file. To activate the options remove the red // character

    [WXRadar]

    //WXBackgroundScan=2
    //Remark: Some WX data are normally required to be scanned in background even when WX Radar is switched off. Due to performance reasons on some customersystems currently the user can select between following background scanning modes: 0 = COMPLETE OFF best frame rates), 1 = LIMITED SCAN, 2 = FULL SCAN (normal status). As long as WX Radar is switched on, this parameter has no affect! This parameter is allowed to be changed at runtime (just change this parameter in INI file and safe it)
  5. If you got a modern graphics card, make sure the software ECAM rendering is off. Note that almost no laptop is able to handle this in hardware!
    http://forum.aerosoft.com/uploads/monthly_11_2014/post-43-0-06453800-1416225565.png

I would be glad and thankful if you have any further suggestions?

Regards,

Rupert

Share this post


Link to post
Share on other sites

We really have no further advise and have never been able to find any difference in FPS between 1.20 and later versions. As far as we can see there is nothing that could be causing additional load.

Are you sure you did a clean install of the later versions?

Share this post


Link to post
Share on other sites

With ASN I get between 3 and 10fps, without it I get 30, which is what I have FSX locked to! This is crazy. Does anyone have any specific recommendations for use with active sky?

OK so I was the guy that you replied to. I know it's taken me many days to test. Holidays and such.

I'm getting WAY better frames. 30-40 on the ground and even 25-30 in rain/snow. Drops to 15-ish for a split second in some areas.

Much improved. Is this because of the new hotfix? Who knows. I also did some tweeking with my anti-aliasing.

Share this post


Link to post
Share on other sites

Some days ago I did a fresh install of Prepar3d 2.4, including aircrafts such as AXE 318/19 and Captain Sim 777. Initially, the frames on AXE were better than the 777, around 30-40 on air and 20-25 on big airports. Yesterday, I just went for a regular flight, without any new addons, and suddenly, after the automated before start checklist, the frames dropped from 20-25 to 10 and remained that low during the remainder of the flight. I´ve struggled the whole day trying to fix this, but could not. Latelly, I´ve realized that whenever I turned the WX Radar on, the frames would drop dramatically, from 20s to 8 or 9. That was not the cause of the problem though, because even with the radar off, the medium frame rate was still way lower that what I was experiencing just hours before.

Today I´ve re-installed AXE and followed all the tips on this topic (WXbackgroundscan, ECAM, etc). Now the frames are back on the high 20s on airports, and 40s mid-flight, but still with a lot of fluctuation (sometimes it goes from high 30s to mid teens). Still, even with a fresh install, I cannot use the WX radar anymore. Important to say, I´m not using ASN, but Opus. Even without any weather addon, I cannot turn the WX on without experiencing a frame drop to around 8 fps.

Just for comparisons sake, on the CS777, i get a lower, but stable fps of around 15-20 all around, even with WX radar on.

Here´s my config:

Stock i7-4770 @ 3.4Ghz

Geforce GTX 970 4GB DDR5 Gigabyte Gaming

16GB RAM

Addons used: FTX Global, Aerosoft LPPT, EDDL, EDDB, Opus FSX for weather, EZDOK for cameras, FSCaptain.

Appreciate any input! Happy new year everyone!

Share this post


Link to post
Share on other sites

Those fluctuations are not unexpected as there are processes that run periodically. It is hard say why your system is affect so much, we believe it could be related to the simconnect bandwidth but that is not something we have any control over.

Please note the 777 uses a weather radar that does not actually scan the environment so should hardly have any effect on the hardware. In your case however, using Opus, it will not show any weather so it will never have any impact. A comparison therefor is not very valid.

Share this post


Link to post
Share on other sites

Surprisingly, what seemed to help in my case was the fsx registry repair tool (without re-install of the Airbus package but following all the tips given by Mathijs). With weather radar turned off frame rates are quite normal now. When turned on, the frame rate really depends on the depicted weather. In complex weather schemes such as "EDDM 041436Z 25017KT 5000 -SN SCT020 BKN030 M08/M10 Q1027 R88/290095" the frame rate is 9 fps (but weather radar is also showing all green and is of no use thus).Under other conditions it can be normal, in my case locked at 30 fps. So this seems to be the fluctuation Mathijs was pointing at initially.

Share this post


Link to post
Share on other sites

I wish we could find out what changes were done to the registry in this case! But it is a good example on how depending complex add-ons are on Windows being correct!

Share this post


Link to post
Share on other sites

Hallo Mathijs,

everything stated about the performance hit stated in here doesn´t work. I am very dissapointed about not going in any further in research about that. Maybe you can take off but you will never land the bird in a scenery like Mega Amsterdam with ASN and REX 4/SoftClouds. Forget that!

Maybe my system is some kind of different, maybe. But I don´t think so. My system is standard Windows 7 Pro Edition 64bit running on a small network with a notebook. The server with FSX runs on a Core i7 4790K, MSI Gaming 5 MB, Asus GTX 970, Trident Ram 8GB FSB2400. That´s what some would call a high end system! If you read Nick´s Bible...

On my notebook runs ASN. And for me it doesn´t make any differnce to make the radar tweak. Clear weather in FSUIPC neither. Usually my FSX runs easily with 25 to 30 frames, altough, we all know frames doesn´t really count in FSX. It should be smooth and without (OOM), I don´t have them. That´s why I changed to DX10 with all necessary software to make that as much as possible.

I saw the A319 in Mega EDDF (Aerosoft!) starting cold and dark at Gate A16 with round about 20 frames coming up. Normal weather, a few clouds and no rain. Ok. After everthing was prepared for taxing, the frames went down to almost ~11... That is absolutely not acceptable!! Don´t tell me to make a reinstall or anything, because I know how my FSX is configured. Do your homework and find the framekiller if there is one.

The Aerosoft A319 goes into the cellar as long the problem is not solved. And it is not my job as a customer to be your proefkonijn!

So long

Share this post


Link to post
Share on other sites

Hi all!

I had update my Airbus 320/321 to the "new" version.

Initially i thougth trouth the installation some configurations are missconfigured because my FPS on a STANDARD FSX Airport with ASN activated comes down to 10-2....

Just to let you know my hardware:

Intel i7 5820k @4,5 GHZ

G.Skill DDR4 16GB

3 of Samsungs Evo SSDs and FSX is on an 500GB SSD.

GTX 780ti EVGA classified....

So i start my tests and found out that if i deactivte this 2 options in the ASN settings, my FPS stay stable at 35... jippi.

post-99139-0-92251400-1420828704_thumb.p

Probably this helps to somebody.

I am not quite sure what those 2 options do, but I am happier with a stable FPS FSX therefor I let those options off.

post-99139-0-92251400-1420828704_thumb.p

Share this post


Link to post
Share on other sites

So i start my tests and found out that if i deactivte this 2 options in the ASN settings, my FPS stay stable at 35... jippi.

post-99139-0-92251400-1420828704_thumb.p

Probably this helps to somebody.

I am not quite sure what those 2 options do, but I am happier with a stable FPS FSX therefor I let those options off.

http://www.hifitechinc.com/forums/showthread.php?3846-ASN-SP1-Aerosoft-A319-318-fps-problems&p=20465&viewfull=1#post20465

post #30. I prefer to disable radar and keep this ASN option checked

Share this post


Link to post
Share on other sites

Hmm after disabling the WX radar and following all these tips nothing really better here.

Standard A321 is giving me 50FPS with default scenery, while the Aerosoft Airbus is giving me 24FPS with thesame scenery, weather, time, ... I don't have to complain because it is reasonable, but still more than 50% loss.

CPU: I7 Quad Core 2.8GHZ

GPU: Nvidia Geforce GTX 460

RAM: 3x2GB

Share this post


Link to post
Share on other sites

Hi I tested with identical settings (with no 3rd party product) in fsx sp2 with no tweaks

default airbus a321 90 fps

airbus x a321 32 fps

Huge fps drop I didn't calculate but more than %50

AMD FX 8350 4.5 GHz (turbo core)

Gskill cl9 1866MhZ (o.c to 2000 mhz) RAM

gtx 750 ti ftw

asus m5a97 r2.0

ocz 650 watt 80+ psu

Berke Karakın

Share this post


Link to post
Share on other sites

Hi,

My problem was that I could see average framerates at around 25-30 that suddenly (5-6 times per minute) would drop to 2-3, just for a second and then back to 25-30 again. This would occur throughout the whole flight and whenever the low FPS the whole sim would stutter and make it near impossible to land safely.

Yesterday I was browsing through the menus in the sim and found RAAS that came with the Airbus. I disabled RAAS and like magic the framerate stays at 25-30 the whole time.

Maybe this can help someone else.

/Christian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...