Jump to content

Framerate drops


az1228
 Share

Recommended Posts

Hello, you did a very good job. Congrats Team!

 

I've been experiencing annoying framerate drops in two situations starting from 32 fps to 15 fps.

 

Situation A - Starting the Aircraft systems

1) starting from MSFS on active runway with EFB Aircraft Status - Turnaround, where only EFB and EICAS Primary, EICAS Secondary display and CDUs are turned on, I get 39 fps

2) if I switch from EFB Aircraft Status - Ready for Taxi,  PFD and MFD are switched on, framerate drops to 26-28 fps (my fps with  CRJ on ground)

 

Situation B - Managing the CDU

1)starting with 32 fps (fig.1)

2)Adding new route waypoint - ACT LEGS ->  waypoint point typed and selected (fig.4) --> showing the select waypoints menu (fig.5) on this menu the framerate drops to 15/16 with a annoying stutters (fig.2)

3)Only by pushing EXEC button framerate can boost back fps to previously 28 fps. (fig.3)

 

This is my configuration: i7 9700K  4.8Ghz - 32 GB Ram -RTX 2080S White OC- SSD M2 1TB - LG 38" (3680x1600) 21:9 - 144Hz - G-Sync.

 

Your help and suggestions will be much appreciated.

 

Regards,

Francesco

 

Fig1.JPG

Fig2.JPG

Fig3.JPG

fig4.JPG

fig5.JPG

Link to comment
Share on other sites

40 minutes ago, Mathijs Kok said:

I have no explanation for that, we have simply never seen anything like that.

We do have three more customers who reported similar things and will keep an eye on it.

Mathijs,

 

I am experiencing the same issue. What sort of configuration data or logs can I provide the team that would be beneficial to help analyze the problem? Here are my PC specs: i7 8700k 4.8GHz OC, 32GB 3200MHz RAM, RTX 3080 running at 3440x1440p with G-SYNC.

Link to comment
Share on other sites

3 hours ago, Mathijs Kok said:

I have no explanation for that, we have simply never seen anything like that.

We do have three more customers who reported similar things and will keep an eye on it.

Thanks Matijs, if can help there are at least two other situation one when changing the range on MFD at max range and several waypoint and nav aids are concentrated in the center of the sceen. Another one is connected to my previous Situation A.

 

Here attached a video regading the activation of GEN1 and GEN2 in the Electical Power panel in the OVH of course that is connected to the screen that are switched on. 

I tried to change also the Glass Cockpit refresh rate value in graphics tab but nothing better, so that's strange! 

 

Ragards,

Francesco

 

 

 

Link to comment
Share on other sites

  • Deputy Sheriffs

Some fps drop can be expected with the displays turning on and more you are drawing on the displays the worse the effect unfortunately. However in your case the fps drop is rather extreme.

Link to comment
Share on other sites

  • Root Admin

Yeah, but that is more or less what we expect. If you switch on the busses there are many thousands of lines of code that start to work and were dormant before. 

 

While we are not sure why on some systems this is more visible than on others, it seems hard for many people to understand that when you start the virtual computers on the aircraft the load on the system increases. There is nothing we can do about that. Complex code takes resources. On my system (totally clean MSFS) is is about 12%, on your a lot more. No idea why. 

 

That said, we feel people look way too much to FPS. When you do NOT see the fps, do you feel the aircraft less responsive at 28 fps? In our user tests people simply were never able to see any difference between 60 fps and 30 fps.  We do extensive test on that monthly.

Link to comment
Share on other sites

Yeah this is true Mathijs. Having the FPS under constant control is driving people crazy. Agreed that no differences between 60 and 28/30 fps.

 

Nevertheless what caputured my attention was the stutters when using the CDU (with 11/15 fps sim is unplayable) so I've activated developers view.  My system is a dedicates MSFS machine started in August,so no garbages and something that can affect processes, backuground apps .... 

 

Anyway if you need more info don't hesitate. 

 

 

Regards,

Francesco.

Link to comment
Share on other sites

Interestingly I run a 3700x with 32GB RAM @3200 with the old 1070 from my previous system (upgrade on hold because of the insane prices), and in full HD the CRJ performs just like the good old 172 even in complex scenery.

This with a second screen for browser etc and a 3rd touchmonitor for the FMC.

I don't look at any FPS numbers, when it's smooth, it's smooth. Settings are all on the high side.

I feel very sorry for the guys with killer systems, and personally I would be deeply unsatisfied as well, but it's not the addon itself I guess. Drivers, anti-virus, resolution or G-Sync might come into play here.

Link to comment
Share on other sites

I'd like to put my hand up for this issue as well.

Totally get the point that it's a more complicated craft, but I go from about 35 fps to 15 and plenty of stutters. It's just unplayable.

By no means is it a complaint – my system is definitely on the lower end and I fight hard for every frame, but if there's anything you guys could do to improve performance, or provide suggestions I would really appreciate it.

 

I'm completely unaffected by the SU3 issues people are reporting. For the last few months I've been getting stable ~30 frames on everything from FBW A320 to WT CJ4 anywhere in the sim and that's smooth enough for me.

 

At the moment I'm using EDLP Paderborn as a sort of a benchmark. In the same session if I switch from the CRJ to say the A320 my frames go back to normal. 

I wonder if it's to do with displays? My machine is definitely affected by cockpit refresh rates, and I have to keep it on low. I assume the screens here are WASM and not JS hence why perhaps they don't follow the refresh rate setting?

 

Is there a way I can turn on the electrics but switch off the displays totally and see if that helps performance?

 

 

  • Upvote 1
Link to comment
Share on other sites

I am having this same exact issue, major framerate drops, and it seems to be a potential leak occuring within the aircraft... Earlier, I did a stream giving away one of these CRJ's... After being on the ground documenting the correct installation procedure, and throttle calibration and zero weights... Eventually my framerates significantly dropped eventually causing the cockpit of the aircraft to become completely unresponsive... buttons could be pressed switches could be switched, and I would get literally no response, all the glass panels were frozen. After this stream I loaded up at KGYY, and did a cold and dark start up, it flew really well, until I went into the FMS in the air and added a destination airport in the FPLN, the FLPN was empty. As soon as I clicked execute the cockpit froze again, I was able to fly from the outside, but even setting the flaps, their was no physical change to the aircraft. The flight model responded with a full flaps feel... This is truly bizarre as I know of many without these issues, but I am not sure how in depth people are going utilizing the FMS and MCDU. I feel like personally there is a lot of detachment that has occurred with the Aerosoft flight model from the simulator, and I know that is to only improve the experience, and add features that otherwise would not be supported.... 

 

Link to comment
Share on other sites

I have the same issue when editing certain parts of the flight plan. Usually when selecting the approach at the arrival field my FPS will drop to about 1-9fps (usually my fps sits around 35-45 with the plane powered up) until I hit EXEC. Another situation off the top of my head is when I enter ISA deviation. Until I hit EXEC my frames drop to about 1-9fps. Strange but there seems to be some kinda code running in certain situations while editing the FP that aren’t well optimized or something. Other than that the plane runs smooth for me with the exception of the stutters introduced in world update, but that’s an asobo issue not CRJ.

Link to comment
Share on other sites

I have exactly the same issue. I am starting cold & dark at 60s-70s fps parked everything is smooth and nice. When i am  adding waypoints & airways of the flight route fps goes to  to 30-35.

I understand how demanding CRJ systems are but is it normal to loose almost 30fps ? And yes at least on my system 60fps are ultra smoother than 30 ( the difference is clear). Hot spot fps is 40 - 50 with g-sync

Flybywire A32NX had exactly the same issue when importing a flight plan but they fixed on latest updates. 

 

PC spec: 8700 @5.1ghz delidded / 3090 Asus Rog Strix OC / Asus Rog PG279Q G-sync monitor / 32 gskill ram 3200 

 

As for those spikes and freezes have nothing to do with CRJ. This is a well known issue that Asobo already investigating.

beside that fps issue , this Plane is Killer, congratulations to Aerosoft.

 

 

  • Like 2
Link to comment
Share on other sites

Yeah this is definitely an issue.  Hopefully they can add something like the glass refresh rate that's in the base sim.  Even other payware devs had similar features for their $100 aircraft in the old FSX.  Or at least be able to turn off FO displays (which shows as an option in the EFB in the manuals but is not in the sim).  I understand "30 fps is fine for sims" however when you're used to Gsync making everything super smooth, but you run a Gsync compatible monitor which means Gsync range starts at 43 and the CRJ drops you to 29-30 from the 50's when off even in external view, it just "looks" horrible and jerky/not smooth.  

Link to comment
Share on other sites

4 hours ago, GeorgLeBoui said:

So my issue ended up being the yoke bug. If you are affected by low FPS and stutters I would suggest you try this:

 

 

I checked that out earlier today when I read about it but there was no permanent boost at all for me.  Sitting at 30fps, push full forward, 47, release, back to 30.

Link to comment
Share on other sites

8 hours ago, flyinion said:

I checked that out earlier today when I read about it but there was no permanent boost at all for me.  Sitting at 30fps, push full forward, 47, release, back to 30.

I have checked and same here. When, on ground,  push forward the yoke fps boost up till 38/40 fps (everything super smooth OMG!! ) but  MFD screen stucked. Rotary knobs and buttons are working but nothing changed in the MFD screen. (Pushing back the yoke, unlock the MFD screen and FPS come back as before.  That's very strange, there is somenthing connected, to the cockpit, or it seems to be. No problems at all with other planes. Don't understand!!

 

 

 

Link to comment
Share on other sites

problem is with the display. in my case when pfd/mfd is off i get 40 fps, then i set the aircraft to ready for taxi i get 32 fps, but when i started to input a flight plan into it which now reflects on the mfd then i lost 3 more fps to 29.

Link to comment
Share on other sites

  • Root Admin
On 3/20/2021 at 4:35 AM, Chris Torres said:

problem is with the display. in my case when pfd/mfd is off i get 40 fps, then i set the aircraft to ready for taxi i get 32 fps, but when i started to input a flight plan into it which now reflects on the mfd then i lost 3 more fps to 29.

 

That is all more or less normal. As you run more code the simulator simply has to do more.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...