We have at this moment problems with e-mails coming to us via Microsoft servers (Outlook, Hotmail, Live, etc). We are in contact with Microsoft to solve this issue.

Jump to content
Sign in to follow this  
Rafal Haczek

Heathrow 2008 and g3d.dll

Recommended Posts

Ok I suspect a night texture is the culprit.

I have none of the patches installed BTW.

I tried the default cessna at KSEA (12 NOON) and did the "go to airport" thing and selected EGLL (trying to place me in England at rougly 9PM when the night textures are loaded).

PLUNK, CTD, d3d.dll error.

Tried it again only this time I was at KSEA at 5AM and placed me at EGLL at 2PM, no problems.

Also the flights I did do were in the day time so that might explain it.

SO.

Were the CTD with the d3d errors happening when you were flying into EGLL at night?

Share this post


Link to post
Share on other sites
Ok I suspect a night texture is the culprit.

Nope since it occurs during the day too have several flights now without any problems to EGLL...

Since for many of us flying into London more then usual it can be even a corrupted AI texture which isn't always at Heathrow :evil:

So maybe a common factor here just a thought going to test some more had one crash and 12 successfully landings 27R and 9L :roll:

Cheers,

Share this post


Link to post
Share on other sites

My CTD must have happened at around 13:00 local.

Before I forget: I'm using Heathrow 2008 with high res textures and UK2000 Gatwick Xtreme installed.

BTW: What if someone tries to change runway ops, that is, use 09L/27R for takeoffs and 09R/27L for landings, just to see if it happens with approaches to 09R/27L as well?

Share this post


Link to post
Share on other sites

AI bad texture is definitely NOT an issue. I have used Heathrow Pro since its first release in 2003 and never had any CTD, lockups, black screens or whatsoever in London Area.

I'm getting more and more with the idea of the scenery's bad textures, especially those in DTX1 format without alpha-channels.

Andre, you're the master of texturing, maybe you could shed some light on possibility of such issue?

Share this post


Link to post
Share on other sites
AI bad texture is definitely NOT an issue. I have used Heathrow Pro since its first release in 2003 and never had any CTD, lockups, black screens or whatsoever in London Area.

I'm getting more and more with the idea of the scenery's bad textures, especially those in DTX1 format without alpha-channels.

Andre, you're the master of texturing, maybe you could shed some light on possibility of such issue?

Yep is possible texture corruption or for example saved with photoshop and not via DXTBMP or imaginetool gives a CTD

Will look into the textures as for the CTD when switching the airports gives indeed a CTD.

The testpatch solved that one so going to check the textures now ;-)

Share this post


Link to post
Share on other sites

Thorsten,

I installed testpatch 2 and have flown test flights with Level D767 and lago Maddog MD80. Both had a happy ending of the passangers getting on the ground alive.

I did notice some frame rate drops at LOC CAP and again at glide slope interception. 4 flights were made, a day and night flight with each aircraft. I was using AES, ActiveSky 6 with all the FS sliders maxed out and My Traffic at 100%.

I'm giong to keep testing after I reinstall the origanal AFCAD file. Keep your fingers crossed!

Share this post


Link to post
Share on other sites

About frame rate drops: These are caused by the HIGH RES textures (guess you use them). When you come closer to the airport the scenery engine loads the big mipmaps (in case of HighRes, the realy big ones), which will mean it skips from a 512 x512 texture mipmap to a 1024 x 1024 one) This is an increase of 400% referenced to the data amount.

Some ultra modern graphic cards can handle it, some cannot.

Please try to use the normal textures.

Please report if you allready used the normal textures that I´ll try to solve that issue after the "big 3dg.dll one" is history.

Thorsten

Any more "good news" about patch 2? Possibly you can try it with the default AFCAD also, as it seems that the error is caused by another BGL)

Thorsten

Share this post


Link to post
Share on other sites

Thorsten,

Yes I was using High res but I 'm reinstalling the the whole airport with the normal textures, then I'll install all of the testpatch2 files except the AFCAD ( I'll use the one that came with the installer).

I will report after each test flight.

Dell XPS710 H2C

Intel® Core2 Quad CPU @ 3.192GHz (4CPUs)

4 GB RAM (only 2.814GB is recoginzed)

2 x 750GB HDs RAID 0 for a total of 1.5TB HD space (only 12% full)

OS is MS Win XP Pro (5.1, Build 2600)

DirectX 9.0c (4.09.0000.0904)

2 x Nvidia GeForce 8800GTX 768.0 MB cards (SLI enabled)

Dell 2407WFP (Digital) set @ 1920 x 1200 (32 bit) (60Hz)

Share this post


Link to post
Share on other sites
RAFAL: Could you delete all Heathrow2008/Textures (keep the directory, simply move them to a directory OUTSIDE FS9 ? And report if the CTD still happens. Perhaps it´s really a corrupted texture.

Thorsten,

Sorry for returning so late, but I had to get a break in these testflights.

So I 've taken my wife to the mountains for some hiking and RNAV spotting. :wink:

I have done as you asked. No textures this time.

The result is very promising. I had a 737 approach to EGLL and it was successful!

So looks like the corrupted texture trace seems probable.

However, as you all know, gentlemen, to call something an experimental proof, we need to make more attempts.

So, another mug of coffee and coming back to night testing.

Best regards,

Rafal

Share this post


Link to post
Share on other sites
Testpatch 2 cured the CTD problem for me.
Oh, I've just seen your post. Happy you got rid of it!

I am now going to test the patch 2 with textures back and I will report.

Best regards,

Rafal

Share this post


Link to post
Share on other sites

OK, good news from me.

I restored textures back and then applied Thorsten's patch 2.

Took off from Amsterdam with KLM 737-800 (PMDG) and landed safely on Heathrow's 09L! :D

Here's some evidence:

EGLL_resize.jpg

Now it is half past one at night.

I have to go to bed or I will get a divorce call...

Will test more tomorrow before work.

Good night to everybody.

With regards,

Rafal

Share this post


Link to post
Share on other sites

I'd like to add my two bits to this topic.

First time I installed AS_Heathrow I actually did a flight from EDDF to EGLL. Level-D, ActiveSky, GEPro, RC4.No trouble at all except for stuttering and textures taking forever to load as I was on VERY short finals. This was with the hi-res textures installed.

Next time I tried, I got the crash. I tried re-booting etc but still kept getting the error. I always begin with the default flight then switch aircraft and move to my departure airfield.

I un-installed and reinstalled the scenery (with low textures this time and after having gotten rid of anything remotely not bog-basic EGLL -such as Gary's Heathrow Pro which I had been using for MANY years- and any afcads I could find). No joy.

The interesting part begins now, however.

With AS_Heathrow installed I cannot even get INTO FS9! When I delete it, FS9 starts fine. Also...when AS_Heathrow is installed I cannot access the Add/Remove option from the control panel to uninstall. I manually delete it then, presto, Add/Remove works just fine. As Alice would say..."curioser and curioser..."

Hope this is some more info Oliver can use!

Cheers!

Tony

P.S. Computer specs:

ASUS P5WD2-E Premium mobo

Intel Duo 940 (3.0GHz)

2GB ram (Kingston)

Asus X1600 radeon Pro (512MB)

Creative Audigy 2 soundcard

3 hard drives

CF Yoke

All software is up to date, latest drivers, etc etc.

FS9.1 /Win XP Home SP2

Share this post


Link to post
Share on other sites

I forgot to mention that I am also using Ultimate Traffic and that the crashes occur with any aircraft, not just the complex add-ons we all have and love.

Cheers!

Tony

Share this post


Link to post
Share on other sites

Thorsten,

I reinstalled LH2008 and applied all files of test patch 2 except the afcad, I kept the one from the ver. 1.0 installer.

Test flights 1, 2, 3, and 4 all went off with no CTD!

Test conditions for all flights:

FS sliders all maxed out

Aircraft was Lago Maddog MD80

Traffic was My Traffic set to 100%

AES active

On flight 1 ILS approach to rwy 27R with no weather during the day.

On flight 2 ILS approach to rwy 27L with ActiveSky 6 live weather during the night.

On flight 3 ILS approsch to rwy 9R with Activesky 6 very heavy rain and thunder storm during the day.

On flight 4 ILS approach to rwy 9L with ActiveSky 6 blizzard with icing conditions during the night.

On all flights all motion was fluid with no real loss of FPS. average FPS was 22 to 30, I have my frame rate locked at 40 and average 28 to 32 FPS.

Now off for some more tests, Level D767 then the default Cessna 208 Carivan followed by some high speed (near Mach1) low level (50ft off the deck) fly bys down each runway with an F/A 18E are on the schedule.

I'll report back when the above tests are complete.

Share this post


Link to post
Share on other sites

Just completed my 3rd flight for today: EBBR - EGLL with extensive testing of night textures. Landing was done at 19:00 GMT.

No problems were noticed.

Share this post


Link to post
Share on other sites

Can someone tell me why the original 'AF2_EGLL_Simwings' file has an extension of '.bgx' instead of '.bgl'??? :shock:

Share this post


Link to post
Share on other sites

I just redid LH4722 DUS-LHR, the very flight that previously CTD'ed on me, but this time I used Patch 2, the original AFCAD, and the PMDG 747, and success! No CTD at all! I hope this permanently fixes it.

Share this post


Link to post
Share on other sites
G3D.dll error has been always linked with corrupted textures - usually "bad" DTX1 format. I had the same problem with Imaginesim KDTW and Overland RJBB. Perhaps, it's better to check texture by texture to see what may cause the problem

I'm with you on this I just wish I had the time. I'm currently testing testpatch2 as I write this...

Share this post


Link to post
Share on other sites

Thorsten,

I have good news! I have now finished all the testing I can think to do and I think that test patch 2 has done the trick. I removed and then reinstalled LH2008 (EGLL) I then dropped in the test patch 2, minus the small afcad, I used the afcad that came with the original version of LH2008.

I have tested with the Lago maddog, LevelD 767, and the default Cessna Grand Carivan. All where flown on 4 seperate flights testing all 4 runways in no weather, AS6 live weather, AS6 heavy thunder storm, AS6 Blizzard with icing conditions and day and night.

Then just to be sure I used my F/A-18E and starting 60nm from the airport each time, I lined up on the runway headings and flew in at Mach 1.2 at an alt of 2500ft and at 10nm I dropped down to 100ft off the deck.

I can report that I have not been able to force a CTD and the frame rates have been rock steady and high.

Got to go to bed or my wife says she'll go back to Hong Kong! :lol:

I hope this helps.

Share this post


Link to post
Share on other sites

Well I'm happy to report after trying 'testpatch2' (without the updated Afcad file). I made a successful landing at EGLL without a CTD... I guess we officially have a fix for this issue... :wink:

I still would like to know why 'AF2_EGLL_Simwings' has a '.bgx' extension instead of a '.bgl' extension (this came like this with the original install). Should I change that extension to '.bgl'??? :shock:

Share this post


Link to post
Share on other sites
I still like to know why 'AF2_EGLL_Simwings' has a '.bgx' extension instead of a '.bgl' extension (this came like this with the original install). Should I change that extension to '.bgl'??? :shock:

Dillion,

My install named the AF2_EGLL_Simwings as a bgl.

So yes change it to bgl.

Share this post


Link to post
Share on other sites

Looks like I am not the only happy sheep on board. 8)

Glad you all guys have it working now.

I'm going to give it a few tries in a moment to confirm the cure.

A thought that comes to my head however is: what is it that may have helped?

The patch didn't change textures, so it ommits the theory of corrupted textures. There were just bgls.

And not the AFCAD, either.

Thorsten, what do you think?

Best regards,

Rafal

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...