Jump to content

Heathrow 2008 and g3d.dll


Recommended Posts

Ok, came back and made two more test flights.

Unfortunately my enthusiasm after reading Jure's and Oliver's posts has crashed with g3d.dll again twice.

I am really happy Jure has his EGLL cured now, but I don't yet.

I decided to test the ILS theory.

So the first flight was with PMDG 737NG planned as departure and arrival back to EGLL.

I did NOT tune the ILS frequency (109.5 or 110.3) to eliminate it relation to the error. Unfortunately crash on finals about 10nm from the rwy threshold.

The second flight was with Oliver's AFCAD. The result was exactly the same.

What I am still going to check is total uninstalling UK2000 EGKK.

Looks like this problem is NOT limited to the ILS/AFCAD issue, though it has worked for some users.

No more ideas at the moment.

Rafal & Oliver, meet at EGLL and we go for a beer?
An excellent idea. As soon as I get there safely. :)

Best regards,

Rafal

Link to post
Share on other sites
  • Replies 304
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

To all: Thanks to a good tip from a colleque at Paderborn conference we discovered that indeed something went wrong with the LHR AFCAD file. The ident for the 09l Runway was incidently not

Hi Rafal,

cause Oliver is trying to catch his flight at the airport I´ll continue to solve the issue.

I attached a zip fils that contains a original g3d.dll (of 9.1) and an AFCAD fils that I simply converted from the default scenery (with backcourse enabled, as this does not seem to be the problem at your system).

If the deault is working this should work too.

Please test this AFCAD file instead of ours and replace your g3d.bgl (in /FS9/Modules). (Make a backup of yours first)

Pleas report if the problem is solved. I tried to reproduce it at my two systems but I dont get the errors.

Thorsten

Link to post
Share on other sites

Hello Thorsten!

Thank you very much for your contribution.

I have followed your indications and replaced both the AFCAD and the dll.

And the result is.... it worked this time! :D

So looks like my problem has also been solved if, of course, we can name it precisely.

And obviously I have to make a few more flights to make sure it was not a lucky coincidence.

A tiny remark to be perfect - with this new AFCAD my AI taxi on the grass. :wink:

Guess it's because of the default conversion.

Hope we can get an expert and "non-g3d.dlling" AFCAD soon.

Have a look:

AI.jpg

Once again thank you for your assistance.

Since I was ready to have a look at the airport finally I would like to say:

SimWings, you're finally going FlyTampa!

Best regards,

Rafal

Link to post
Share on other sites
Hi Rafal,

cause Oliver is trying to catch his flight at the airport I´ll continue to solve the issue.

I attached a zip fils that contains a original g3d.dll (of 9.1) and an AFCAD fils that I simply converted from the default scenery (with backcourse enabled, as this does not seem to be the problem at your system).

If the deault is working this should work too.

Please test this AFCAD file instead of ours and replace your g3d.bgl (in /FS9/Modules). (Make a backup of yours first)

Pleas report if the problem is solved. I tried to reproduce it at my two systems but I dont get the errors.

Thorsten

Same issue here guys g3d.dll error and crash :cry:

Going to try the other AFCAD...

Cheers,

Link to post
Share on other sites

Only problem of course is that the AFCAD Thorsten uploaded here was just to test out the theory; it won't work with the new SimWings EGLL - all the traffic will taxi in the wrong places - and more than half the gates are missing. I'm sure Thorsten never meant it as a definitive replacement.

Did anyone try changing the ILS frequencies on the SimWings AFCAD (as linked through Oliver's post above, as Oliver suggested? I'd do it - but haven't downloaded the airport yet. Waiting to see that it all works OK first!

Martin :)

Link to post
Share on other sites

Assuming no-one had got around to this, here is the 'official' AFCAD from Oliver, but I have changed the ILS frequencies so that 27R, 27L, 9R & 9L all now have a different radio frequency.

I think that was what Oliver was suggesting. Be good to know if it helps at all.

Martin

Link to post
Share on other sites

@RAFAL

Your aircraft is in the gras because the AFCAD I gave you for testing was a quick conversion of the default one. Can you now substitute the afcad again with the first one Oliver posted (the one with backcourse set to OFF)

or the one from Martin? But keep the G3D.dll from my file

(just to make sure the problem is really caused by the AFCAD and not by your G3d.dll)

Others: Please dont use the AFCAD file I uploaded for RAFAL. It is just the default one.

Link to post
Share on other sites

Oh no! I have been following on trying the different files, on using the G3d.dll my sim started hanging at 78% loading (adjusting scenery objects) and very slowly loaded. Once in the cockpit I am getting 4 fps down from 25-40.

Help, I replaced all the original files no improvement, uninstalled EGLL still no improvement.

Any ideas to rectify this problem gratefully recieved.

John

Link to post
Share on other sites

Phew, panic over I turned off for 10 mins and then restarted and frame rates are back up. Overheated maybe ? I know that I am !!

OK before I change any files again I will wait for the definitive solution from you clever chaps or Aerosoft, please keep posting your results its really interesting to see your efforts to solve this DLL crash problem.

Regards John

Link to post
Share on other sites

Just finished an Online flight from KBOS-EGLL, no problems at all with the original AFCAD provided with the scenery. I am using FSINN, PMDG744, AS and PAI aircrafts for the online traffic.

If this helps I received the dll error only when I was flying the PSS 757 ver 1.3 at EDDM. This has happene twice and only with the above mentioned plane.

Chris

Link to post
Share on other sites

OK, here we go.

Please download: www.data4image.com/inofficialpatch1.zip

This zip file contains some files that must overwrite the files

in LondonHeahrow/scenery.

- A new full working AFCAD file

- BGL files that smooth the stuttering when approaching to the airport because not all long distance buildings are loaded at the same time.

Cannot guarantee that it will solve the problems but it could. Please report.

Third: It is HIGHLY RECOMMENDED to use the Normal Textures.

The HighrRes textures are only for those having a "on top" PC with a 500MB Graphic card or similar and use a very large monitor like the 30" Dell. On screens up to 22" you´ll virtually notice no diffference.

On an average PC you´ll get LOTS OF STUTTERING due to the fact that the scenery engine has to load 3 times more data than using the normals.

Maybe it was a bad Idea to integrate those HighRes textures as they cause more problems on normal PC´s than it´s worth to have them for few users. :?:

Link to post
Share on other sites

Thorsten,

No joy!

I removed and reinstalled with normal textures and then installed your last posted files in the zip, inofficialpatch and then made a total of 18 flights to EGLL from LFPG with the Aerosoft LTU A321, Posky 747-400, Level D 767-300ER, Lago Maddog MD-80, PMDG Beechcraft 1900C, and default 737. Each aircraft was flown on the same flght plan 3 times, (day time with AS6 weather and Pilots global mesh, daytime with the mesh and no weather, and daytime no mesh and no weather). No other add on scenery.

All flights ended in a CTD (g3d.dll error) anywhere between 11 and 8nm while on approach to Rwy27R. I further slewed each aircraft to 25 miles and made approaches to the other rwys with the same results at 8 to 11 nm.

My FS9 is 9.1 and the rest of my system details are as follows:

Dell XPS710 H2C

Intel® Core2 Quad CPU @ 3.192GHz (4CPUs)

4 GB RAM (only 2.814GB is recoginzed)

2 x 750GB HDs RAID 0 for a total of 1.5TB HD space (only 12% full)

OS is MS Win XP Pro (5.1, Build 2600)

DirectX 9.0c (4.09.0000.0904)

2 x Nvidia GeForce 8800GTX 768.0 MB cards (SLI enabled)

Dell 2407WFP (Digital) set @ 1920 x 1200 (32 bit) (60Hz)

Link to post
Share on other sites

I had my first CTD today. I am using the latest fixes provided here. I am using the Low texture install.

Plane PMDG 737-700, AS and AES1.91. On yesterday flight everything was OK.

Crash happened to a flight from EBBR-EGLL on 7 miles 27R while fully establisehd.

I don't think that AFCAD has to do with the crashes. LGAV also uses the same frequencies for each runway and I have no problem with the AFCAD. I am afraid it has to do with a texture loading problem...

PC Specs

XP SP2

Directx 9

P4@3Ghz

3GB Ram

Ati X1950256MB running on Omega 3.8.360 drivers.

Chris

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...