Jump to content

Heathrow 2008 and g3d.dll


Rafal Haczek
 Share

Recommended Posts

It only happens when arriving at EGLL :wink: so XXXX - EGLL

Going to test some more myself only time :lol:

Ok guys when the ILS isn't captured and the aircraft is landed manual no OOM as soon a capture of the ILS OOM CTD :D

Running Windows XP SP2

Link to comment
Share on other sites

Hi Joeflyer,

the "yadda yadda yadda"-part could be interesting. There is a patch for Vista concerning Out-of-Memory errors.

I did not experience OOM-errors, using Vista 32-bit, EGLL and PMDG.

Hello, Marco....

I did fail to mention the OS :D I have XP Pro SP2. I haven't had an out of memory error in a very long time, but of course I don't do as much flying around Europe....until I purchased Heathrow '08 :D The OOM error I experienced with the PMDG and the EGLL scenery is the first one, so I don't have a frustration level as others...yet.

From what I have read so far, the culprit may be in capturing the ILS at EGLL for any runway. I'm curious as to why this may be happening :?

Thanks,

Joe

Link to comment
Share on other sites

Another OOM ocurred while I was using the PSS 777 and around 25nm from EGLL on final descent. I suppose there isn't any point in trying to fly to EGLL for any reason since I didn't even try to connect with a LOC at that point in the flight. :cry: If I can only fly from EGLL and not to the airport, what's the point in having this scenery? It's a shame because I really like the eye candy.

I hope someone can find a solution to this problem. :?:

Link to comment
Share on other sites

  • Developer
Well, I tried the option of unchecking EGLL and rechecking it then doing a resync/repair prior to using the PSS 777. Still got the CTD. So, it may be something else with the EGLL scenery or a combination of EGLL and AES causing the problem.

Hi,

did you make the same flight with EGLL unchecked in AESHelp?

Link to comment
Share on other sites

Hi,

have tried some flights to EGLL with the 744F PMDG and always at BIG i get a CTD, no error message. With the FT737 all works fine. I run version 1.1; AES; UTE; AS6.5; GEPro.

E6850 + 2GB Ram + X1950pro 256mb.

Can somebody help me?

Regards,

Chris

Link to comment
Share on other sites

Hi,

did you make the same flight with EGLL unchecked in AESHelp?

Hello,

No, I did not try it out with EGLL unchecked. What I did attempt is a flight out of EGLL for about 25-30 nm and return to intercept the LOC for RWY 25L with the PMDG 747. No problems throughout the flight to landing. I assume that since the EGLL textures have already loaded, I will not have the out of memory or out of disk space errors. The problem lies in making a flight TO EGLL from another airport and get within the EGLL texture loading distance then FS9 freezes up.

I will attempt another go at it from another airport.

Link to comment
Share on other sites

Hi,

have tried some flights to EGLL with the 744F PMDG and always at BIG i get a CTD, no error message. With the FT737 all works fine. I run version 1.1; AES; UTE; AS6.5; GEPro.

E6850 + 2GB Ram + X1950pro 256mb.

Can somebody help me?

Regards,

Chris

Chris curious but try not to lock the ILS but handfly the approach worked for me with the LDS 767...

Going tot test with another AFCAD.

As for OOM have never had the event in FS9 or FSX for that matter :!:

Link to comment
Share on other sites

  • Deputy Sheriffs

HI,

sorry for beeing not as quick as usual as I thought this problem is not depending on Heathrow (And I´m stucked in this FSX SP2 etc. stuff).

I saw in several forums that the OOM error is a common fault of the 744, specially when capturing the glideslope. But I got this plane myself and never had such an error.

So if we dont put it on the aircraft it could possibly be another add-on that is used in the London area. To be specific: The more add-ons are installed for that area the more memory is needed which could cause this OOM. In the LHR scenery I could not find something causing this, despite it possibly could be the very dense AFCAD file (maybe because related to the ILS capturing). And Heathrow also is very special that way: They have the same ILS frequency for both sides of the runway. Maybe this will cause the aircraft trouble when getting both ILS from side approaches?

Please try the following as I cannot reproduce this error and therfore it´s nearly impossible to solve it:

- Make sure that you have installed the most recent 1.1 Version correctly. Sometimes, when installed 1.0 before and not removed via the software function the 1.1 Installer let you think it´s 1.1, but it is 1.0.

- Possibly you could change from high res to the normal res textures (not a big difference, but a little bit less memory) If that´s the trick I could provide a new more smaller texture set.

- Do NOT use the 1.0 version!

- Temporarily disactivate other scenery that could effect that area and report which one possibly caused trouble in combination with our LHR. than I can check this.

- Makes ure that you do not have double entries for LHR in your scenery.cfg or scenery library

- Set the Ai trafiic to 0% for testing. This OOM or fe.dll error could also be caused by a corrupt or missing texture of one AI-aircraft. Possibly one that only shows in LHR as there is a very huge amount of AI stands.

- Move the entire LHR/texture directory to a space outside FS9 to check if it´s related to a corrupted texture or too much texture memory needed

- rename the LHR/scenery/AF2-EGLL-simwings.bgl to *.OFF (just a test to see if the AFCAD is causing the problem)

- Follow the advices of PMDG how to solve that OOM error (higher virtual memory or else)

- Try to deactivate ActiveSky temporarily as I could see that most users have it running.

I dont have it, but afaik it also uses lots of textures?

London is in any kind a very dense area, therefore it´s not really comparable to Frankfurt etc. But I´m trying to find a solution if you can assist me as for me this error is not reproducable and could have so many reasons, even in combination.

Thorsten

Link to comment
Share on other sites

  • Deputy Sheriffs

Another thing came into my mind: Could someone having the error when capturing the GS alter the ILS frequencies on the opposite ends to a different value (just to test if the double ILS of LHR is causing the trouble)?

If not I can attach a altered AFCAD file here.

- And check that ANY OTHER AFCAD file from other versions of LHR is not present on the system anymore. Specially UK200 put AFCAD files in a different scenery entry than the scenery itself. search your scenery.cfg.

@ChrisZet: Are you sure using the V1.1 and not 1.0 ?

Thorsten

Link to comment
Share on other sites

  • Deputy Sheriffs

Just another suggestion for experts:

Those having that reproducable OOM error.: Could you possibly download and use filemon http://www.winload.de/downloading/64545-Filemon.7.04.html which is a programm showing what is loaded into memory during the flight and hopefully what is loading before OOM occours. (could help to identify a corrupted or missing texture)

Or maybe the aircraft is trying to load things but it cannot during the flight which reserves a huge amount of memory.

Another important question: Are all of you having OOM´s using UT Europe/US?

There were some missing textures in UT europe cusing exactly the error you describe with PIC737, PMDG744...

Thorsten

Link to comment
Share on other sites

Just another suggestion for experts:

Thorsten

Thorsten going to do some more testing I had this error for the first time in FS history and with the LDS 767 and also with other aircraft...

Have UT Europe installed + a lot of airports when I fly to those I don't have the OOM...

For example:

Flight EDDF with AES - to EGKK or EGDD or EGGS or EGLC no OOM

Flight EDDF with AES to EGLL after locking the ILS a few seconds after OOM CTD with the facilities.dll written to the event viewer...

Hand flying the approach no CTD have to do some more testing...

Will do some more test flights...

Also de-installed version one and installed version 1.1 with the normal textures :-)

Testing now with the testpatch afcad will use filemon already installed...

In my case running WinXP SP2 C2D E6600 with 4 gb crucial ram 7950GT 512MB drivers 94.24 Nvidia and a raptor WD 10.000 rpm drive only for FS...

Hope the above info is useful

Link to comment
Share on other sites

  • Deputy Sheriffs

@awf

about UT-Europe, just to make sure it is NOT the UT-Europe OOM issue I copied from another thread concerning OOMs of this forum. Some of UT-Europe users had OOM´s even with the default Heathrow, so maybe thats the trick :?: :

" i think it has nothing to do with your RAM.

There is a known problem in relation between Flight1's Ultimate Terrain Europe and the use of, what they call, sophesticate aircraft's (e.g. Level D's 767 or the PIC series of planes). If You have UT-Europe installed an use such a plane a OOM (out of memory) problem occur, with the result of a CTD.

There is a new Setup.exe (V 1.11) available from Scenery Solution, to fix that memory leakage. "

If you are using UT-Europe, are you sure you fixed that memory leakage?

(It was caused by some missing landclass textures, but 1.11 should fix that)

The error that is reported while getting the OOM seems to be random. Sometimes it´s FE.dll, Facilities.dll etc.) I guess this is just the dll loaded when running out of memory.

Thorsten

Link to comment
Share on other sites

@awf

about UT-Europe, just to make sure it is NOT the UT-Europe OOM issue I copied from another thread concerning OOMs of this forum. Some of UT-Europe users had OOM´s even with the default Heathrow, so maybe thats the trick :?: :

" i think it has nothing to do with your RAM.

There is a known problem in relation between Flight1's Ultimate Terrain Europe and the use of, what they call, sophesticate aircraft's (e.g. Level D's 767 or the PIC series of planes). If You have UT-Europe installed an use such a plane a OOM (out of memory) problem occur, with the result of a CTD.

There is a new Setup.exe (V 1.11) available from Scenery Solution, to fix that memory leakage. "

If you are using UT-Europe, are you sure you fixed that memory leakage?

(It was caused by some missing landclass textures, but 1.11 should fix that)

The error that is reported while getting the OOM seems to be random. Sometimes it´s FE.dll, Facilities.dll etc.) I guess this is just the dll loaded when running out of memory.

Thorsten

@Thorsten

I gave the above mentioned advice to another user, because i had OOM's with CTD's over different locations across europe some times ago.

This worked for me 'till the installation of Heathrow and/or the upgrade of AES from 1.90 to 1.91 on my computer.

So unfortunatly it doesn't solve the prob's for me even with the 1.11 Setup.exe from UTEurope.

Link to comment
Share on other sites

Hi, I do not have UTE but experience OOM /FE.DLL errors using v1.1 of EGLL.

The only way I can land at Heathrow is to use a saved weather file in ASv6.5 that gives very "light" weather.Not running ASv6.5 produces the following results , Short flights into EGLL . ie under 2 hours are ok , over 2 hours OOM error.

This leads me to believe that the problem is with the texture size/amount being loaded on final approach (around 8 miles) into EGLL and would appreciate a smaller set of textures to see if that helps.

Thanks John

Link to comment
Share on other sites

  • Deputy Sheriffs

@johnegg

could you please try to remove the entire content of the LHR/Texture directory temporarily to a place outside FS9.

So finally the textures are NOT loaded. This could help us to see if it´s about the LHR textures. Dont worry about a CTD as it is only related to landclass textures not found.

Of course the scenery will look entire grey but just for testing.

What happens on your PC NOT using AS at all?

@crowsnest

What will happen at LHR if NOT using UT Europe at all (dont know if it is a big deal to temporarilly deactivate it)

Thorsten

Link to comment
Share on other sites

@johnegg

could you please try to remove the entire content of the LHR/Texture directory temporarily to a place outside FS9.

So finally the textures are NOT loaded. This could help us to see if it´s about the LHR textures. Dont worry about a CTD as it is only related to landclass textures not found.

Of course the scenery will look entire grey but just for testing.

What happens on your PC NOT using AS at all?

@crowsnest

What will happen at LHR if NOT using UT Europe at all (dont know if it is a big deal to temporarilly deactivate it)

Thorsten

@Thorsten

No big deal, just an unchecking in the scenery library.

Same results as described by johnegg.........OOM

I'm waiting for the results without ASv6.5................try & error

Rainer

Link to comment
Share on other sites

  • Deputy Sheriffs

And waiting for the result without LHR/Texture textures.

Does anyone know what Filemon is telling?

@crowsnest: When without UT Europe is still happens we should really investigate more in the direction of AS. If we know that without AS the error is gone it could help us to solve it.

Just a thought: I remember from some years ago that weather addons often caused FE.DLL errors when used in combination with other weather related programs. (for instance flying a Weather program (dont remember the name) together with "real MS weather" caused allways a reproducable FE.DLL error when the FS9 tried to get the latest data.

But I must confess I do not know anything about AS.

Link to comment
Share on other sites

Removed the EGLL textures and set up a flight from LOWW to EGLL which consistently produces an OOM error on final with a saved weather file in AS.

13 miles from EGLL 27R OOM error weather.DLL

I will repeat the flight without AS and post the results here.

John

Link to comment
Share on other sites

  • Deputy Sheriffs

@johnegg: OK, thanx. As I could see in the AS Forum while making some investigations there were lot of OOM problems mentionend with AS in combination with complex aircrafts/complex scenery. But they allways put it on the other add ons or FS9 itself:-(

(just read the FAQ´s in the AS forum at AVSIM). But anyway: We´ll try hard to solve this issue. If the error occours without LHR textures, what will happen without LHR at all using the same weather file? But we have to proceed step by step, otherwise we get lost. So I`m waiting what happens without AS. (Maybe a good thing to reinstall LHR textures first)

Thorsten

Link to comment
Share on other sites

Hi Thorsten, ok I replaced the EGLL textures in the Aerosoft folder and flew the same route but did not start AS, so effectively clear skies.

No errors and landed ok on 27R.

I hope this helps get to the bottom of this annoying problem as flying with clear skies does detract from the enjoyment.

Regards John

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...