Jump to content

MSFS ATC doesn't recognize Squawk Code


Recommended Posts

Hi,

 

I'm trying to fly an IFR flight plan with the MSFS ATC.

But ATC service is terminating constantly, because they don't recognize my squawk code and ask me to rest it to 1773.

As fas as I can tell, I am squawking 1773. Can't seem to find a solution. Any ideas?

Pictures of my setup attached: 

radio panel - 2.PNG

radio panel.PNG

mcdu radio.PNG

  • Upvote 2
Link to post
Share on other sites
  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

As I've said elsewhere, It works for me if I set it via the FMS. If I use the pedestal radios it doesn't.

Hi,   I'm trying to fly an IFR flight plan with the MSFS ATC. But ATC service is terminating constantly, because they don't recognize my squawk code and ask me to rest it to 1773.

I set the radio to standby, read back clearance, set squawk thru the FMS and then turn radio to 1. Works for me without issues. 

Posted Images

Ok, did another Flight, this time without a hitch.

Need a couple of confirmation flights, but I think as soon as you set a callsign and flight number in the ATC menu in MSFS word map, you're golden. I forgot to do that last time around.

Link to post
Share on other sites

Ok, another flight with a callsign and it doesn't accept my transponder code again... so that wasn't it. out of ideas honestly...

Link to post
Share on other sites
  • Deputy Sheriffs

Is this repeatable with a stock aircraft, preferably a turbojet? And more than one make/model? If so, that points to a sim issue rather than an add-on issue, so best to report it on the MFS forums instead of here. If it only affects the CRJ, than of course we'll explore it further.

  • Upvote 1
Link to post
Share on other sites

I have completed many flights in the A320 (flybywire), one today, with no issues.

As this is the only other airliner I tend to fly, in addition to that, I have quite a few flights in GA planes, and never had any issue.

The CRJ is so far the only aircraft I have encountered this problem with.

 

To me it seems that the transponder doesn't always switch to Alt mode when it should and stays in Stby. Just an assumption though, based on the behaviour I observed.

I wonder, because I think I might have forgotten to set the To To mode prior to takeoff on my second flight today, if that is coupled with the transponder going to Alt? Will test tomorrow and report back.

  • Thanks 1
Link to post
Share on other sites

Regarding this issue on other aircraft, if you don’t manually enter the squawk code on all the default aircraft the code automatically appears as entered when you read back the ATC instructions (in other words the sim enters it in the correct location). This doesn’t happen in the CRJ. 

Link to post
Share on other sites
3 hours ago, Lloyd Morris said:

Regarding this issue on other aircraft, if you don’t manually enter the squawk code on all the default aircraft the code automatically appears as entered when you read back the ATC instructions (in other words the sim enters it in the correct location). This doesn’t happen in the CRJ. 

 

3 hours ago, Thx1137 said:

is the ATC SEL set to 1 on the center pedestal? I've no idea if that make a difference but TCAS isn't enabled until it is switched.

 

See pictures in OP. Code is entered manually and ATC selector is on 1

Link to post
Share on other sites

Yeah what I’m saying is even if you don’t manually enter it, on the other aircraft in the sim it will automatically update when you press “acknowledge atc transmission” in the atc window. With the CRJ this doesn’t happen which makes me think the sim doesn’t know where to enter it on this aircraft and that’s why it doesn’t understand when you enter it there. Just a guess. 

Link to post
Share on other sites

I am 95% sure that this is related to the issue I replied to here. Because the Aerosoft CRJ is not setting the TRANSPONDER STATE:1 variable, not even MSFS ATC would realize that the transponder was "on" or in "alt" mode. The transponder code is being set to the appropriate variable (and is updated with the ATC 1 or 2 value depending on the selection in the CRJ), but the mode is not. Unfortunately, the workaround I provide here would only work on VATSIM, since there is a separate button you can use to enable Mode C in the vPilot client. In my own setup with SPAD.NEXT, I added a scripted action that automatically sets this variable to Mode C (4) whenever I change the ATC switch selection, and sets it back to Standby (1) whenever the switch is move to standby.

 

  • Like 1
Link to post
Share on other sites

This is definitely a bug of some sort although I can't isolate the cause.  It doesn't happen on every flight - only every third flight or so.  I follow the same transponder setup every time.  As soon as ATC gives me the code on IFR acceptance, I set it, verify it's in there, and flip to 1 on the TCAS.  I've even tried to set BOTH 1 and 2 when it gives me a failure, but that doesn't work either.  It seems like it may be reading the #2 instead of the #2 sometimes although I can't guarantee that.  But if you move the #2 dials it changes the #1 setting, so I think that's something worth looking into??

 

When I do get the failure, there's nothing to stop it except let ATC go thru the motions of VFR clearance, then Retry with Last.  Second time it always works.

Link to post
Share on other sites

just had the same issue .... all set correctly in radio and knob to 1 ..... IFR terminated.

 

I will try only the FMC if possible like suggested above and see what that does.

Link to post
Share on other sites

Happening on almost all flights.  I don't get it.  Can't figure out the pattern as to when it works and doesn't.  Only happening on this A/C for sure.  I have over 850 hours in the A32NX and this NEVER happened, and in here it's almost every flight.  Annoying, that's for sure so I hope they figure it out soon.

Link to post
Share on other sites
On 3/21/2021 at 10:45 PM, Thx1137 said:

As I've said elsewhere, It works for me if I set it via the FMS. If I use the pedestal radios it doesn't.

 

This has saved my life!  Thanks.  Didn't think to check if hat was even possible.  I've been fooling with the selection knobs.  As a point of quality, those should work too, but...using the CDU is so much easier and has worked on every flight thus far.  Thanks @Thx1137! 👍

Link to post
Share on other sites
  • Deputy Sheriffs

I'll try to have a look into this and try to check the different variables that could be related with this in due time to see if I can find any anomalies there that could cause this.

Link to post
Share on other sites

Seems like if I wait until after the readback is complete, *then* set the squawk code in the FMS, there are no issues. But if I get impatient and set the squawk code and turn the knob to 1 (using exactly the same method) before finishing the readback, ATC eventually fails to pick up the transponder. That might not really be the issue, but seems like that's the pattern for me.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...