Jump to content

Autopilot Irregularities


Recommended Posts

Hello!

 

Great to see the CRJ 700 flying in MSFS2020.  

 

There seems to be occasional issues with the Autopilot.  I often do not capture a successful ALT CAP with the autopilot on.  I have tried in both Speed and VS modes but the FD will show a level off yet the aircraft continues to climb or descend hundreds of feet.  Even thousands in some cases.  The flight director shows the correct vertical speed and even will show the level off, but the aircraft sometimes will continue and not follow the flight director guidance.  I also notice even after ensuring the weight and balance is correct, the ND trim is at 0.0 in flight.  I have tried various fuel levels and various payloads, all within CG and MAC limits, yet the trim at 0.0 seems a bit odd, from takeoff to touchdown with the auto pilot on.

 

When I was able to get the aircraft in a commanded descent from FL200 to 10,000 at a VS of 2500fpm, the FD and aircraft seemed stable, yet every 60 seconds or so, the aircraft would have an uncommanded pitch down to 3800fpm then back up to a climb of 1000fpm before settling back at 2500fpm descent.  I was not using the VNAV function and the auto pilot was set up correctly.

 

There were also deviations with lateral navigation.  While traveling from the intermediate fix to the final approach fix into KMSP, the FD showed a continued course which matched the FMS yet the aircraft began a turn to the left, while the Flight director showed a correct level flight to the next fix.  

 

Overall... Excellent aircraft and I am happy to have it in the simulation.  I look forward to continued updates and refinements. 

 

Cheers!

  • Upvote 2
Link to comment
Share on other sites

  • Root Admin
55 minutes ago, CaptMike2 said:

Hello!

 

Great to see the CRJ 700 flying in MSFS2020.  

 

There seems to be occasional issues with the Autopilot.  I often do not capture a successful ALT CAP with the autopilot on.  I have tried in both Speed and VS modes but the FD will show a level off yet the aircraft continues to climb or descend hundreds of feet.  Even thousands in some cases.  The flight director shows the correct vertical speed and even will show the level off, but the aircraft sometimes will continue and not follow the flight director guidance.  I also notice even after ensuring the weight and balance is correct, the ND trim is at 0.0 in flight.  I have tried various fuel levels and various payloads, all within CG and MAC limits, yet the trim at 0.0 seems a bit odd, from takeoff to touchdown with the auto pilot on.

 

When I was able to get the aircraft in a commanded descent from FL200 to 10,000 at a VS of 2500fpm, the FD and aircraft seemed stable, yet every 60 seconds or so, the aircraft would have an uncommanded pitch down to 3800fpm then back up to a climb of 1000fpm before settling back at 2500fpm descent.  I was not using the VNAV function and the auto pilot was set up correctly.

 

There were also deviations with lateral navigation.  While traveling from the intermediate fix to the final approach fix into KMSP, the FD showed a continued course which matched the FMS yet the aircraft began a turn to the left, while the Flight director showed a correct level flight to the next fix.  

 

Overall... Excellent aircraft and I am happy to have it in the simulation.  I look forward to continued updates and refinements. 

 

Cheers!

 

Can you provide some screenshots the next time you see something like this?

Link to comment
Share on other sites

Seeing the same here - this also seems to prevent GS mode from going from armed to activated while ALT CAP is still showing as active. Will try to get some screenshots next flight.

Link to comment
Share on other sites

  • Developer

The payload looks weird. That might cause a problem. It's difficult to trim the aircraft with a 800lb Flight Attendant in the front... 😄

These are the default numbers:

grafik.png

As you can see, there's little weight in the front.  We recommend to not use the simulator's fuel window to set the payload but the payload feature on the Performance page of the EFB:

grafik.png

  • Like 1
Link to comment
Share on other sites

This was after adding flaps 1, 8 in, stable at 4000.  A climb began at 1500fpm, ALT CAP brought the FD back down, but the aircraft never responded.  As there is an ALT CAP, you have to then change the altitude, and try to VS it back down to the assigned alt.

 

I used the tablet for performance as mentioned above.  Then synced that performance to the simulator.

Link to comment
Share on other sites

Hi, I have the same problem, the aircraft doesn´t fix attitude nor V/S and all the time is climbing without a reason. Even when Im making a takeoff I need to use more flaps to do it.

Do you have any kind of magical solution? thnks.

Link to comment
Share on other sites

I have the same effect like shown in the video. 

 

Obervations:

Is it right when changing wights via EFB, there is no change in simulator wights and fuel window? 

I set the cargo to 0i n EFB, click set payload an when I open the build in panal (where you ca refuel everywhree.. ) the cargo was not changend.

Also i never used the ingame variant, only via EFB.

 

Bild2.thumb.jpg.47e6388328c2df757693700f6e980ce7.jpg

Link to comment
Share on other sites

Issues Fixed!! -- I had to change my setting in MSFS to "Modern".  Somehow I was in "legacy" settings and once I changed the flight model to Modern, all issues went away.  Autopilot is stable, rotation speed is normal and the aircraft flies like a dream.

 

Hope this helps.

Flight Model.JPG

Link to comment
Share on other sites

Even I have set the flight model to Modern, after manually flying the plane to the altitude set at the AP with the correct speed, engaging AP starts a climb instead of just keeping the altitude . Using default payload and fuel, only sending the data to sim and FMS.

Regards, Herbert

Link to comment
Share on other sites

Hi, since the other thread was closed:

 

I am now completely enjoying this aircraft. What a fun to fly !!

 

What I did to fix MY issues, it may help others:

 

DE-installed the CRJ completely, removing its folder in COMMUNITY

Started MSFS  and made sure FLIGHTMODEL is set to MODERN !      It was on MODERN !  so  i toggled it back and forth, just to make sure

Applied and saved.

 

RE-installed the CRJ and started MSFS to have it rebuild its files !!

 

And there she goes. Everthing is working now AS EXPECTED. (excluded the issues with the known MSFS limitations)

 

OC i was fixed in assuming the CRJ had bugs, bc everything was /seemed to be set up correctly.

 

Three Greens

Oliver

Link to comment
Share on other sites

  • Developer
1 hour ago, Puukka said:

Even I have set the flight model to Modern, after manually flying the plane to the altitude set at the AP with the correct speed, engaging AP starts a climb instead of just keeping the altitude . Using default payload and fuel, only sending the data to sim and FMS.

Regards, Herbert

If you want to change from manual to autopilot flying it, first turn on the FD and assure it is showing properly in the middle. Then select the mode you want to use and again assure the FD is in the middle and only then switch on the AP.

Link to comment
Share on other sites

vor 1 hour , JetNoise sagte:

Hi, since the other thread was closed:

 

I am now completely enjoying this aircraft. What a fun to fly !!

 

What I did to fix MY issues, it may help others:

 

DE-installed the CRJ completely, removing its folder in COMMUNITY

Started MSFS  and made sure FLIGHTMODEL is set to MODERN !      It was on MODERN !  so  i toggled it back and forth, just to make sure

Applied and saved.

 

RE-installed the CRJ and started MSFS to have it rebuild its files !!

 

And there she goes. Everthing is working now AS EXPECTED. (excluded the issues with the known MSFS limitations)

 

OC i was fixed in assuming the CRJ had bugs, bc everything was /seemed to be set up correctly.

 

Three Greens

Oliver

I´ll trty at once, since I was in Legacy Mode before switching after the installation, thanks!

Link to comment
Share on other sites

vor 3 Stunden , metzgergva sagte:

If you want to change from manual to autopilot flying it, first turn on the FD and assure it is showing properly in the middle. Then select the mode you want to use and again assure the FD is in the middle and only then switch on the AP.

Well, I climb manually from airport to as example 5000ft. Flight Director is centered, I set AP from as example prer-selected 10000 to 5000ft, activate it, it shows ALT CAP and up it goes instead of just staying at the present altitude.

Regards,

Herbert 

 

Link to comment
Share on other sites

vor 8 Stunden , metzgergva sagte:

If you want to change from manual to autopilot flying it, first turn on the FD and assure it is showing properly in the middle. Then select the mode you want to use and again assure the FD is in the middle and only then switch on the AP.

I´ve just recorded a short vido showing this issue.

I´m stabile and settled at 5000ft, 250kts, FD is centered. ALT is armed at 5000ft.

I engage the AP and the plane starts a harsh climb well above the altitude.

Regards,

Herbert

 

Altitude Capture Issue - YouTube

Link to comment
Share on other sites

On 3/16/2021 at 7:58 PM, CaptMike2 said:

Hello!

 

Great to see the CRJ 700 flying in MSFS2020.  

 

There seems to be occasional issues with the Autopilot.  I often do not capture a successful ALT CAP with the autopilot on.  I have tried in both Speed and VS modes but the FD will show a level off yet the aircraft continues to climb or descend hundreds of feet.  Even thousands in some cases.  The flight director shows the correct vertical speed and even will show the level off, but the aircraft sometimes will continue and not follow the flight director guidance.  I also notice even after ensuring the weight and balance is correct, the ND trim is at 0.0 in flight.  I have tried various fuel levels and various payloads, all within CG and MAC limits, yet the trim at 0.0 seems a bit odd, from takeoff to touchdown with the auto pilot on.

 

When I was able to get the aircraft in a commanded descent from FL200 to 10,000 at a VS of 2500fpm, the FD and aircraft seemed stable, yet every 60 seconds or so, the aircraft would have an uncommanded pitch down to 3800fpm then back up to a climb of 1000fpm before settling back at 2500fpm descent.  I was not using the VNAV function and the auto pilot was set up correctly.

 

There were also deviations with lateral navigation.  While traveling from the intermediate fix to the final approach fix into KMSP, the FD showed a continued course which matched the FMS yet the aircraft began a turn to the left, while the Flight director showed a correct level flight to the next fix.  

 

Overall... Excellent aircraft and I am happy to have it in the simulation.  I look forward to continued updates and refinements. 

 

Cheers!

Hi, I'm having the same issues. The aircraft is not responding, no problems with take off and cruise (even though I have to costantly check that it does not deviate from its path despite FD, AP, NAV and SPD are engaged, but when it approaches the first point of the STAR, it deviates, it suddenly pitches down despite an ALT RESTRICTION is set up and I have never had the chance to land an instrumental approach. Did you solve your issue? 

Best

Saverio

Link to comment
Share on other sites

When reaching an altitude for the first time of the flight, engaging AP while PFD shows ALT CAP it tends to overshoot the altitude for some hundred feet.

Selecting AP before it shows ALT CAP captures it as it should.

Same strange behavior when dead on altitude and activating AP as seen in my video.

Regards, Herbert

Link to comment
Share on other sites

Same here. Either alts cap overshoot or a huge undershoot, leveling off hundreds of feet short of ASEL. LNAV is totally snaky, especially when select direct to. 
I hope the AP gets fixed in the next version. My CRJ is grounded until then. 

Link to comment
Share on other sites

I tried flying yesterday and for sobe reason the snaky lnav thing didn’t happen. I’m not sure if it has do to with winds or what. Regarding alts cap and alt, it MIGHT be because of abrupt pressure fluctuations in the sim, which is wrong but is not aerosoft’s fault. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...