Jump to content
Bill721

P3D shuts down after recent update 1.3.0.0

Recommended Posts

Since I updated P3D to 1.3.0.0 I can't start P3D if I select any of the Airbuses at startup.  It begins to start but just disappears.  If I load P3D with a different plane I can switch to the Airbus and it works fine.  I did an uninstall and reinstall of 1.3.0.0.

 

Any help would be appreciated

 

Bill

 

Share this post


Link to post
Share on other sites

Hi there
I also have the same problem (by the way, I already had it after updating the A330 to 1.0.0.5).
For me it has something to do with the default-flight. If an Airbus is stored in it, the P3D crashes when it is started.
Greeting
Stephan

 

Translated by google

Share this post


Link to post
Share on other sites

I installed the airbuses in c:addon folder as is suggested in this forum.  Do I need to create a linking document somewhere?  Do I need to install in the main p3d folder?  I tried uninstalling and then running P3D to see it saw the Airbuses were gone and then reinstalled but it still continues to disappear whenever I try to load P3D with Airbus selected at startup.

 

Balu1968 can you do a normal startup, not default, and select the airbus and see if it crashes like mine is?

 

Bill

Share this post


Link to post
Share on other sites

encountered the same error, immediately after installing version 1.3.0.0, going to load the plane the crash simulator

Share this post


Link to post
Share on other sites

Same here.

After update to 1.3.0 the A330 crash on loading

Share this post


Link to post
Share on other sites

I have McAfee antivirus and I need to turn off Real Time Scanning prior to starting P3DV4 if I am going to load any of the Airbuses.

 

I have the option to turn off for 15mins and this usually allows enough time to get P3DV4 started and the bus loaded and ready for cockpit preparation.  Use 30mins if you need longer.  When the time is up Real Time Scanning turns itself back on again and I usually don’t have any further problems for the rest of the session.

 

I do this every time I start P3DV4 if I’m going to use a bus.  If you have an option to view your Quarantined files in your anti virus and see an Aerosoft txt file, Documents/Aerosoft/ASC.log this is the one that causes me problems.

 

My antivirus does not like this file, even though I’ve selected it as an Excluded file (for Real Time Scanning).

 

I hope this solution works for others but if not, I’m sorry, but this is what works for me when P3DV4 disappears when trying to load an airbus.  And I did install with antivirus off, as an administrator, and restarted after successful installation.

Share this post


Link to post
Share on other sites

I don't use any antivirus, neither the windows10 default one

Share this post


Link to post
Share on other sites
4 minutes ago, klisura said:

I don't use any antivirus, neither the windows10 default one


ok sorry, I just share advice that works for me in this situation, if it can’t work for you I can’t help sorry.

Share this post


Link to post
Share on other sites

Mathijs Kok, it looks like we need some help...  Happy New Year!

 

Bill

Share this post


Link to post
Share on other sites

I partially solved deleting p3d.cfg and genereting a fresh one.

I say partially because when I press ok to loading the flight p3d freezes for 2 seconds ... it doesnt't crash but something mess my setup... I'm very disappointed.

Share this post


Link to post
Share on other sites

Hi

 

If you are having issues after updating the Airbus this might help:

 

Regards

 

Markus

 

Share this post


Link to post
Share on other sites

Guys, simply writing that P3D crashes isnt very helpfull. We need some more details, like:
- What is the exact error message? You can check the Windows Eventviewer for more details.

- Which exact version of P3Dv4 are you using. Please post the version number of the prepar3d.exe.

  • Like 1

Share this post


Link to post
Share on other sites

There is no error msg.  P3D gets to the point where you pick the plane, airport, time of day.  You select what you want.  Hit enter and the after a while the program closes.  You never get to where the slider bar loads P3D or anything.

 

I hope that helps.  If you need anything else let me know.  Thanks for looking into it.

Bill

Share this post


Link to post
Share on other sites

 

18 minutes ago, Bill721 said:

There is no error msg.  P3D gets to the point where you pick the plane, airport, time of day.  You select what you want.  Hit enter and the after a while the program closes.  You never get to where the slider bar loads P3D or anything.

 

I hope that helps.  If you need anything else let me know.  Thanks for looking into it.

Bill

Bill, delete p3d.cfg file (remember to backup or take a note of every single p3d setting, export joystick settings) then run p3d again in order to let it generate a new .cfg file

That solves the issue

Share this post


Link to post
Share on other sites

Same problem here.

 

since update to v1.3, p3d crashes when loading saved flights.
installation as recommended:
old version deleted, new version installed (admin, antivirus etc.) 


Latest p3d version 4.5.13.32097
prepar.cfg deleted. nevertheless again ctd.

 

Name der fehlerhaften Anwendung: Prepar3D.exe, Version: 4.5.13.32097, Zeitstempel: 0x5d8abf93
Name des fehlerhaften Moduls: ucrtbase.dll, Version: 10.0.18362.387, Zeitstempel: 0x4361b720
Ausnahmecode: 0xc0000409
Fehleroffset: 0x000000000006db8e
ID des fehlerhaften Prozesses: 0xd590
Startzeit der fehlerhaften Anwendung: 0x01d5c48327bb9f41
Pfad der fehlerhaften Anwendung: E:\Prepar3D v4\Prepar3D.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\ucrtbase.dll
Berichtskennung: 7090d026-cf59-4be6-aad2-5cf91f88c624

 

 

Robert

 

Aerosoft Version Info.TXT

Share this post


Link to post
Share on other sites
16 minutes ago, robby25451 said:

Same problem here.

 

since update to v1.3, p3d crashes when loading saved flights.
installation as recommended:
old version deleted, new version installed (admin, antivirus etc.) 


Latest p3d version 4.5.13.32097
prepar.cfg deleted. nevertheless again ctd.

 

Name der fehlerhaften Anwendung: Prepar3D.exe, Version: 4.5.13.32097, Zeitstempel: 0x5d8abf93
Name des fehlerhaften Moduls: ucrtbase.dll, Version: 10.0.18362.387, Zeitstempel: 0x4361b720
Ausnahmecode: 0xc0000409
Fehleroffset: 0x000000000006db8e
ID des fehlerhaften Prozesses: 0xd590
Startzeit der fehlerhaften Anwendung: 0x01d5c48327bb9f41
Pfad der fehlerhaften Anwendung: E:\Prepar3D v4\Prepar3D.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\ucrtbase.dll
Berichtskennung: 7090d026-cf59-4be6-aad2-5cf91f88c624

 

 

Robert

 

Aerosoft Version Info.TXT 3.63 kB · 0 downloads

Hi Robert

 

Have you tried the guide I linked to earlier on this topic?

 

Regards,

Markus

Share this post


Link to post
Share on other sites
1 hour ago, robby25451 said:

Same problem here.

 

since update to v1.3, p3d crashes when loading saved flights.
installation as recommended:
old version deleted, new version installed (admin, antivirus etc.) 


Latest p3d version 4.5.13.32097
prepar.cfg deleted. nevertheless again ctd.

 

Name der fehlerhaften Anwendung: Prepar3D.exe, Version: 4.5.13.32097, Zeitstempel: 0x5d8abf93
Name des fehlerhaften Moduls: ucrtbase.dll, Version: 10.0.18362.387, Zeitstempel: 0x4361b720
Ausnahmecode: 0xc0000409
Fehleroffset: 0x000000000006db8e
ID des fehlerhaften Prozesses: 0xd590
Startzeit der fehlerhaften Anwendung: 0x01d5c48327bb9f41
Pfad der fehlerhaften Anwendung: E:\Prepar3D v4\Prepar3D.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\ucrtbase.dll
Berichtskennung: 7090d026-cf59-4be6-aad2-5cf91f88c624

 

 

Robert

 

Aerosoft Version Info.TXT 3.63 kB · 1 download

Robert it's the scenario! That's why if you generate a new cfg p3d doesn't crash, because it starts with F22 default aircraft. While if you save a scenario with A320 then if you launch A330 you have a CTD.

So p3d has to start with a default aircraft 

Share this post


Link to post
Share on other sites
vor 1 hour , klisura sagte:

Robert it's the scenario! That's why if you generate a new cfg p3d doesn't crash, because it starts with F22 default aircraft. While if you save a scenario with A320 then if you launch A330 you have a CTD.

So p3d has to start with a default aircraft 

 

vor 3 Stunden , M4rk0 sagte:

Hi Robert

 

Have you tried the guide I linked to earlier on this topic?

 

Regards,

Markus

Thanks for your feedback.

 

yes, i have done the installation again as described in the new .pdf.

But i only have the a319/a318 and i did not delete the folder A3XX Flightplans.


p3d loads my default-scenario (A319 and EDDH) in the start window without problems.
when i confirm OK in the start window, p3d loads without ctd.

when loaded, you can also load an old  saved flight from there without ctd.

 

but since v 1.3. it is no longer possible as before (v 1.2.5) to load a saved flight directly from the start window using the "load" button without ctd.
regardless of whether the A319 or a p3d default-aircraft is loaded at program start.

(even deleting the prepar3d.cfg does not change this).

 

does anyone still have an idea / tip?

 

Robert

 

Share this post


Link to post
Share on other sites

Can you send me the scenario that you are trying to load so I can see if I can replicate it?

Share this post


Link to post
Share on other sites

Since I updated P3D Airbus Professional to 1.3.0.0  P3D won't completely load if I select any of the Airbuses at startup.  If I load P3D with a different plane I can switch to the Airbus and it works fine.  I did an uninstall and reinstall of 1.3.0.0.

I get no error msg.  P3D gets to the point where you pick the plane, airport, time of day.  You select what you want.  Hit enter and the after the circle just spins for a while;  P3D just closes down. 

I never get to where the P3D slider bar starts loading the  P3D scenario I loaded.  It's like P3D get lost and just shuts down.

 

I installed the airbuses in c:addon folder as is suggested in this forum.  

I did try to delete my p3d.cfg file and let it reload but that didn't help.

 

Mathijs thank you for you help..

Share this post


Link to post
Share on other sites

hello Mathijs,

 

as an attachment i send you (exemplary) all files concerning to my saved flight eedh-lkpr.
please note, that the ctd occurs no matter which scenario i choose with the load button.

i find it strange that all scenarios can be loaded if i have started and loaded my default scenario (A319cfm + EDDH) via "ok" in the start-window and then load another saved flight in p3d (Scenario/Load...).

 

Robert

EDDH-LKPR Prag vor Start RW5.wx eddh-lkpr prag vor start rw5.fms EDDH-LKPR Prag vor Start RW5.abx eddh-lkpr prag vor start rw5.asc EDDH-LKPR Prag vor Start RW5.fxml

Share this post


Link to post
Share on other sites
23 hours ago, robby25451 said:

hello Mathijs,

 

as an attachment i send you (exemplary) all files concerning to my saved flight eedh-lkpr.
please note, that the ctd occurs no matter which scenario i choose with the load button.

i find it strange that all scenarios can be loaded if i have started and loaded my default scenario (A319cfm + EDDH) via "ok" in the start-window and then load another saved flight in p3d (Scenario/Load...).

 

Robert

EDDH-LKPR Prag vor Start RW5.wx 163.64 kB · 1 download eddh-lkpr prag vor start rw5.fms 15.92 kB · 0 downloads EDDH-LKPR Prag vor Start RW5.abx 36 B · 1 download eddh-lkpr prag vor start rw5.asc 21.95 kB · 0 downloads EDDH-LKPR Prag vor Start RW5.fxml 105.68 kB · 0 downloads

 

We have no problems starting the sim with that. No idea why it causes an issue for you.

21 hours ago, Bill721 said:

 

Nothing in there that hints at a problem. Could you check the Eventlog of windows itself?

Share this post


Link to post
Share on other sites

For the people who are having problems with P3D shutting down, random CTD with the new Airbus 1.3.0 update, I ran into the same issues, but have  found the solution.  During the course of P3D 4.X development, I have been updating the Client and Content from my initial purchase of the 4.1 version to 4.5.  Once I updated to 4.5, and installed 1.3 version of the Airbus narrow bodies, Pmdg NGXu I started having random CTDs.  Removing such planes and returning to 4.4 was fix.  After consultation with Lockheed Martin's Prepar3d forums, I was instructed to delete my shaders folder, P3D.cfg and update my Nvidia drivers.  Apparently, P3D 4.5 Hotfix 2 has several changes under the hood that make it incompatible with the older shader files and cfg.  Aircraft like the AS Bus 1.3 and NGXu that are complied using the 4.5 SDK make these incompatibilities worse and cause stability issues.  Older aircraft compiled with the P3d 4.0 SDK show none of these issues/instabilities.            

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...