docolly

Erhebliche Geschwindigkeitsprobleme... Wo kann es hängen???

Recommended Posts

Moin zusammen,

ich habe, trotz Hardware aus dem Oberklassebereich, ganz erhebliche Geschwindigkeitsprobleme bei X-Plane 11. Gefühlt ist das auch seit dem letzten Update schlimmer geworden. Wenn ich von manchen hier Frameraten von 60 lese wird mir schwindlig und ich frage mich ernsthaft, wie die das machen. Wenn ich das Programm starte habe ich noch Frameraten von 22-24fps, im Verlauf rutsche ich aber auf 19 runter. Die Geschwindigkeits-Ratio bleibt aber konstant bei 1,0.

Hardware: ASUS  GL502V

Hardwaredetails: siehe Grafik.

Einstellungen X-Plane: siehe Grafik, hier kann ich ändern was ich will, runter oder rauf, es hat kaum einen nennenswerten Einfluss.

Egal, ob ich das Programm von SSD-HD oder konventioneller HD starte, kein Effekt

 

Hat irgendeiner von den Cracks hier eine Idee??

 

Danke im voraus! Ach ja, die Tips aus dem Forum habe ich alle abgearbeitet, ohne Erfolg

conf5.jpg

conf4.jpg

conf3.jpg

conf2.jpg

conf1.jpg

Share this post


Link to post
Share on other sites

Hallo!

 

Der Prozessor klingt zwar mit "i7 77xxx" schon mal ganz gut - leider hat er aber einen Standard-Takt von 2,8GHz und einen max. Turbo von 3,8 GHz. HQ halt, die Schlepptoppversion. Bestimmt eine tolle CPU für ein mobiles Gerät, reicht dann aber doch nicht ganz an die Dektop-CPUs heran. Vergleiche mal mit der "richtigen i7 7700K": Standard-Takt 4,2GHz (=+50%) und max. Turbo 4,4 GHz (immerhin noch +16%).

 

Viel spannender ist allerdings, was man XP noch an Aircrafts, Plugins und Szenerie auf die Schultern legt. Wenn Du allerdings sagst, Du hättest die vorhandenen Threads schon durchgearbeitet, bleibt vermutlich nicht mehr viel übrig, als sich mit eingeschränkteren Settings zufrieden zu geben.

 

Mein Tipp:

- Regler bei den Objekten eins runter: Das wird sicher helfen, ist aber bitter, verstehe ich gut... - ich kämpfe selber gerade darum, diese Einstellung halten zu können...

- Schatten abschalten (Stichwort settings.txt, siehe unten)

- Qualität der Texturen vielleicht eins runter (wobei ich vermute, dass die Grafikkarte sich eher langweilt)

- und nochmals hier schauen: http://board.vacc-sag.org/42/61516/

- und hier: 

 

 

Viel Erfolg!

Jörg

Share this post


Link to post
Share on other sites

Vielen Dank, hab die Objekte eins runter gedreht und hatte direkt zu Beginn fps-Raten von fast 50. Zu Begin......! Denn schon nachdem ich den FMC programmiert habe fielen diese auf die quälenden 20 runter.

Das komische ist nur, der Taskmanager zeigt mir eine Prozessorauslastung durch X-Plane von NUR 37-40% an, auch der arbeitet ja augescheinlich nur mit angezogener Handbremse.... Ich habe den Eindruck ich fahre einen Porsche nur bis zum zweiten Gang...

Hat jemand eine Erklärung hierfür?????

Share this post


Link to post
Share on other sites

....und jetzt wird es noch merkwürdiger....:

 

Drehe ich ALLE Regler nach links, alles ALLES auf minimal, dann fliege ich immer noch mit 19 fps.....!!!!!

 

Kann wohl nicht sein, oder?

Share this post


Link to post
Share on other sites

Moin,

 

da es sich wohl um einen Laptop handelt, eine Möglichkeit (damit wir nichts auslassen...):

Ist es denn sicher, dass überhaupt die Nvidia Grafik genutzt wird für X-Plane 11?

Oft ist es ja so, dass auf einem Laptop erstmal die Mainboard Grafik verwendet wird (falls vorhanden).

Das kann man in der Log.txt sehen. Die befindet sich im X-Plane 11 Hauptordner.

 

Wenn nicht, dann kann man das ja in der Nvidia Systemsteuerung einstellen, dass für die X-Plane.exe immer auch die 1070 genommen wird.

Siehe Bild.

 

Gruß Heinz

 

 

NVIDIA.jpg

Share this post


Link to post
Share on other sites

Interessanter Einwand, aber in dem NVIDEA Fenstern habe ich keine Einstellmöglichkeiten wie du unter Punkt 2

nvdia.jpg

Share this post


Link to post
Share on other sites

Hallo,

ok, möglicherweise gibt es keine Mainboardgrafik, oder sie ist abgeschaltet.

Hast Du mal in der Log.txt Datei nachgeschaut?

Oder lege sie mal als Datei-Anhang hier bei, wenn Du möchtest.

 

Ist denn der Video Treiber aktuell? Das müsste zur Zeit 435.61 385.69 sein.

Am Besten den vom Hersteller verwenden:

http://www.nvidia.de/Download/index.aspx?lang=de

 

Gruß Heinz

 

Share this post


Link to post
Share on other sites

@docolly Bitte überprüfe doch mal den Grafikspeicher. Teilt er sich den Speicher mit dem RAM oder hat er einen eigenen Speicherbereich?

Meistens ist ein sogenannter "dedizierter" Speicher für das Grafikteil nur 2 GB groß, und dann dürfte es an allen Stellen nur haken.

 

Grüße

Horst

Share this post


Link to post
Share on other sites

Am besten mal die FPS einblenden lassen (Häkchen bei Einstellungen --> Datenausgabe --> Framerate --> Im Cockpit anzeigen lassen).

 

Dann kann sehen, wo der Flaschenhals ist, also ob die CPU, oder die GPU begrenzt (letzteres vermute ich eher nicht). Ausgegeben wir dann unter CPU und GPU der Kehrwert der Framerate, die Zahl sollte also möglichst klein sein: 25 fps entsprechen beispielsweise 1/25 = 0,0400. Optimal wäre, bei beiden Angaben ungefähr gleiche Werte hinzubekommen, ist aber nicht zwingend notwendig und wird auch niemals 100%ig klappen. In dem oben bezeichneten thread findet man beispielsweise die Ausgabe cpu = 0,0357, gpu = 0,0155 und frame = 0,0368, was 27,148 fps entspricht. Man sieht, dass die CPU begrenzt, während sich die GPU im Prinzip langweilt (sie könnte eigentlich 1/0,0155 = 64,5 fps).

 

 

fps-tmp.JPG

fps-tmp2.JPG

 

Edit:

Schau Dir mal den xOrganizer an und schalte versuchsweise mal xLife und die zusätzlichen Flugplätze aus. Ich könnte mir vorstellen, dass da einer dabei ist, der die Frames herunter zieht (mir ist das mit Wismar-Müggenburg so gegangen).

Die Reihenfolge in der scenery_packs.ini solltest Du auf jeden Fall in Ordnung bringen. Erklärungen dazu findest Du hier im Forum. Das wäre aus meiner Sicht der wichtigste Ansatz!!! Der xOrganizer leistet dabei gute Hilfe!

Man erkennt in der log.txt auch noch, dass es Probleme mit der RescueX gibt, hier glaube ich aber nicht an den Verursacher.

Zusätzlich sieht man, dass Du noch KI-Verkehr anhast - den muss XP auch berechnen, was Leistung kostet. Brauchst die die KI-Flieger? Ich habe die in der Luft so gut wie nie gesehen...

Share this post


Link to post
Share on other sites

Falls es dir an bestimmten Flughäfen passiert behalte die Szenerie im Auge. Achte auf Anomalien, wie Pyramiden, Riesenschatten und dergleichen. Ich hatte beim Standard EDDH den Fehler, dass sobald ich in eine bestimmte Richtung geschaut habe ein Bodenfahrzeug oder Objekt wie eine Pyramide ins unendliche nach oben ging, was mich von 40 auf 3fps runterhaute, da eben sowohl der komplette Schatten, als auch das ins unendliche gehende Objekt dargestellt wurden. Auf einigen kleineren US Flughäfen waren es meist die Treppenfahrzeuge, die eine Pyramide in den Himmel erzeugten sobald man in einem bestimmten Winkel zum Objekt stand. 

Share this post


Link to post
Share on other sites

Ja! Ggf. erst einmal alles erdenkliche ausschalten = Häkchen entfernen im xOrganizer, und dann mal schauen, ob sich etwas verbessert. Dann schrittweise zuschalten und testen. Immer auf gleiche Testbedingungen achten, also gleiches Flugzeug, Flughafen mit viel Objekten (EDDH oder EDDK nehme ich immer), gleiches Wetter, KI usw. . Bei den abzuschaltenden Airports auch die zugehörigen und in dem Fall gerade nicht gebrauchten librarys mit abschalten! Ist etwas mühselig, aber normalerweise lernt man schnell, was wie viele fps kostet. Und im besten Fall erwischt man den Übeltäter.

Share this post


Link to post
Share on other sites

Moin.

 

Du hast mit über 93 Grad ein sehr großes Sichtfeld eingestellt. "Normal" sollte es nicht mehr als 70 Grad sein, dann werden auch weniger Objekte berechnet und dürfte sich positiv auf die Frames auswirken.

Wer eine detaillierte Szenerie mit guten Frames braucht (Heliflieger z. B. und das in 4K) ist immer noch besser mit X-Plane 10 dran.

 

Gruß Dieter

Share this post


Link to post
Share on other sites

Vielen Dank für alle Tips!

Ich habe sie alle abgearbeitet, leider ohne Effekt.

 

Die GPU langweilt sich bei 0,02-0,03, die CPU geht jedes mal im Verlauf hoch mit dem Effekt, dass die fps Rate auf 19-20 fällt....

 

Es scheint völlig egal zu sein, was ich zu- oder abschalte, das Phänomen bleibt das Gleiche.

 

Alle Treiber auf dem neusten Stand. Noch jemand eine Idee??????

Share this post


Link to post
Share on other sites

Hallo docolly,

 

meine Meinung dazu: Flach und schick, nur leider miese Kühlung. Denke mal das die Frames anfangs in Ordnung sind, weil das Notebook da noch kühl ist, später wird automatisch der CPU-Takt gedrosselt um den Prozessor vor Überhitzung zu schützen und deshalb gehen die Frames dann auch runter.

 

Gruß Thomas

Share this post


Link to post
Share on other sites

Dem Hinweis von eTronfly kannst Du leicht nachgehen:

Lade die kostenlose Version des HWMonitors ("Hardwaremonitor") herunter und lass ihn parallel zu XP11 laufen. Du kannst sofort erkennen, welche Temperaturen gerade vorliegen und unter "Clocks", ob die CPU von der Taktzahl heruntergeregelt wird - was beim i7 7700x glaube ich oberhalb von 100°C passiert und nach meinem Geschmack schon mindestens 15...20°C zu spät käme... . Jedenfalls könnte man diese Ursache für schlechte FPS schnell erkennen, bzw. ausschließen, wenn keine Temperaturerhöhung/-abriegelung vorliegt!

 

https://www.cpuid.com/softwares/hwmonitor.html

Share this post


Link to post
Share on other sites

Energiesparoptionen sind aus, CPU-Temepratur liegt zwischen 70 und 80 Grad, VCPU-Auslastung 29%, GPU auch bei 30%

Alle Werte nach Starten, stehend auf dem Airport. Anfangs Frameraten zwischen 25 und 30, nur stehenbleiben und x-plane laufen lassen führt nach ein paar Minuten zu einem Abfall auf 19 fps.

 

In meinen Augen ist die Hardware bereit, wird aber vom Programm nicht ausgelastet, oder?

Share this post


Link to post
Share on other sites

Doch, deine Hardware wird voll ausgelastet.

Der Hauptprozess von X-Plane ist noch immer zu einem Großteil nicht auf mehrere Prozessoren aufzuteilen. Daher wird ein Prozessor voll ausgelastet und bremst die Simulation entsprechend aus.

 

Das du nur 29% Auslastung angezeigt bekommst ist dabei völlig normal. Windows schiebt diesen voll ausgelasteten Prozess blitzschnell immer auf den sich ansonsten langweilenden Prozessoren hin und her. Da der Taskmanager oder andere leistungsmessende Programme immer einen aktuellen Durchschnittswert der Leistung anzeigen, sieht es so aus, als ob alle Prozessoren ca. 25% leisten würden. Dabei leistet jeder Prozessor für ungefähr 1/4 seiner Betriebszeit 100% und für 3/4 seiner Zeit 0%.

 

Wenn du über den Taskmanager den X-Plane Prozess auf nur einen Prozessor beschränkst, wirst du sehen, dass plötzlich ein Prozessor beständig auf 100% arbeitet und alle anderen bei 0 % böeiben. Deine Auslastung bleibt dann insgesamt bei um die 29% (je nachdem was der Prozessor noch im Hintergrund zu tun hat).

 

Wenn jemand mit einem i7-6700k (4GHz Leistung) etwa um die 45-60 fps schafft, dann hast du mit der HQ version mit nur 2,8 GHz Leistung folgerichtig nur 31 bis 42 fps (nur ca. 70% des 6700k). Das ganze aber vorausgesetzt, das dein Rechner ansonsten exakt gleich schnell ist wie das Musterbeispiel mit dem i7-6700k. Da in Laptops aber meist auch das Mainboard und andere Bausteine nicht die gleiche Leistung schaffen, wie die mit großen Kühlungen versehenen Hochleistungsbausteine eines Desktop-PCs, ist es im Grunde zu erwarten, dass du nur 25 bis 30 fps schaffst.

 

Du musst also die Anforderungen senken!

Hier ist ein sehr großer Tipp, über einen recht harten Eingriff in X-Plane 11 die Extended DSF Funktion wieder abzuschalten. Dadurch lädt X-Plane 11 wieder nur 6 Kacheln wie zu X-Plane 10 Zeiten anstelle von 12 Kacheln.

Am Boden stehend sieht man dadurch keinen Unterschied in der Grafik, fliegt man jedoch sehr hoch, bemerkt man, dass die Sichtweite beschränkt ist und man schon am recht nahen Horizont keine gute Szenerie mehr sieht, sondern eine sehr grobe "Weltkugeldarstellung" .

 

Hier sind Vergleichsbilder aus XP10 mit und ohne extended DSF:

http://developer.x-plane.com/2015/03/extended-dsfs-in-x-plane-10-40/

 

Um auch X-Plane11 wieder von 4x3 auf 3x2 Kacheln zu beschränken musst du die settings.txt datei ändern. Dabei sind folgende Überlegungen aber sehr wichtig:

  1. X-Plane möchte bei jedem Update diese settings.txt wieder auf den originalstand zurück setzten. Das kann man dem Updater zwar verbieten, jedoch verpasst man auf diesem Wege eventuell wirklich wichtige Veränderungen in dieser Datei, die durch ein Update vorgenommen werden sollen. Daher sollte man diese Datei bei jedem X-Plane update mit updaten lassen und die Änderungen anschließend wieder händisch einfügen.
  2. Grundsätzlich ist es NICHT VORGESEHEN, diese Datei zu ändern und es kann durchaus zu Fehlern in X-Plane 11 kommen. (ich konnte bislang keine Fehler feststellen, nur die X-Plane11 Karte braucht die Kacheln, weshalb hier der Kartenausschnitt und die Zoomfunktion stark eingeschränkt ist)

Für mich konnte ich feststellen, dass X-Plane 11 dank der bisherigen Optimierungen nun ohne extended DSF grundsätzlich genau so schnell läuft wie X-Plane10 und teilweise sogar höhere fps bringt (dank der gegenüber XP10 optimierten Autos usw.)

 

Wenn du also trotz der GEfahren diese Änderungen versuchen möchtest, hier die nötigen Änderungen:

 

Du musst in der Datei die Zeile mit:

SETTING DRAW POPUP renopt_draw_3d_04 

finden. Anschließend musst du folgende Dateien irgendwo in der Textdatei neu hinzufügen. Du darfst aus der Textdatei nichts löschen, sondern musst diese zusätzlichen Zeilen einfügen. Dies reaktiviert die Option der extended-dsf in X-Plane 11 wieder und setzt als Standard, dass die extended-dsf für jede Grafikeinstellung im Menü abgeschaltet wird.

SETTING_1 renopt_draw_3d_04 0 geoid/extended_dsfs 0 
SETTING_1 renopt_draw_3d_04 1 geoid/extended_dsfs 0 
SETTING_1 renopt_draw_3d_04 2 geoid/extended_dsfs 0 
SETTING_1 renopt_draw_3d_04 3 geoid/extended_dsfs 0 
SETTING_1 renopt_draw_3d_04 4 geoid/extended_dsfs 0

Nach dieser Änderung wird X-Plane11 tatsächlich nur die Hälfte der ursprünglichen Szenerie laden und sollte dir bei deinem Laptop einen deutlichen Sprung verschaffen...

 

Philip

  • Upvote 1

Share this post


Link to post
Share on other sites
vor 40 Minuten, ubbi sagte:

Wenn du über den Taskmanager den X-Plane Prozess auf nur einen Prozessor beschränkst, wirst du sehen, dass plötzlich ein Prozessor beständig auf 100% arbeitet und alle anderen bei 0 % böeiben. Deine Auslastung bleibt dann insgesamt bei um die 29% (je nachdem was der Prozessor noch im Hintergrund zu tun hat).

Wie genau macht man das?

 

edit: gerade selbst gefunden und probiert: dann schafft es X-Plane nicht mal zu laden und als ich mir die Auslastung der Kerne anschaute zeigte sich, dass mehrere Kerne beim Starten voll ausgelastet waren.

Share this post


Link to post
Share on other sites

@ubbi: Vielen Dank für den ausführlichen Beitrag!

Ich habe die alte Zeile belassen und die von dir genannten in dem Block unterhalb eingefügt.... Leider KEIN Effekt! Oder mach ich da was falsch?

Share this post


Link to post
Share on other sites

Ich persönlich habe auch mit den extDSF in der settings.txt herumprobiert, diese bei mir aber wieder aktiviert. Die Schatten auszuschalten hat mir sehr geholfen. Anbei mal meine Dateien, aus den Bezeichnungen geht einigermaßen hervor, was ich geändert habe.

Am besten vorher die originale Datei sichern (einfach umbenennen). Dann die gewünschte Datei nach "settings.txt" umbenennen und mal schauen, ob es was bringt!

 

Gruß,

Jörg

 

 

settings - Forum v4 - extDSF-on+clouds-lighten-off+shaddows-off.txt

settings - Forum v3 - extDSF-off+clouds-lighten-off+shaddows-off.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now