Jump to content
maydayc

reshade - Der OpenGL Shader injector auch für X-Plane

Recommended Posts

Hallo godmann,

danke für die Einstellungen. Das scheint aber nicht die vollständige Datei zu sein. Meine ist viel größer und hat mehr Einstellungsmöglichkeiten.

Versuche doch bitte, die Datei zu zippen und dann anzuhängen. Sollte funktionieren.

Danke!

Share this post


Link to post
Guest

Hallo Schorle,

ich habe nur das Kopiert was ich verstellt habe, alles andere habe ich so gelassen, deshalb habe ich nicht alles kopiert. Was mir am meistens gebracht hat sind diese Einstellungen, die standen vorher auf null, und die habe ich auf 1000 erhöht.

/*-----------------------------------------------------------.
/ FXAA Anti-aliasing settings /
'-----------------------------------------------------------*/
#define FXAA_QUALITY__PRESET 9 //[1 to 9] Choose the quality preset. 9 is the highest quality.
#define fxaa_Subpix 1.000 //[0.000 to 1.000] Choose the amount of sub-pixel aliasing removal. Higher values makes the image softer/blurrier.
#define fxaa_EdgeThreshold 1.166 //[0.000 to 1.000] Edge detection threshold. The minimum amount of local contrast required to apply algorithm. Similar to SMAA_THRESHOLD
#define fxaa_EdgeThresholdMin 1.000 //[0.000 to 1.000] Darkness threshold. Pixels darker than this are not processed in order to increase performance.

Share this post


Link to post

Hallo

bin ebenfalls sehr überzeugt von reshade. Top Sache :excellenttext_s:

Frage:

Meine Menuschrift in xplane ist leicht verschwommen. Gibt es eine Einstellung die die Schrift klarer macht ?

Vielen Dank für die Hilfe.

Share this post


Link to post

Funzt auch bei mir (Treiberversion 350.12) super, vielen Dank für den Tipp maydayc!

ReShade ist ne echte Bereicherung, so wie es auch schon JSGME war :glare_s:

Frage:

Meine Menuschrift in xplane ist leicht verschwommen. Gibt es eine Einstellung die die Schrift klarer macht ?

Hast du dieses Problem erst mit ReShade?

Gruß

Daniel

Share this post


Link to post

Glaube nicht das es ein Problem von Treiber oder Reshade selber ist.

Das Tool setzt den Filter ja nicht nur auf die Grafik sondern das Gesamte X-Plane Bild incl. Menü, dadurch wird alles beeinflusst.

Wahrscheinlich musst die Einstellung der INI anpassen, man kann da die Schärfe und den Blure Effekt ändern.

Bei mir ist die Menü Schrift eher zu Scharf dadurch wirkt sie auch nicht sauber, aber das Bild gefällt mir so.

Share this post


Link to post

Bei mir wird das alles irgendwie zu "überstrahlt" Als ob Gamma zu hoch wäre. Hab aber an der Konfiguration noch nix geändert. Weiß jemand woran das liegt? Und warum funktioniert die Screenshotfunktion von XPX nicht? Wenn ich einen Screenshot mache wird nur das normale Bild aufgenommen wie wenn Reshade aus wäre.

Share this post


Link to post

Das Plugin is ne super Bereicherung für X-Plane, ich hatte no nie so scharfe Phototexturen (Dank Luma Scharpen) sowie Kontrastverbesserung und vielen mehr. Man muss hald einefach ausprobieren und sich ran tasten.

 

Hier einige Bilder

 

Mehr Bilder hier zu finden http://at.forum.ivao.aero/index.php?topic=262422.0

 

h2mwu.png

 

gYOzx.png

 

h2mtc.png

 

h2mWr.png

 

h2mKC.png

 

 

h2mBA.png

Kannst du bitte deine Config-Datei hochladen ;) Sieht nämlich echt super bei dir aus.

Share this post


Link to post

Hallo.

Nachdem ich von euren guten Ergebnissen überzeugt wurde habe ich nun auch reshade installiert.

Aber wie man sehen kann mit keinem guten Ergebnis, denn X-Plane wird bei mir nur noch halbiert dargestellt.

Habe gem. maydayc  Installationsanweisung reShade installiert, aber was ist da bei mir schief gegangen?

Danke und mit Gruß,

Dieter

 

X-Plane mit reShade 2.jpg

X-Plane mit reShade.jpg

Share this post


Link to post

Hallo Heinz Dieter,

1. Was für eine ReShade Version hast du installiert ?

2. Verschwindet das Problem wenn du ReShade mit der scrolllock Taste (Rollen Taste) deaktivierst ?

3. Welchen NVIDIA Treiber hast du installiert ?

4. Ist vielleicht #define USE_SPLITSCREEN   1 gesetzt ? ... poste doch mal deine SweetFx_settings.txt Datei

 

Share this post


Link to post

Du installierst anscheinend mit dem "ReShade Setup.exe" Programm aus dem Archiv.

Versuch doch mal das Archiv direkt im X-Plane Verzeichnis auszupacken. Wenn du die *.7z Datei geöffnet hast dann kannst
alle Dateien auswählen und mit der Maus in das X-Plane Verzeichnis schieben. Dann entsteht auch das SweetFX Verzeichnis. 

Share this post


Link to post

Danke für Deine Hilfe.

Habe zum wiederholten Male die zip Datei entpackt - innerhalb und außerhalb von X-Plane - aber ein SweetFX Verzeichnis wollte sich einfach nicht generieren. Jetzt, nachdem ich auch mehrmals die zip Datei neu geladen habe, ist es bei mir so, wie Du es auch beschrieben hast. Warum es nicht von Anfang an zum "ordentlichen" Entpacken kam ist mir allerdings ein Rätsel.

Nun kann ich mich an die Gestaltung von x-Plane machen.

Schöne Grüße,

Dieter
 

Share this post


Link to post

Hallo zusammen,

habe heute durch zufall diesem Tip entdeckt und direkt ausprobiert. 

Programm runtergeladen -> entpackt und nach Anweisung von maydayc installiert. Nur dummerweise erzielte das nicht das erwünschte Ergebnis. 

Hab ich das richtig verstanden das Sweet FX und Framework seperate Unterordner im Ordner X-Plane sind?

Muss die ReShade64.dll im Frameworkordner auch umbenannt werden? Muss auf Groß-bzw.Kleinschreibung geachtet werden.

Wäre nett wenn ich Unterstützung bekäme.

Gruß Mike

Share this post


Link to post

Hallo Mile_001 

Ich kann leider nur zu einer älteren Version erst einmal was sagen. Ich verwende zur Zeit noch die Version 0.19.2.905.
Eine Framework Verzeichnis habe ich nicht. In meiner älteren Version gibt es nur das SweetFX Unterverzeichnis.
Reshade64.dll muss nur im X-Plane10 Hauptverzeichnis auf opengl32.dll umbenannt werden.
Alles andere sollte so bleiben wie vorher.  

Welche Version von reShade hast du installiert ? 

Gruß madayc

Share this post


Link to post

Hallo maydayc,

vielen Dank für deine rasche Antwort. 

Ich habe gestern die Version 1.0.0 runtergeladen.

Ich probiere es heute nochmal. Vielleicht bekomme ich es ja heute zum laufen. :angry:

 

Gruß Mike

Share this post


Link to post

Hallo XP-Flieger,

vielen Dank für die Unterstützung. 

Habe mir die Version 1.0.0 nochmal runtergeladen, ins Hauptverzeichnis von XP10 entpackt und natürlich das was umzubenennen war umbenannt.

Nach dem XPlane Start kam folgende Anzeige

--> ReShade 1.000.....bla bla bla

      Compiling effect ----FAILED!!!!   

F:\x-plane 10\sweet.fx(236, 35): error X3004: undeclared identifiert `ReShade_Sart_Enabled

F:\x-plane 10\sweet.fx(236, 56): error X3000: syntax error: umexpectet`;`, expected`{`

 

:beatcomputer_s:

Share this post


Link to post

Nein, die sweet.fx habe ich nicht bearbeitet. Ich kann die FX-Datei noch nicht einmal öffnen. 

Ja. ich habe alle ordner zuvor gelöscht.

Ich probiere es noch ein paar Mal. Mal schauen, wäre toll wenn es klappen würde. 

Trotzdem vielen Dank für den Support. 

Gruß Mike

 

Share this post


Link to post

Hallo,

ich habe eine gtx980 mit der Treiberversion 358.91 auf der WIN10 Plattform am laufen.

Share this post


Link to post

Das ist doch echt zum verrückt werden...ich weiß nicht was ich getan habe aber nun bringt er mir die Meldung 

Loading effect...No effect found !

:beatcomputer_s:

Irgendetwas elementares mach ich wohl falsch. Aber was????:angry2_s:

Share this post


Link to post

Hallo,

Ich habe alles installiert nach Anleitung und anscheinend funktioniert es auch.

Ohne irgendwas an den Einstellungen in der sweet.fx zu ändern bekomme ich aber ein heftig dunkleres Bild geliefert.

Schalte ich ReShade ab, wird´s wieder normal (siehe Bilder)

Irgendeine Idee, was man machen muss, um die Helligkeit zu korrigieren?

Erwähnen tue ich mal, dass ich eine AMD 7900 habe.

 

resh2.thumb.JPG.fc5ac4d4e3014f9f90ebe342resh1.thumb.JPG.8210edb99aa690972eb16c94

so long, MjTom

 

Share this post


Link to post

.....also nachdem was ich hier gelesen habe musst du wohl an den settings rumspielen. Mehr kann ich dir dazu noch nicht sagen, bei mir will das Programm einfach nicht funktionieren. :cussing_s:  

Share this post


Link to post

Vielleicht hast du nicht alle Dateien ins X-Plane-Hauptverzeichnis kopiert.

Ich selber hatte die Datei Reshade.fx nicht mitkopiert, weil die bei früheren Versionen noch nicht mit dabei war, und bekam die gleiche Fehlermeldung.

Im Hauptverzeichnis von X-Plane müssen sich folgende Dateien befinden:

Sweet.fx
ReShade.fx
opengl32.dll

Außerdem muss noch ein Ordner namens SweetFX dort vorhanden sein.

Viel Glück!
Thomas

Share this post


Link to post

Ja .. genau!  eTronFly hat es schon geschrieben aber hier noch mal zwei Screenshots wie das aussehen sollte.
 

 

ReShade2.jpg

ReShade1.jpg

  • Upvote 1

Share this post


Link to post

Hallo,

Ist alles drin und ich kann in den sweetFX_settings auch Änderungen vornehmen mit Auswirkung.

Problem ist nur, dass beim Einschalten alles viel dunkler und somit unrealistisch wird.

EDIT :  Übeltäter gefunden, wenn ich bei #define USE_SMAA   0 //[0 or 1] eine 1 setze bekomme ich den Effekt.

resh4.thumb.JPG.d790ee0f2db4c00301eb3304resh3.thumb.JPG.e29b1a51d27262ea100544f4

Share this post


Link to post

USE_SMAA = 1 bedeutet das eine zusätzliche Kantenglättung aktiviert wird. Damit flimmern die Texturen weniger und das Bild wirkt ruhiger. 
Das hat aber auch einen Nachteile. Aus irgendwelchen Pixeldaten muss ja der Rechner die Kantenglättung berechnen und
das führt dazu das Daten anders interpretiert werden oder wegfallen. Bei diesem SMAA Algorithmus (in dieser SweetFX Umsetzung)
führt das dann zu einer Reduzierung der Helligkeit bei schon dunklen Flächen im Bild. 

Das kann aber auch wieder kompensiert werden. Dazu einfach USE_LIFTGAMMAGAIN  oder !!! USE_TONEMAP aktivieren und
die Parameter weiter unten in der  SweetFX_Settings.txt anpassen:

LIFTGAMMAGAIN
#define RGB_Lift  float3(1.000, 1.000, 1.000)  //[0.000 to 2.000] Adjust shadows for Red, Green and Blue.
#define RGB_Gamma float3(1.000, 1.000, 1.000)  //[0.000 to 2.000] Adjust midtones for Red, Green and Blue
#define RGB_Gain  float3(1.000, 1.000, 1.000)  //[0.000 to 2.000] Adjust highlights for Red, Green and Blue

TONEMAP
#define Gamma       1.000  //[0.000 to 2.000] Adjust midtones. 1.000 is neutral. This setting does exactly the same as the one in Lift Gamma Gain, only with less control.

Dann wird das Bild auch wieder heller und die Kantenglättung sieht auch noch gut aus.  

Natürlich geht aber auch in den Einstellungen -> Darstellungsoptionen den Gamma Wert (oben Rechts) zu erhöhen ... dazu muss aber XP neu gestartet werden. 
 

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...