Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
Mathijs Kok

SODE issues

Recommended Posts

49 minutes ago, radeon29 said:

Yes, the new soda has been substantially changed, newest AS scenary for P5 now give an error:

 

EDDV

[13:03:56.846] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\JustSim_EDDV_VDGS.xml'
[13:03:56.848] WARN SODE.XML : [VDGS] SimObject 'VDGS GATE 16', Stop@22.600000: AcftType='NOT DEFINEDALL_ACFT' is not supported by SODE!

---

LZKZ

[13:03:56.903] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\LZKZ_Kosice_rain.xml'
[13:03:56.903] WARN SODE.XML : Environmental Data Probe 'LZKZ_Kosice_rain': Listed Client SimObject '' does not exist in the XML!

---

EDDF

[13:03:56.746] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\AJS_EDDF_SODE.XML'
[13:03:56.747] WARN SODE.XML : Environmental Data Probe 'EDDF': Listed Client SimObject '' does not exist in the XML!

---

EGLL

[13:03:56.761] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\AJS_EGLL_SODE.XML'
[13:03:56.762] WARN SODE.XML : Environmental Data Probe 'EGLL': Listed Client SimObject '' does not exist in the XML!

---

 

It seems that testers did not check these scenary  with soda, although the release of the new soda was a very long time ago, already on May 12!

 

Sorry, but the first two issue are not Aerosoft related and the two regarding EDDF and EGLL are just a Warning, Sode will gernerate in his log.

It is not an error and the Environmental Data Probe is simple not needed in SODE files for EDDF and EGLL, which do not placeing any objects needs weather related infos.

It makes no sense to define a Probe (which loads a simobject), when the clientlist is empty, as non of the placed Objects is related to data's of the probe. Simple generates codes not used.

 

You can contact Jeffrey and ask him to remove the warning as long as there is no object in the xml needing data of an Environmental Data Probe.

 

So no need to blame testers, when you seams not to know how SODE works internaly.

Share this post


Link to post
Share on other sites

 

Hi Oliver !

 

13 minutes ago, OPabst said:

Sorry, but the first two issue are not Aerosoft related

yes sorry, the first one by mistake, this refers to JustSim.

the second problem is exactly your scenario, I already fixed it, I already wrote to the developer, I think he will soon find it the same.

 

13 minutes ago, OPabst said:

It is not an error and the Environmental Data Probe

well let's call it a problem, but no matter how we call it, it should not be...

 

13 minutes ago, OPabst said:

You can contact Jeffrey

I fixed it myself, I think the developer will see this message and make a fix for everyone.

 

Share this post


Link to post
Share on other sites
2 minutes ago, radeon29 said:

 

Hi Oliver !

 

I fixed it myself, I think the developer will see this message and make a fix for everyone.

 

No, you talk with the developer and he will not "fix" an non existing issue, only because the SODE code is generating a warning, simple not needed.

Share this post


Link to post
Share on other sites
13 minutes ago, OPabst said:

No, you talk with the developer

the developer of specifically this scenary  is Maxim, he said that he is looking for a problem, I already found this: extra characters caused a problem...

 

13 minutes ago, OPabst said:

SODE code is generating a warning

SODE  warnings are probably not just(senselessly) created?

Share this post


Link to post
Share on other sites
29 minutes ago, radeon29 said:

the developer of specifically this scenary  is Maxim, he said that he is looking for a problem, I already found this: extra characters caused a problem...

 

SODE  warnings are probably not just(senselessly) created?

I talk about EDDF and EGLL you have in your post, in case of LZKZ I am not envolved and did not see this Airport before. Ok, it is Aerosoft related, as they are the publisher here.

And based on the name of the xml 'LZKZ_Kosice_rain' it could be expected, that in this case the Probe is needed. This developer needs maybe to fix it.

But in case of EDDF and EGLL you listet too, no needs to fix anything.

I have send Jeffrey (developer of SODE) an email, if he can remove the warning in case of no need of it and may change it to an Error, when a object is included, that needs the probe for it's function.

  • Upvote 1

Share this post


Link to post
Share on other sites
45 minutes ago, OPabst said:

But in case of EDDF and EGLL you listet too, no needs to fix anything.

 

45 minutes ago, OPabst said:

I have send Jeffrey (developer of SODE) an email

ok, I’m waiting, will be good  if  the soda developer, can remove the warning, I also wrote him, thx!

Share this post


Link to post
Share on other sites
5 hours ago, radeon29 said:

Yes, the new soda has been substantially changed, newest AS scenary for P5 now give an error:

 

EDDV

[13:03:56.846] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\JustSim_EDDV_VDGS.xml'
[13:03:56.848] WARN SODE.XML : [VDGS] SimObject 'VDGS GATE 16', Stop@22.600000: AcftType='NOT DEFINEDALL_ACFT' is not supported by SODE!

---

LZKZ

[13:03:56.903] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\LZKZ_Kosice_rain.xml'
[13:03:56.903] WARN SODE.XML : Environmental Data Probe 'LZKZ_Kosice_rain': Listed Client SimObject '' does not exist in the XML!

---

EDDF

[13:03:56.746] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\AJS_EDDF_SODE.XML'
[13:03:56.747] WARN SODE.XML : Environmental Data Probe 'EDDF': Listed Client SimObject '' does not exist in the XML!

---

EGLL

[13:03:56.761] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\AJS_EGLL_SODE.XML'
[13:03:56.762] WARN SODE.XML : Environmental Data Probe 'EGLL': Listed Client SimObject '' does not exist in the XML!

---

 

It seems that testers did not check these scenary  with soda, although the release of the new soda was a very long time ago, already on May 12!

Just my two cents....
EDDV....change to AcftType='ALL_ACFT'
LZKZ just remove the not required listed client LZKZ_Kosice_rain, if all other simobjetcs in the file match with the listed clients
EDDF, EGLL remove the complete Simobject part of the Dataprobe, if it is not required.

  • Upvote 1

Share this post


Link to post
Share on other sites
53 minutes ago, masterhawk said:

Just my two cents....

LZKZ just remove the not required listed client LZKZ_Kosice_rain, if all other simobjetcs in the file match with the listed clients
EDDF, EGLL remove the complete Simobject part of the Dataprobe, if it is not required.

Ja, habe mir EDDF und EGLL angesehen, da war noch eine nicht benötigte Probe drin, aber mit leerer ClientList

 

    <SimObject Name="EDDF" >
        <Placement Lat="50.033334" Lon="8.570555" Alt="110.95" Hdg="0.0" />
        <Model SimTitle="12bPilot_SODE_Environmental_Data_Probe" >
            <EnvironmentalDataProbe ClientList="" />
        </Model>
    </SimObject>

 

Da macht die Warnung

WARN SODE.XML : Environmental Data Probe 'EDDF': Listed Client SimObject '' does not exist in the XML!

aber auch nicht wirklich Sinn, denn die interpretiere ich so, dass ein Objekt, das dort unter Clientlist gelisted ist, nicht im XML vorhanden ist. Bei eine leeren Liste nach einem leeren Objektnamen ('') zu suchen, passt das nicht wirklich.

 

Wird aber bei LZKZ das gleiche sein, weil 'LZKZ_Kosice_rain' ist sicher wie bei EDDF der SimObject Name des Probe Objectes (wie bei EDDF), nach Listed Client SimObject steht ja auch nichts in den '' Anführungszeichen.

Also eine Probeobject mit leerer Liste kann man einfach weglassen.

Share this post


Link to post
Share on other sites
5 hours ago, masterhawk said:

Just my two cents....

yes, I already fixed it for myself, although setting AcftType = 'NOT DEFINEDALL_ACFT' I think was intentionally done by the developer(this was done intentionally for some purpose), but it doesn't seem to work correctly...

 

5 hours ago, masterhawk said:

LZKZ just remove the not required listed client LZKZ_Kosice_rain,

I already fixed it for myself, the problem was a text error, tag closing was not performed correctly:

; "/> was

"/> should

---

I have a more serious problem, neither I nor the scenary developer(AS non developer this) knows the solution, everything looks right, but we get a warning: 

WARN SODE.XML : Environmental Data Probe ‘LTAI’: Listed Client SimObject ‘LTAI_SVET2’ does not exist in the XML!

lt.thumb.jpg.83d7921f374c7fc473bf72c4cc495636.jpg

Share this post


Link to post
Share on other sites

Thanks to everyone, separately "radeon29", for identifying a bug in LZKZ. I did not see her on time. In the coming days I will fix it and include it in the updates. Also check Poprad, which is preparing for release. 

  • Upvote 1

Share this post


Link to post
Share on other sites
32 minutes ago, radeon29 said:

I have a more serious problem, neither I nor the scenary developer(AS non developer this) knows the solution, everything looks right, but we get a warning: 

WARN SODE.XML : Environmental Data Probe ‘LTAI’: Listed Client SimObject ‘LTAI_SVET2’ does not exist in the XML!

lt.thumb.jpg.83d7921f374c7fc473bf72c4cc495636.jpg

The picture is maybe not the best way to provide the issue and solve it, simple to attach the xml file here in the post could help better.

1.) The critical simobject is not shown completely, the end tag </Simobject> is missing.

if it is not in the file, this could result in the issue, that SODE don‘t see the object with the name „LTAI_SVET2“
2.) I don‘t know, if the naming in SODE is case sensitive, the ClientList has the Name in capitals, the Name of the Simobject is „LTAI_Svet2“, which is not the same, if the check is a case sensitive.

 

  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, OPabst said:

 I don‘t know, if the naming in SODE is case sensitive

I also thought about it, I specifically conducted this tests and it turned out that it does not matter.

 

1 hour ago, OPabst said:

</Simobject> is missing.

you made me think again and oops, it turned out that on the contrary there was an excess tag, because it was already higher then it is not needed again:



lt.thumb.jpg.b7608402134ed69c75c55e0324b5b7b2.jpg

or did i do it wrong?

 

p/s yes, I did it wrong, this is another SIM object and I should not have deleted the closing tag:

ERROR SODE.XML : Failed to load file 'C:\ProgramData\12bPilot\SODE\xml\LTAI.xml

Share this post


Link to post
Share on other sites

The question is, was is below the </Model> tag at the end of your „picture“.

The next line should be the </Simobject> endtag, that close the <Simobject name=LTAI_Svet2“> starttag of this object.

After that, the next <Simobject name=„LTAI_Grass“> should follow.

But what we don‘t see, we could only make speculations.

 

And, you know, that Justsim should solve your issues, you never could pay my invoice for that ;)

 

Share this post


Link to post
Share on other sites
1 hour ago, OPabst said:

2.) I don‘t know, if the naming in SODE is case sensitive, the ClientList has the Name in capitals, the Name of the Simobject is „LTAI_Svet2“, which is not the same, if the check is a case sensitive.

Most likely. I changed it in my install, but forgot to check the log again, will do it tomorrow.

Share this post


Link to post
Share on other sites
34 minutes ago, OPabst said:

The next line should be the </Simobject> endtag,

yes, there is a tag there(below under the spoiler I posted more .xml code).

 

34 minutes ago, OPabst said:

that Justsim should solve your issues

yes, but they are not in a hurry with this, and I myself am interested in finding a solution, thanks for helping.

 

22 minutes ago, masterhawk said:

Most likely.

it is interesting, it looks like it really is so but not in all cases, a riddle...

 

I changed only: LTAI_SVET to LTAI_Svet2 and now there are no warning now:

 

 


<SODE>    
    <SimObject Name="LTAI">
        <Placement Lat="36.902732" Lon="30.797465" Alt="53.949" Hdg="6.27"/>
        <Model SimTitle="12bPilot_SODE_Environmental_Data_Probe">
        <EnvironmentalDataProbe ClientList=
        "LTAI_SVET;LTAI_Svet2;LTAI_Grass"/>
        </Model>
    </SimObject>

   


        <SimObject Name="LTAI_SVET">
        <Placement Lat="36.902732" Lon="30.797465" Alt="0.0#AGL" Hdg="6.27"/>

        <Model SimTitle="LTAI_SVET">
       <ConditionalVisibility Variable="TimeOfDay" Value="DAWN;DUSK;NIGHT"/>
        </Model>

    </SimObject>
    <SimObject Name="LTAI_Svet2">
        <Placement Lat="36.902732" Lon="30.797465" Alt="0.0#AGL" Hdg="6.27"/>

        <Model SimTitle="LTAI_Svet2">
        <ConditionalVisibility LogicExpression="A$B|C">
             <Condition ID="A" Variable="MonthOfYear" Value="JAN-DEC"/> 
             <Condition ID="B" Variable="TimeOfDay" Value="DAWN;DUSK;NIGHT"/> 
             <Condition ID="C" Variable="MetVisibility" Value="0-5000"/>               
          </ConditionalVisibility>
        

</Model>

    </SimObject>
 

 

---

 

but why then no warning for LTAI_SVET, because the naming(letter size)  is different(.xml=LTAI_SVET,  SimObjects=model.LTAI_Svet)?:

 

ltai1.jpg.1e1d07e50dda51189b3be8d29408ccad.jpg

 

Share this post


Link to post
Share on other sites

The file system is not case sensitive.

 

And now, we end the discussion here, otherwise I or Aerosoft send you an invoice about that. When Justsim is not „hurry with this“, then simple don‘t pay them for it (for you: don‘t buy there product).

 

So last: no more questions about Sode internal issues and other product files here. 
For the moment, I look this topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...