!! Windows 7 no longer supported !!

As Microsoft will stop supporting Windows 7 on Jan 20th we will be unable to test any of our
products on that platform. It may work, or it may not, but no guarantees from our side. 

Jump to content
bobby70

Honeycomb Alpha flight yoke Templates/Profiles

Recommended Posts

I  do not know if this is the correct place to post this but I believe that Aerosoft provided the software for the key binding for the above for P3Dv4. I cannot find a section on your forums that might be dedicated to this. Is there/going  to be one? I must say that the yoke is magic and adds a new realistic feel to my flying after my ageing Saitek.

I am particularly interested in the template for the A2A Bonanza. Most of it works  but I cannot get the Nav Lights to function off/on correctly, even trying to change the true /false around or substituting the SDK Event ID directly. 

Has anyone else had the same problem or have I just got "finger trouble"? An error in the template?

I have looked on the forum for Honeycomb and can find nothing there.

If this is the wrong place to post perhaps you can advise me accordingly. 

 

Bobby

 

 

Share this post


Link to post
Share on other sites

Hi Bobby,

 

additionally to Mathijs question, I've also forwarded your NAV LIGHT issue to the person responsible for the template.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Mathijs and Ben for your prompt replies and help. Maththijs, yes but no luck  and Ben , good news .  Is this likely to be a "hot fix" or will it take some time for things to be resolved?

I do not have any third party apps, only the  SDK Event ID. Is there somewhere I could be looking to set the template up myself as I shall also want them for the other A2A aircraft as well?

Thanks 

Bobby 

Share this post


Link to post
Share on other sites
On 11/29/2019 at 3:57 PM, BenBaron said:

Hi Bobby,

additionally to Mathijs question, I've also forwarded your NAV LIGHT issue to the person responsible for the template.

 

Hi Benjamin,

 

With me the following switches are not working in the Bonanza:

- Alternator

- Landing lights

- Nav lights (already mentioned by OP)

- The AP on/off button (red button on the right horn)

 

All others work perfectly with the A2A Bonanza template of the 1.0.3.1 version . :)

Share this post


Link to post
Share on other sites

Hi Raphael------thanks for your response  and the version I have is 4.4.16. 27077 with a Sim Connect version of 4.4.0.0.  I have now redone the profile, starting from scratch, and all the lights now work OK . In the process it was not the Nav light this time but the BCN light which would not work at all . Now all solved on the lights front, so guess it must be finger trouble (or eyesight!).

BUT--( as always) I am trying to transpose the Ap Disconnect from button 4 on the template to button 1 (I prefer to use the button 4 for the gear) and even loading the supplied template of the Bonanza and using Button 4, I cannot get a response from the button on the yoke in the sim. Error here? Can I transpose these values between buttons or do I need another value like K:???.

And, what I now have is several Bonanza profiles (all numbered) in the load profile box, some of which are clearly half baked by my previous botched efforts, and I cannot find a way to delete those to avoid any possible confusion with them being loaded when I finally get this sorted. More finger trouble on my part?

If this is an Aerosoft problem at present, would it be possible to include a delete box next to the load box on the Load profile box at the bottom? Or perhaps give me a clue if I am missing something here. Probably.

Bobby

  

 

Share this post


Link to post
Share on other sites
9 hours ago, Raphael Jakob said:

Hi to all,
everything works fine on my side. So could you please tell me which P3D V4 Version and which Version of the A2A Bonanza.

Hi Raphael,

 

image.png

 

image.png

 

image.png

The latest Bonanza, I assume Version 19.5.24.0

Share this post


Link to post
Share on other sites

Raphael,

 

This is very peculiar. I read what Bobby did, and I did the same: create a new profile from the Bonanza template, save it and activate it.

To my surprise most switches are working now! But:

- The AP on/off button (red button on the right horn) still does not work

- Now the Taxi Light only works when shifted to the up position, the down position of the switch does not do anything.

 

I don't understand what happened. I will check further if funny things happen when changing profiles etc. and try to understand when a profile gets 'active'. Maybe you have a hint? How to activate a loaded profile without saving it?

 

Share this post


Link to post
Share on other sites

Hi,
sorry, some other projects kept me busy.

Could you please try this template? There was a bug in the old Bonza Template (correct Variable is L:ApDisconnect). Just drop the file into the Honeycomb/bin/Templates folder and replace it.

 

A2A has some nice documentation for HomeCockpit Builders....for example for the Cherokee 180 - Link - but sadly not for the Bonza.
The way from loading a template and save and activate is not the best. I think I will change that... I will add an only activate button and yes of cause a delete button. I hope to get a new version out with also new templates by the end of next week. You now can delete your Profiles in the UserProfiles folder, located in the install/bin directory.

A2A - Bonanza.json

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Eric /Raphael ---I think that the "problem" is that of  the in putter having to be, not surprisingl,y exacting (and no reflection intended Raphael on the error) in the input and the saving and activation of the profile . I see that there are a couple of ways on the net that are advised and I have been doing mine by ,--ensure that you clear all the Events that you are going to map off the P3Dv4 options /key assignments before entering each new values into the Yoke profile,saving and activating each one before going onto the next one. Clearly I was not exacting enough.

However, I now know that you can assign all of these buttons for A2A planes directly either/and through their aircraft configurator or the P3D key assignments box. However having got this far in something that I have not been into before I will await the new profiles and give it another go (thanks Raphael) and the delete button to enable me to tidy up my box! It is not exactly how I want it to work but is OK, doesn't stop me flying and nearly all of the inputs that are working are good for the Comanche as well.

Having now had some decent flying time with this new yoke, I cannot believe what a difference this has made. What little  RW flying that I have done is in a Robin 400 so do not have any comparison with those people who comment adversely on the pitch axis being too strong but I would call it "positive" and find it no problem at all. Compared to my old Saitek (I am not knocking it as it did me well for a good number of years and never let me down) landing even the Bonanza in the last bit of the flare is a doddle  and with that extra rotation I find that standard rate turns are much easier to hold. As an added benefit , having lost my PS 2 connection for the TPM I went out and bought another one (from Currys,PC World would you believe)with a USB  and now realise how spiky and sloppy that had got 

as well. 

First time that I have been on this forum and I am impressed and grateful for the quick responses and help.

Many thanks 

Bobby

  • Thanks 1

Share this post


Link to post
Share on other sites

Raphael, thanks for the updated Bonanza template, it works perfectly now.

 

For now, I will use the 'save and activate' option each time when changing profiles, until you have added the 'activate only' option.

What actually happens in the programs/system/hardware when I use 'activate'? Where are the values stored?

If I restart my computer or your YokeInput program, will it read back the current/previous state from somewhere? I am still struggling with the concept.

Maybe you need a beta tester ;)

 

 

Share this post


Link to post
Share on other sites

Phew...that sounds good ;)
Inside the install directory, you should find two folders (UserProfiles and Templates) In the Templates folder you will find of cause the Templates and inside the UserProfiles folder, you will find your saved profiles. When you Save and activate your profile, the program will save the config into the UserProfiles folder and it will also overwrite the YokeConfig.json file in the main directory. This JSON file is always the active Config and it will be loaded by the sim and when you load the ConfigTool. About the Tester...can you drop me an mail about that?

  • Like 2

Share this post


Link to post
Share on other sites

I had this question but I did place it at a wrong topic , now again here :

 

I try to program the yoke-input for the Alpha Honeycomb, but there is no manual that give a good information about this. It said to configure via the YokeInput .  So I try to understand the templates in the program. I understand that you have to put in a variable  for the various buttons. But when must I place : >K , K, >L or L at the beginning of a variable ? . Or is there somewhere to download a good manual for this subject ?  I will try to configure the yoke for the Douglad C47 of Manfred Jahn in Prepar3Dv4.5.

Joop

Share this post


Link to post
Share on other sites

Hi Joop,

let me refer you to this thread. There you can find some information about variables and their prefixing. 

If you have further questions, don't hesitate to ask.

Share this post


Link to post
Share on other sites

Thanks, But i am still searching for the answer: When must I place : >K , K, >L or L at the beginning of a variable ? In a template it's sometimes blanc , or <K ,K , L or >L. And I have no clue what it means.

Joop

Share this post


Link to post
Share on other sites

Joop, 

did you take a look at the link? There it is described what K, A and L variables are with links to their P3D SDK sections describing their usage. Prefixing them with ">" is simply used to set a variable. Vice versa, if it is not present, the variable will be read out.

Share this post


Link to post
Share on other sites

Thanks Ben,

Sorry I overlooked that, now it's clear.

Joop

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...