Jump to content

Twin Otter Fuel feed problem


davideo0
 Share

Recommended Posts

I've noticed that during any flight, despite having the fuel selector centred on Norm, the fuel in the aft tank only is used which ultimately results in port engine fuel starvation and stoppage.
I must admit that I am not totally familiar with the Twin Otter fuel system but am puzzled that I have not seen comments from anyone else about this. All flights I have done so far have been after selecting "FLY" and commencing with engines started on the runway.
What is it that I am not setting correctly?
Has anyone else experienced this? I'd appreciate any suggestions.
Link to comment
Share on other sites

  • Root Admin

That really suggest a misconfiguration in the switches. Next time it happens make a screenshot of the fuel systems so we can assist. Also make sure you are on the latest version as I believe some minor changes were done.

Link to comment
Share on other sites

I have just updated from Microsoft Store to the latest version 1.0.2 but, apart from a slight improvement in the sounds, the problem remains.

I carried out a short flight of about 30 minutes.  I attach screen shots of the fuel system and readings of fuel quantity.

You can see I started with 800lbs of fuel in aft and forward tanks cruised for about 30 mins checking fuel situation at 20mins and 30 mins.

You can see the fuel is being depleted from the aft tank at the rate of 600 pph while the fwd tank remains at 800lbs.

 

Since no one else seems to be reporting the problem, I imagine it is a problem with the Microsoft store version.

I hope you can see an answer to this!

 

Sorry but I inadvertently switched from NORM to Both on AFT when I intended to switch to both on FWD. But the reading at twenty minutes proves my point any way.

I intended to continue for another half hour with the fuel selector set to both on FWD  tank to prove the point finally but was distracted. The 30 minute reading was however accurate before the switch.

Control lever positions .jpg

Just before TOff.jpg

no warnings annunciator.jpg

20 mins into cruise.jpg

30 mins into cruise.jpg

Link to comment
Share on other sites

9 hours ago, teeloo said:

I have the same problem.

 

Only the AFT is feeding. FWD never feeds. Fuel tank switch to BOTH ON FWD still depletes AFT...

 

Is your version also from Microsoft Store or is that co-incidental?

At last, I feel vindicated to find I am not the only one with this problem!

Can someone with Aerosoft now take us seriously and come up with a solution?

This is after all a £30 program and it's reasonable to expect the basics to work properly.

 

Link to comment
Share on other sites

21 hours ago, Mathijs Kok said:

That really suggest a misconfiguration in the switches. Next time it happens make a screenshot of the fuel systems so we can assist. Also make sure you are on the latest version as I believe some minor changes were done.

Thank you, I have carried out your suggestion downloaded the latest version (1.0.2) from Microsoft Store and present the results above.

Link to comment
Share on other sites

I also have this issue. Mine is not the Microsoft Store version. For greater context, I first had this issue with the initial release. I then uninstalled it and re-installed the latest update (1.0.1.0) and the issue persists. I have the Steam version of MSFS and I have done all installations of the Twin Otter through Aerosoft One.

Link to comment
Share on other sites

I removed all hardware assignments, still no luck. 

 

I added two pictures below. 

Picture Fuel selector to NORM: start state 600 lbs in both FWD and AFT. Bottom half shows results after a few minutes (full power).

Picture Fuel selector to Both FWD: start state 600 lbs in both FWD and AFT. Bottom half shows results after about 5- 10 minutes (full power).

Yes, I over torque and over temp the engines, but I wanted to get max FF for this test.

 

In both cases the fuel is feeding mainly from AFT and ever so slightly from FWD. 

 

FUEL SELECTOR NORM

Fuel NORM.png

 

 

 

FUEL SELECTOR BOTH FWD

Fuel Both FWD.png

Link to comment
Share on other sites

I did some more testing:

 

1) Both tiptanks work fine and equal. 

 

2) When switching the AFT boost pump OFF, fuel is still fed from AFT tank to an engine.

3) when adding 600lbs in a tank, the indicator does not show 600lbs.

 

Link to comment
Share on other sites

What you have done teeloo , is a rather better presentation than the one I tried to do but the conclusion is the same - there is a definite problem with the program.

I have also deleted and re downloaded the program from Marketplace but like you, the problem persists.

Link to comment
Share on other sites

2 hours ago, Anthony Hibbs said:

I also have this issue. Mine is not the Microsoft Store version. For greater context, I first had this issue with the initial release. I then uninstalled it and re-installed the latest update (1.0.1.0) and the issue persists. I have the Steam version of MSFS and I have done all installations of the Twin Otter through Aerosoft One.

That's interesting. 

I wonder how many more of us are suffering the same problem, and yet watching many videos on Utube other users appear to have properly functioning fuel systems.

 

Link to comment
Share on other sites

2 hours ago, geraldlec said:

Works fine for me,  at end of flight fuel has been pumped in both tank.

There are obviously many if not most who are having no problems in this regard.

What was your source for the Twin Otter? Was it Marketplace, Steam or other? 

Link to comment
Share on other sites

I have the same issue.  Usually the aft tank is drained before take off.  The fuel from the aft tank gets pumped into the forward tank everytime.  Also the wing tanks automatically fill from the aft tank if I don't fill them before starting the flight.  Boost pumps on, fuel lever to normal.

 

Also I noticed the boost pump pressure lights are backwards.  When doing the crossfeed checks, if fuel selector is both on fwd then the boost pump 1 and 2 fwd pressure lights are on, aft are off, which is opposite of what the checklist indicates.  Same result when fuel selector moved to both aft, then aft pressure lights are on and fwd are off, opposite of the checklist.

Link to comment
Share on other sites

I'm having the same or at least similiar issue. Aft tank gets drained first. Doesn't matter what position boost pumps or fuel selector are set. Once aft tank is empty only then the forward tank gets used.
But what I find really strange is, when I change my camera mode to showcase only then both tanks get used as they should.
Also With aft tank empty, left engine dies only, as soon I switch to showcase camera mode.


MSFS Steam version. Twin Otter purchased directly from Aerosoft. Checked with only the AS Twin Otter in my mod folder.

Link to comment
Share on other sites

Guys, please check your bindings.
Having normal fuel flow in showcase cam mode gave me some thoughts about my bindings, since in that cam mode it changes controls interaction. So maybe check, if you have there fuel flow from both center tanks.


In my case they were the "increase mixture" and "decrease mixture" for 1 and 2 bindings, which I've set both to the same switch. Only difference was the action type "on press" and "on release".

  • Upvote 1
Link to comment
Share on other sites

4 hours ago, davideo0 said:

There are obviously many if not most who are having no problems in this regard.

What was your source for the Twin Otter? Was it Marketplace, Steam or other? 

 

Aerosoft website directly, I always try to buy product directly at the productor, so I don't have to wait for updates. My FS20 comes from Steam.

 

Link to comment
Share on other sites

1 hour ago, Bushman_XY said:

Guys, please check your bindings.
Having normal fuel flow in showcase cam mode gave me some thoughts about my bindings, since in that cam mode it changes controls interaction. So maybe check, if you have there fuel flow from both center tanks.


In my case they were the "increase mixture" and "decrease mixture" for 1 and 2 bindings, which I've set both to the same switch. Only difference was the action type "on press" and "on release".

 

SOLVED:

 

Ok, so mixture was not the problem as I had nothing assigned.

I had to reset both Honeycomb Alpha and Bravo to default and now all is ok. So it seems it IS a binding issue, but it is unclear which binding.

 

Resetting to default on al hardware devices will at least reset the fuel system in normal operation.

Thanks Bushman for letting us know.

 

 

 

Link to comment
Share on other sites

I troubleshooted some more and found out what binding caused the issue:

 

Assigning switches to CONDITION LEVER 1 and/or 2 to HIGH IDLE (or LOW IDLE) causes the fuel system to act up.

This shouldn't be that way. Condition lever should be assignable to a switch and the fuel system should work as normal.

This seems to be a 'bug'.

 

Solution:

Assign the switch for CONDITION LEVER - HIGH IDLE to the CONDITION LEVER AXIS instead. Yes MSFS will warn you about this odd assignment (switch should not be assigned to an axis) but it works!

Keep the other switch for CUT OFF as it is.

 

For the Honeycomb Bravo toggle switches, this works. (I use the toggles because I need axis 5 and 6 for the flaps construction). 

 

 

 

Link to comment
Share on other sites

Well, it seems that adjustments vary between us to get the system working properly.

For My part:

The basic simulator program was from Microsoft Store

The Twin Otter program was downloaded through Marketplace

With Honeycomb Bravo Throttle Quadrant and Alpha controls

The following Throttle and Mixture settings only were used:

Condition Lever settings are Nil.

 

I hope this may help some - it seems to have sorted the problem for me.

 

1820900941_Mixturesettingsgood.thumb.jpg.6c151a5e3531fd553191ecce76438353.jpg

Throttle settings good.jpg

Link to comment
Share on other sites

20 minutes ago, davideo0 said:

Well, it seems that adjustments vary between us to get the system working properly.

For My part:

The basic simulator program was from Microsoft Store

The Twin Otter program was downloaded through Marketplace

With Honeycomb Bravo Throttle Quadrant and Alpha controls

The following Throttle and Mixture settings only were used:

Condition Lever settings are Nil.

 

I hope this may help some - it seems to have sorted the problem for me.

 

1820900941_Mixturesettingsgood.thumb.jpg.6c151a5e3531fd553191ecce76438353.jpg

Throttle settings good.jpg

 

@davideo0 do you still have the same issue if you assign mixture to the 0-100 axis instead of the -100 - 100?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...