Jump to content
sortepermand

X-plane 11 Vulkan Crash

Recommended Posts

Ich wollte Vulkan statt OpenGl nehmen in der X-PLane 11.50b9. Aber leider crashte X-PLane 11 nach einige Minuten nach dem Takeoff.  Funktioniert Vulkan auch mit einer Nvidia Grafikkarte? 

 

Plugins die Ich verwende: 

 

  • Better Pushback
  • AviTab 
  • Terrainradar
  • X-Raas2
  • Landing Rate Lua Script
  • Fly with Lua
  • Zibo Mod 737-800X_3_42_full 
  • Zibo Mod 737-800X_3_42_full Eurowings Livery
  • Cloudart 

 

 

Cpu: Ryzen 5 3600

GPU: Rtx 2070 Super

Ram: 16GB Crucial Ballistix 3200mhz

 

Alle Treiber sind auch auf den neusten Stand.

 

Jetzt stellt sich mir die Farge an was es liegt?

 

 

 

 

 

 

Mir ist eben aufgefallen das, ich versehentlich den deutschen Beitrag bzw Thema in das Englische Forum gestellt habe von euch. Stelle Ihn also nochmal hier ins Deutsche Forum von euch und der Beitrag von heute aus dem Englischen Forum kann dann gelöscht werden. 

 

x-plane 11 error.PNG

x-plane error 2.PNG

Share this post


Link to post
Share on other sites

Ich habe diese Meldung vereinzelt auch schon erhalten, jedoch geschah dies bei mir ausschliessling während der Aufstartphase von X-Plane11. In meinem System ist ein GTX1080Ti von Nvidia verbaut. Die Frage, ob Vulkan damit auch funktioniert, kann demnach mit ja beantwortet werden.

Share this post


Link to post
Share on other sites

Für die Beta Version gibt es eine eindeutige Anleitung zur Fehlersuche:

 

1) alle nicht zu X-Plane gehörenden Addons / Plugins entfernen 🙂

 

Versuch's doch einmal und aktiviere eines nach dem anderen wieder.

Und ein Blick in's log.txt file hilft eventuell ebenfalls.

 

 

Und ganz wichtig:

Betas haben ganz sicher Bugs. Um diese zu beheben, braucht Laminar die crash reports!

 

x-plane 11 error.PNG

 

Share this post


Link to post
Share on other sites
vor 3 Stunden , Othello sagte:

Für die Beta Version gibt es eine eindeutige Anleitung zur Fehlersuche:

 

1) alle nicht zu X-Plane gehörenden Addons / Plugins entfernen 🙂

 

Versuch's doch einmal und aktiviere eines nach dem anderen wieder.

Und ein Blick in's log.txt file hilft eventuell ebenfalls.

 

 

Und ganz wichtig:

Betas haben ganz sicher Bugs. Um diese zu beheben, braucht Laminar die crash reports!

 

x-plane 11 error.PNG

 

 

Vielen Dank für deine Antwort und Ich werde es mal ausprobieren mit den Plugins wie von dir empfohlen. Problem hierbei ist nur, dass X-PLane 11 mal crasht  bei einem Flug und beim nächsten Flug mit der Vulkan API alles glatt läuft und es zu keinem Crash kommt wegen Vulkan. Auch tritt der Crash sehr zufällig auf was bedeutet das ich nicht sagen kann das nach Minute oder Stunde X Y der Simulator dann crasht. Also bleibt mir nichts anderes übrig einmal mit Plugins so lange rum zu fliegen z.B. in einer Cessna/Zibo bis es zu einem Crash kommt. Dann auch noch einmal ohne Plugins solange rumzufliegen bis es zu einem Crash oder hoffentlich zu keinem Crash kommt dann. Und die Bug reports habe ich immer an Laminar gesendet, wenn es zu einem Crash wegen Vulkan kam. 

Share this post


Link to post
Share on other sites

Hallo,

 

ok, die Bug Reports sind bei Beta Versionen (wie Othello schon schrieb) wichtig, damit Laminar die Fehler untersuchen kann...

Mehr Infos über die 11.50 beta Version und die aktuellen fehlerbereinigungen sowie noch zu bearbeitende Fehler kann man hier nachlesen.

https://developer.x-plane.com/blog/

Und hier die Release Notes und "known bugs" (bekannte Fehler) usw ....

https://www.x-plane.com/kb/x-plane-11-50-release-notes/

 

Betas können eben Fehler beinhalten, auch sporadische ...

Auch die jeweils gerade zu ladende Landschaft kann eine Ursache sein...

Und wie gesagt ganz wichtig:

Es laufen viele Addons und zusätzlich installierte Plugins noch nicht mit Vulkan.

Da muss man auf Updates der jeweiligen Entwickler warten...

 

Gruß heinz

Share this post


Link to post
Share on other sites

Ach so ok, Sende ich euch mal einen Log von X-PLane 11. Da X-plane eben wieder gecrasht ist wegen Vulkan vermutlich.Nach einer std und 30 min Flug oder länger. Beim neustart von X-plane habe ich wieder die folgende Meldung erhalten, welche ihr ja in meinem Eingangs Post seht hier im Thread.

Log.txt

x-plane error 2.PNG

Share this post


Link to post
Share on other sites

Die Probleme mit dem Vulkan crash und den Grafikfehler in XPlane 11.50b9 sind Geschichte. Da es wie sich heraustellte an dem Nvidia Treiber 445.87 lag. Diesen konnte ich nun auf den kürzlich releasten neusten Treiber 446.14 Treiber updaten. Siehe da alle Probleme wie die Grafikfehler etc sind nun verschwunden. An dieser Stelle möchte ich mich nochmal bei Allen bedanke für ihre zahlreichen Antworten und Tipps.

Share this post


Link to post
Share on other sites

Hallo Zusammen,

 

Ich benutze noch nicht die 11.50 Version, habe aber gestern schon mal die Vulkan-Treiber für NVIDIA GTX 1080 installiert. Habe jetzt festgestellt, das ich auf einmal ca. 10 FPS mehr habe. Daraufhin wollte ich mich mal hier umschauen, ob andere das gleiche festgestellt haben und bin auf diese Forum-Seite gelandet. Der Treiber 446.14, wie oben beschrieben, ist aber nicht der Vulkan-Treiber, sondern der normale Standard-Treiber von NVIDIA. Ich wundere mich nur, das es mit diesem Treiber läuft, bisher habe ich immer gelesen, das man den Vulkan-Treiber haben muß. Vielleicht kann man hier nochmal die richtige vorgehensweise erfahren, wenn man auf 11.50 mit Vulkan updated.

 

Guten Flug an alle

Gruß Coverdale

Share this post


Link to post
Share on other sites

Die Standardtreiber von NVidia  sind komplett Vulkankompatibel.

Share this post


Link to post
Share on other sites

Hallo Frithjof,

das war mir bisher unbekannt. Wenn das so ist, dann stellt sich mir die Frage, welche Treiber denn besser sind. Mal sehen, wie sich die neuen Treiber so verhalten.

 

Gruß, Coverdale

Share this post


Link to post
Share on other sites

Von welchem speziellen Vulkantreiber sprichst du denn hier? Den einzigen "zusätzlichen" den ich kenne ist ein Developertreiber.

Share this post


Link to post
Share on other sites

Habe nach Vulkan-Treiber gesucht und habe Vulkan 1.2 (442.81) gefunden. Den habe ich mir dann installiert.

Du hast Recht, ist ein Developer-Treiber

Share this post


Link to post
Share on other sites

Hallo Horst,

danke für die Info.

 

Ich habe beim normalen Betrieb keinen Unterschied festgestellt, so wie ich es zuerst vermutet hatte. Habe jetzt wieder zurück auf Standard-Treiber gestellt.

 

Gruß, Coverdale

Share this post


Link to post
Share on other sites

Da ist auch kein Unterschied weil Vulkan 1.2 ein neues Feature Set bereitstellt welches von XP gar nicht genutzt wird - die Treiber-Beta ist für Entwickler, die diese Beta-features testen wollen oder müssen und für den Nutzer komplett irrelevant.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...