Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
truthknown

G3d.dll Errors With Aes And 3gb Patch

Recommended Posts

Ok,

I have done some more changes, which my protect the code better. As we don't know yet, what realy happens, this is the only way to go forward.

Replace the attached file in the AES\Scenery directory (step 14 needed before -14a not needed) and try again.

You will only see the green Window with step 98 and 99. As I don't expect that the CTD happens before, this are the last steps before the AES goes active.

This windows should open around 7-9 NM before the Airports ARP. It's possible, that the CTD is not poping up direct after pressing F1 in step 99, but maybe later in approach. So please inform me as soon as possible, when it happens.

Share this post


Link to post
Share on other sites

Ok,

did "Step 14b" as instructed and both windows No. 98 and 99 popped up, after pressing F1 at window No. 99, the window disappeared as expected and FS continued to work for about 1 minute. About 2.5 nm from the airport I got the CTD (as always "g3d.dll").

Cheers,

T

Share this post


Link to post
Share on other sites

Ok,

thanks, that was expected. Now I have the next test, just replace the file.

In this case, you should get a blue window at the 2.5NM point. This will show Steps 00 to 15, incremented with every F1 hit.

I need to know, which is the last number you see before the CTD comes up. Wait 1 sec between the his, to give AES time to run this step.

By the number I can see which module part is responsable for the CTD.

Share this post


Link to post
Share on other sites

Ok,

about 2-3 nm from the airport the blue window of "Step 14c" popped up showing No. "00", I´ve been waiting for about 1-2 sec to press F1, after that --> CTD, so the last window I saw was No. "00".

Best Regards,

Tetiaroa

Share this post


Link to post
Share on other sites

Ok,

thats the module where the positions are controlled. In the attached test I have disabled this module for this time, so please try if there rest of the modules will work. When no CTD happens, you will not have working positions, but then we can look in deep in this module.

Share this post


Link to post
Share on other sites

Hello Oliver,

just finished testing "Step 14d", but unfortunately I got another CTD:

this time FS crashed after window No. "02" (immediately after hitting F1)...what a bad luck!

Hope you can get it sorted!

Thanks,

Tetiaroa

Share this post


Link to post
Share on other sites

I appreciate both you guys putting in the time and effort to track down this issue. Thank you, I really miss my AES!

Oliver, Do you expect a fix to be included in the upcoming 1.96 release?

Share this post


Link to post
Share on other sites
I appreciate both you guys putting in the time and effort to track down this issue. Thank you, I really miss my AES!

Oliver, Do you expect a fix to be included in the upcoming 1.96 release?

I am going to have to step in for Oliver here but if 1.96 is expected within the next few days and no fix has been found as of yet it is highly unlikely...

Share this post


Link to post
Share on other sites
I am going to have to step in for Oliver here but if 1.96 is expected within the next few days and no fix has been found as of yet it is highly unlikely...

Quick question, Are you guys running UTE?

-P

Share this post


Link to post
Share on other sites
No.

Thanks Stiffy ;) sorry, couldn't resist Allstiff.

I mentioned a few posts back I was having the g3d.dll error coming into EGCC from KEWR and I think it was UTE. That is the only reason I was asking.

Is it possible that the g3d.dll is the equivalent of the OOM error with the /3gb switch? We wont get an OOM anymore so we get this instead? Since I got rid of UTE I was able to enable AES at KEWR again and can at least fly from KEWR-EGCC but I am sure I would get the G3D error coming back to KEWR.

I feel bad for Oliver, we really owe him and the rest of you guys who have been testing to get this resolved.

Thank You! :)

-P

Share this post


Link to post
Share on other sites

Hi all,

sorry, but I will not expect the fix in AES 1.96. It is still not clear, where and why this happens. The allocation of memory, I see first as a problem, seams not to fail. The last test here looks like as a problem in Code parts, where visual objects are involved (Safegates and Jetways), but this is also not clear yet.

The good part is, that I had a CTD in approach in EDDF too, since I have used the patched EXE. I am trying now to get a situation, where I can reproduce this CTD, because just Loading the airport or slewing into the area as not shown the effect.

But this say clear, that the code itself is not buggy. The problem must have reasons outside of AES and only the combination with the code in AES will gernerate the issue.

I will first finished the release of AES 1.96, because it is unfair to delay the release for the main base of uses, which have no problem here. Based on this version we will go more in detail, as we know much more now, where it happes. When I am able to get into this situation, I have better chances to find a Workaround (because a fix is maybe not possible from my side)

Share this post


Link to post
Share on other sites
Thanks Stiffy ;) sorry, couldn't resist Allstiff.

I mentioned a few posts back I was having the g3d.dll error coming into EGCC from KEWR and I think it was UTE. That is the only reason I was asking.

Is it possible that the g3d.dll is the equivalent of the OOM error with the /3gb switch? We wont get an OOM anymore so we get this instead? Since I got rid of UTE I was able to enable AES at KEWR again and can at least fly from KEWR-EGCC but I am sure I would get the G3D error coming back to KEWR.

I feel bad for Oliver, we really owe him and the rest of you guys who have been testing to get this resolved.

Thank You! :)

-P

Thanks Oliver for at least giving it a shot. I always suspected that what your saying may have been the problem all along. It's the moduels, not AES it's self.

Did Maurizio ever look into this?

On a side note it also happens (this G3D.dll error) with my Geo Render Addons from Richard Goldstien (and I have since stopped using them). GeoRender scenery also uses Maurizios modules.

Keep us posted please! ;)

Share this post


Link to post
Share on other sites

Indeed, I appreciate the efforts. Hopefully a work around is found as I do really love the addon and have sunk a few bucks into it, but the crashes win out every time.

Share this post


Link to post
Share on other sites

Hi Oliver,

I just installed the new version of AES, so I´m prepared for the next test-sessions, although I´d still have to test with the workaround for "EDDF-2008" (using EDDF-2008 together with AES for EDDF 2005), as I don´t have any credits left to activate AES for EDDF-2008; hope that doesn´t matter for testing!

Furthermore, I´d also like to thank you for the update and the efforts you´re putting into this! THANK YOU!!!!

Do you already know, if you´ll release the next test-steps within the next couple of days? I´m only asking, because I thought about going on a short trip till wednesday, but if you released a test before that, I´d stay - of course!

Best regards,

Tetiaroa

@ all others:

You´re very welcome!

As I also miss AES quite a lot, I just hope that with joined efforts, we can get this wonderful addon back on our systems!

Share this post


Link to post
Share on other sites
Do you already know, if you´ll release the next test-steps within the next couple of days? I´m only asking, because I thought about going on a short trip till wednesday, but if you released a test before that, I´d stay - of course!

Hi,

make your trip, because I don't think I have much time the next week (I make a trip to at the end of the week) and I first want to try to get the situation on my PC, because at the moment, I can't see the issue, even with the Patch FS.EXE. I first have to install some memory intensive addons.

Share this post


Link to post
Share on other sites

Please dont let this issue slip away. I feel like such progress was being made. I still have not flown FS since I encountered this issue and its starting to kill me slowly!!!!

Share this post


Link to post
Share on other sites

Hi,

it's not forgotten, I just in contact with Maurizio to build a test dll to consume memory, so I hope to get this error reproduced soon.

Share this post


Link to post
Share on other sites
Please dont let this issue slip away. I feel like such progress was being made. I still have not flown FS since I encountered this issue and its starting to kill me slowly!!!!

Guys,

There is no reason to stop flying, not even to stop flying with AES.

Here are the details:

You should not get the error flying between two AES airports, lord knows there are enough of them to choose from ;)

You should not get the error flying from an AES airport to a non AES airport

You SHOULD get the error flying from a non AES airpot to an AES airport

I have not tried it between two non-AES airports

So fly all you want with scenarios 1 and 2 and if you want scenario 3 or 4 just disable AES and remove the 2 VIMA* Modules before the flight.

We need to compromise a little until this can be worked out "if" it can be worked out....

Cheers,

-Paul

Share this post


Link to post
Share on other sites
You should not get the error flying between two AES airports, lord knows there are enough of them to choose from ;)

You should not get the error flying from an AES airport to a non AES airport

You SHOULD get the error flying from a non AES airpot to an AES airport

I have not tried it between two non-AES airports

So fly all you want with scenarios 1 and 2 and if you want scenario 3 or 4 just disable AES and remove the 2 VIMA* Modules before the flight.

We need to compromise a little until this can be worked out "if" it can be worked out....

Cheers,

-Paul

That is not completely true. As stated early in this thread, AES can be unloaded from memory on longer flights and when called upon again you will get the error even if you start at an AES airport. Alot of factors depend on it being unloaded from memory such as if you use ultimate terrain, a complex plane like the PMDG and so on.

I'm not an expert but from what I understand the 32 bit memory system loads and unloads in "blocks" and I always thought maybe Oliver could find a way to keep AES loaded into memory and not let go until you end your FS session. This is not possible yet.

For the record, since applying the 3GB fix I have yet to have an OOM error no matter what or where I'm flying, I have done eight hour flights in real time and have not had the error, I could only do 1.5 or less before I would get that dreaded OOM "GONG!". I am 100% confident Oliver and Maurizio will fix this, it just might take some time.

Before AES evers gets shifted over to FSX they will need to have it fixed and working with the 3GB fix, FSX and the SP2 fixes the FSX.exe to use the 3GB fix by default. Aces are that confident about the usefulness of this hack. This is something that has not gotten by Oliver and the gang, I'd be willing to bet it WILL get fixed ;)

Share this post


Link to post
Share on other sites

Hello fellow fs friends

I was reading this topic. Really impressed by the way you all try to solve the problem. and find out what is causing the CDT's.

This evening i was making a flight from EGLL to EDDF and a CTD occured about 3nm out of 25L

Mayby you have something in sharing some info from me. But mayby it is nothing.

I have:

FS9.1 patched with 3Gb patch.

I have FS global2008

Ground Enviroment

Flight Enviroment

WOAI ai traffic installed. (note that in LEMD CTD's a A319 file of Iberia our Spanair mayby caused the CTD's)

I was flying a B767-300 from LEVEL D with FS2crew.

On the background:

AES 6.5

RadarContact V4

AI-smooth and Tracker IR.

I also recently reported crashes at: LEMD after landing.

our at EGLL final app.

All Airports have AES activated.

My pc specs:

AMD x2 6000 3.01Ghz

4Gb 800FSB

ASUS Nvidia 9800GTX 512MB

Windows XP with service pack 2 and 3

The message i get on my CTD's are:

ATC.DLL

G3D.DLL

UNKNOWN

I'm not so experienced in testing but if there is anything i can do to help the investigation....

For know, i will test tomorrow if removing the AI traffic solves the problem our when deactivating AES will help.

Peter

Share this post


Link to post
Share on other sites
Hello fellow fs friends

I was reading this topic. Really impressed by the way you all try to solve the problem. and find out what is causing the CDT's.

This evening i was making a flight from EGLL to EDDF and a CTD occured about 3nm out of 25L

Mayby you have something in sharing some info from me. But mayby it is nothing.

I have:

FS9.1 patched with 3Gb patch.

I have FS global2008

Ground Enviroment

Flight Enviroment

WOAI ai traffic installed. (note that in LEMD CTD's a A319 file of Iberia our Spanair mayby caused the CTD's)

I was flying a B767-300 from LEVEL D with FS2crew.

On the background:

AES 6.5

RadarContact V4

AI-smooth and Tracker IR.

I also recently reported crashes at: LEMD after landing.

our at EGLL final app.

All Airports have AES activated.

My pc specs:

AMD x2 6000 3.01Ghz

4Gb 800FSB

ASUS Nvidia 9800GTX 512MB

Windows XP with service pack 2 and 3

The message i get on my CTD's are:

ATC.DLL

G3D.DLL

UNKNOWN

I'm not so experienced in testing but if there is anything i can do to help the investigation....

For know, i will test tomorrow if removing the AI traffic solves the problem our when deactivating AES will help.

Peter

As stated by Oliver in this very thread. He is aware of what makes the error happen.

The way the vimiaplay DLL uses memory, if the dll calls on memory outside the normal 2GB range your going to get the error.

It is just a matter of waiting until Maurizio and Oliver can come up with a fix.

Share this post


Link to post
Share on other sites

sorry, i think i missed that answer, that he knew wat caused the CTD.

It was only to give more info.

Peter

Share this post


Link to post
Share on other sites
sorry, i think i missed that answer, that he knew wat caused the CTD.

It was only to give more info.

Peter

No problem Pete, good to add to it.

It's a long thread for sure.

Hope you have a gerat weekend of sim flying ahead ;)

Share this post


Link to post
Share on other sites
As stated by Oliver in this very thread. He is aware of what makes the error happen.

The way the vimiaplay DLL uses memory, if the dll calls on memory outside the normal 2GB range your going to get the error.

It is just a matter of waiting until Maurizio and Oliver can come up with a fix.

Sorry,

but all the test shows, that the allocation itself seams to work, but other conditions in the engine seams to generate the CTD.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...