We got a new video from World of Aircraft: Glider Simulator and are asking for some alpha/beta testers! Check this post.

 

Jump to content
hmslion

Most recent update breaks trim handle and indicator

Recommended Posts

Just used the updater software to update the plane to 2.1.  Love the 2d autopilot panel, but the update has broken the visuals on the trim handle, the indicator and the pitch up/down on the a/p panel.  In short, trim still works, but the handle and indicator don't work unless you are in autopilot mode.  Further, the pitch up/down rotating knob rotates when you use the trim.  I've gone back to 2.0 until this is fixed.  

 

This is the p3d v4 version of the plane.  

 

Thanks!

 

Colin Ware

Share this post


Link to post
Share on other sites

Hi Colin.  No one else has reported this and 2.1 has been out for a long time.  I've been using the aircraft a lot to test the upcoming auto flight engineer and haven't found anything amiss with the VS wheel, trim indicator or trim handles, both in VC or on the 2D AP panel.  Maybe there was something wrong with your aircraft install or your XMLTools install got corrupted.  XMLTools is needed for elevator trim.  I would suggest installing 2.1 again from scratch without using the updater. 

 

Let us know if you still have problems. 

Share this post


Link to post
Share on other sites
On 11/12/2019 at 7:48 PM, hmslion said:

Just used the updater software to update the plane to 2.1.  Love the 2d autopilot panel, but the update has broken the visuals on the trim handle, the indicator and the pitch up/down on the a/p panel.  In short, trim still works, but the handle and indicator don't work unless you are in autopilot mode.  Further, the pitch up/down rotating knob rotates when you use the trim.  I've gone back to 2.0 until this is fixed.  

 

This is the p3d v4 version of the plane.  

 

Thanks!

 

Colin Ware


Colin did you get it working? I installed twice and my trim handle or indicator does not move either so I can't set my trim before takeoff.  Will try a reinstall again this weekend I guess.

Share this post


Link to post
Share on other sites

I am at a bit of loss in understanding what is causing this problem for the two of you.  I would like to rule out an XMLTools install issue.  Can you tell me if the fuel loader works as it should?  Like the trim, it uses XMLTools. 

Share this post


Link to post
Share on other sites

The fuel loader works OK, the trim works OK but the trim handle is stuck and so is the trim indicator.....

 

If You fix this pls add warning sound when trim handle moves

 

Long time ago I was looking for green mark at the trim indicator showing normal trim limits....just 4 info

 

Thanks

 

L E Axgren

Share this post


Link to post
Share on other sites

I have checked our ticket system and could not find more incidents like this. So it really needs toe be something local.

Share this post


Link to post
Share on other sites

I reinstalled 2.0 and I will not go further in update.....

 

Trim handle moves correct but without warning sound

 

I use P3D 4.5

 

Have A Good Day

Share this post


Link to post
Share on other sites

The trim warning sound is working on my install.  

 

I am still on P3D 4.3 so I will update my version and see if that breaks anything. 

  • Like 1

Share this post


Link to post
Share on other sites

Trim works OK (and the buzzer) after updating to P3D 4.5.  So that's not the problem.

Are you using FSUIPC for trim?  I recall there was an issue with this in the past - the DC8 has a custom trim system that isn't compatible with FSUIPC. 

Share this post


Link to post
Share on other sites

Can't find the wav-file for trim warning ......where shall i look....??

Share this post


Link to post
Share on other sites

DC8-50\Panel\PanelSounds.

 

The file name is DC8_trim_warn.wav.

 

Can anyone with the auto-pilot pop-up version (2.1) confirm that their stab trim still works OK.  It seems like there should be many people raising this issue if it's a general problem, but I would like to be sure.

 

 

 

 

Share this post


Link to post
Share on other sites
On 20.12.2019 at 08:59, Michael2 sagte:

Trim works OK (and the buzzer) after updating to P3D 4.5.  So that's not the problem.

Are you using FSUIPC for trim?  I recall there was an issue with this in the past - the DC8 has a custom trim system that isn't compatible with FSUIPC. 

 

Hi Michael

 

I just attempt my first flight with the DC-8 and have no stab trim either. I do have the trim buttons on my yoke set to elev trim up and down via the FSUIPC buttons (right side) as I am absolutely no fan of assigning hardware controls via the P3D controls (I use to have a custom hardware setup - joysticks and yoke - for every aircraft I fly and FSUIPC and Linda manage this quite well in opposite of P3D. 

 

Does the stab trim HAVE to be set via P3D to work? Also I have seen a dll.xml install failure during setup as it couldn't find the location for whatever reason..I'm yet to understand all those locations where P3D puts its files..  But everything else of the DC8 seems to work just fine.. 

 

Thanks,

Marc

 

Edit: This is the error.

 

I have my P3D installed into my P: drive (SSD) while the dll.xml file is located on the main system drive c:. could this be the problem?

dllxmlAerosoft.JPG

Share this post


Link to post
Share on other sites

Which dll.xml do you use?

there's one in C:\ProgramData\Lockheed Martin\Prepar3D v4 and one in C:\Users\name\AppData\Roaming\Lockheed Martin\Prepar3D v4... no comment on that, I've resigned to understand that.

What would be the entry? So I could enter it manually, as I don't see any Aerosoft entries in neither file..

Weird enough I have an XMLTools64 entry in BOTH files.. everything else is different.

 

Thanks

Share this post


Link to post
Share on other sites
vor 2 Stunden , Ephedrin sagte:

Which dll.xml do you use?

there's one in C:\ProgramData\Lockheed Martin\Prepar3D v4 and one in C:\Users\name\AppData\Roaming\Lockheed Martin\Prepar3D v4... no comment on that, I've resigned to understand that.

What would be the entry? So I could enter it manually, as I don't see any Aerosoft entries in neither file..

Weird enough I have an XMLTools64 entry in BOTH files.. everything else is different.

 

Thanks

 

Can't edit, so a third post: I'm back to v2.0.0.. The trim works now, using v2.1 it does not. Not using the P3D controls either.

Share this post


Link to post
Share on other sites

Possibly there is an error in the updater files -- I am going to uninstall, install 2.0 and then update to see if I can reproduce the problem.

  • Thanks 1

Share this post


Link to post
Share on other sites

I've confirmed that the stab trim warning sound doesn't work in 2.0.  So making some progress.

  • Thanks 1

Share this post


Link to post
Share on other sites

Now confirmed that in 2.1 the stab trim doesn't work at all.  It seems there has been a disconnect between what the updater produces and the development version I had on my computer.  Working on a quick fix.

Share this post


Link to post
Share on other sites

Here is a link for 2.1 users to fix the stab trim:

https://drive.google.com/open?id=1FNPu6uYl8Pj24-GxpC9f4JgqXRVrCNhh

Again, you are replacing the two logic files in the DC-8_50\panel\DC81 folder.

We'll get the installers sorted out later -- probably after Christmas give the proximity of the holidays. 

Let me know if there are any problems with these hotfixes. 

Share this post


Link to post
Share on other sites

Thanks for the quick response and solution as always........

 

I wish You a Merry Christmas and a Happy New Year......

Share this post


Link to post
Share on other sites

Michael,

 

thanks for the quick reaction too. I wonder how nobody has brought this up earlier.. maybe there are differences in the sim version etc? anyway, it works well now, thanks! Honestly, I hope to see a fuel crossfeed one day but the airplane is really fun to manage. I did an approach in IMC into MMMX yesterday, flying there from Sint Martin.. certainly a new experience after all that 737/A320 management. It's a little faster than a C172 :D Using 4 independant throttles that's simply an amazing aircraft! 

Share this post


Link to post
Share on other sites
22 hours ago, AAC47 said:

I wish You a Merry Christmas and a Happy New Year......

 

And the same to you!

 

15 hours ago, Ephedrin said:

I did an approach in IMC into MMMX yesterday, flying there from Sint Martin.. certainly a new experience after all that 737/A320 management. It's a little faster than a C172 :D Using 4 independant throttles that's simply an amazing aircraft! 

 

Glad you're enjoying it.  I hope to get a new update out reasonably soon with an automated flight engineer option.  All done now except manifold pressure management and deicing.  After the FE is out, maybe cross feeds.  

  • Like 2

Share this post


Link to post
Share on other sites

Bought the DC 8 last week and also had this problem after updating with the update tool.

The above fix has now sorted it out.

Thanks Michael

 

Trevor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...