We have at this moment problems with e-mails coming to us via Microsoft servers (Outlook, Hotmail, Live, etc). We are in contact with Microsoft to solve this issue.

Jump to content
PilotBalu

simHeaven VFR-Landmarks für XP11/10

Recommended Posts

On 31.10.2017 at 13:14, PilotBalu sagte:

@dima17 Ja, das ist ein sehr signifikantes Objekt in Chems... Das Bild deutet auf ein 3D-OSM-Objekt hin, da du die Koordinaten weißt, kann ich dir sagen wo genau du suchen musst, ist einfach:

   w2xp_Europe_osm\objects\12\50\parts\  Doch bei 1.681 Objekten ist dies nicht so einfach. Vielleicht besser im OE gucken, welches Objekt(e) da an der Stelle ist.

 

Und dann müsstest du bei der VFR-Landmarks in der library.txt diesen Eintrag auf das Objekt ändern:

      EXPORT simheaven/chimney_250m.obj        objects/R2_Library/industrial/komin_A250.obj

also den rechten Teil davon. Nur sehen dann alle so großen Schlote so aus.

 

@PilotBalu

Hi Armin,

ich hab das mal ausprobiert. Da ich im relevanten Ordner erst mal nichts gefunden habe, habe ich mir die Mühe gemacht, mit einem Bildbetrachter sämtliche dds anzuschauen.
Allein im objects- Verzeichnis waren das 4076 Dateien, hab mir alle angeguckt, hat eine Weile gedauert, daher antworte ich auch jetzt erst ;)
Da ich dort keine Schornsteine gefunden habe, hab ich mir auch alle Bilddateien in facades-BlackRoofs, facades-osm2xp und facades-w2xp angeschaut.
Dazu noch die Bilder in den w2xp_Europe_objects und w2xp_world-models. Aber auch hier hab ich nichts schornsteinähnliches gefunden.
Nun habe ich mir eine abgespeckte w2xp gebaut, die nur die relevante Kachel +50+012.dsf beinhaltete. Ich musste dann in die neue Szenerie auch noch alle facades Ordner
und alle 12/50 parts Objekte mitnehmen, ebenso die w2xp_world-models wegen der industrial lugano objekte, da ich ansonsten Probleme beim Laden der Szenerie hatte.

 

Sieht dann so aus:
SCENERY_PACK Custom Scenery/simHeaven_VFR-Landmarks/
SCENERY_PACK Custom Scenery/simHeaven_Forests_Europe/
SCENERY_PACK Custom Scenery/w2xp_Europe_objects/
SCENERY_PACK Custom Scenery/w2xp_Chemnitz_osm/        //meine abgespeckte Szenerie
SCENERY_PACK Custom Scenery/w2xp_world-models/

 

Dann bin ich geflogen und der Lulatsch war da.
Allerdings hab ich damit ziemlich wenige Häuser, wahrscheinlich hat diese Szenerie die VFR-Landmarks überdeckt.
 

Dann habe ich mich auch noch am OE versucht (wie du ja vorgeschlagen hattest), um zu sehen, welches Objekt nun tatsächlich verwendet wird.
Musste mir den OE aber erst mal runterladen und etwas einarbeiten, da ich hiermit noch nichts gemacht hatte, ging aber ganz gut.

 

Das Objekt verwendet folgende Referenzen:
12/50/parts/part_233501621w
12/50/parts/part_233501622w
12/50/parts/part_233501623w
12/50/parts/part_233501625w
12/50/parts/part_233501627w
12/50/parts/part_233501628w
12/50/parts/part_172417979w

 

Hier als Beispiel mal ein paar Screenshots:

OE_Schornstein_1.thumb.PNG.d1ba350b56a4dce3abb80380b1baf52a.PNG

OE_Schornstein_2.thumb.PNG.4a495a48037ca3ec8b2e72f5380c90cc.PNG

OE_Schornstein_4.thumb.PNG.a2f3e73fb1ca37edf7888414454beb76.PNG

OE_Schornstein_3.thumb.PNG.00fa59576b40f452b60c5b068f14d7c7.PNG

 

Ich vermute mal, das die separaten Streifen die unterschiedlichen Farben bewirken.

 

Ich befürchte nun fast, dass sich das so nicht abbilden lässt. Entweder ich nehme die VFR-Landmarks (die mir eigentlich besser gefallen da ich viel mehr Objekte sehe) und verzichte auf den Lulatsch, oder ich nehme meine angepasste w2xp mit dem Nachteil, dass meine Szenerie ziemlich leer aussieht.

Ich vermute auch, dass die Referenzierung im dsf steht und wenn die VFR-Landmarks die Objekte nicht verwendet, lässt sich in der library.txt auch nix ersetzen.

 

Korrekt?

Vielen Dank schon mal vorab.

 

Viele Grüße

Dirk

 

 

Share this post


Link to post
Share on other sites

Na, dann machen wir das anders. ;) 

 

Ich hab mal auf https://3dwarehouse.sketchup.com/search.html?backendClass=both&q=chemnitz geguckt und den Lulatsch gefunden, hier das konvertierte Objekt, was du entweder in der VFR-Landmarks austauschen kannst oder (damit der Lulatsch nur dort steht) direkt in die VFR-Landmarks mit dem OE einbauen kannst:

 

Lulatsch_Chemnitz.zip

 

image.png

 

Für Chemnitz gibt es schöne Objekte auf 3D warehouse, wird sicher eine schöne Szenerie. :) 

 

  • Like 2

Share this post


Link to post
Share on other sites

Hallo Armin,

vielen Dank für deine Bemühungen :).

Dann werd ich das mal ausprobieren.

Werde dann mal berichten. Zur Zeit habe ich aber erst mal andere Probleme. Das neueste Windows-Update hat  meinen Rechner so richtig lahmgelegt. Muss den nun zunächst wieder zum Laufen bringen, bevor ich hier weiter testen kann.

 

Viele Grüße

Dirk

Share this post


Link to post
Share on other sites

@dima17 Ich hatte das Windows-Update auch schon drauf und musste wieder zurück auf den Stand vorher, weil u.a. MS Office und damit auch Outlook nicht mehr lief.

Share this post


Link to post
Share on other sites

@PilotBalu Hallo Armin, Rechner läuft wieder und ich habe nun wieder Zeit, mich den wichtigen Dingen zu widmen ;)

Damit nicht alle Schornsteine so aussehen, wollte ich dein Objekt mit Hilfe des OverlayEditors einbauen.

Beim Laden der Szenerie bekomme ich folgenden Fehler:

Fehler_2_OE.PNG.39968d0d3e5355a2cbd0768450bca498.PNG

 

Die Szenerie ist dann völlig leer, also nur Bodentexturen:

Fehler_OE.thumb.PNG.de297a19ec9d0bc8e3497e5deb3aed69.PNG

 

Für den OE habe ich die aktuelle Version 2.61 verwendet und auch die Landmarks habe ich nochmal auf die aktuelle Version 17.10 vom 15.11.2017 aktualisiert.

Das Copy-Skript ist auch ausgeführt und die Szenerie liegt auch im richtigen Verzeichnis, die benötigten Bibliotheken waren auch alle vorhanden,

 

Im XPlane wird die Szenerie fehlerfrei geladen.

 

Mache ich irgendetwas falsch?

 

PS: Im WED lässt sich die Szenerie übrigens laden, ist dann wohl eher ein Problem im OverlayEditor?

 

VG Dirk

 

Share this post


Link to post
Share on other sites

Hallo Dirk, ich hab das eben im OE geöffnet, bei mir werden nur diese 6 Objekte fehlerhaft angezeigt:

 

image.png

 

Guck doch mal ob alle Objekte richtig kopiert worden sind, prüfe ob diese beiden markierten Verzeichnisse auch vorhanden sind:

 

VFR-Landmarks_folders.png

 

 

Share this post


Link to post
Share on other sites

Hmm, also auf den ersten Blick sind alle Verzeichnisse da und auch alle Objekte.

Ich werde das aber dann noch mal verifizieren und melde mich wieder, wenn ich was entdeckt habe.

Share this post


Link to post
Share on other sites

Guten Abend.

 

Ich bin mir nicht sicher ob ich hier richtig bin aber ich fand dein Addon immer super. 

Nun hab ich ein Problem woraus ich nicht ganz schlau bin womit du mir eventuell helfen könntest.

 

Folgendes: Durch die Landmarks gab es auf dem "Üetliberg" oberhalb von Zürich immer den Aussichtsturm sowie die Kirchen in der Stadt.

 

Ich habe einpaar andere Landmarks noch ausprobiert, so wie "simHeaven_VFR-Aerials" oder *VFR-Landmarks_CH_Switzerland". Dann ist mir aufgefallen, dass weder Kirchen noch Schiffe und auch kein Aussichtsturm mehr um Zürich waren.

 

Also habe ich alles wieder zurückgesetzt und auch dann waren keine Landmarks mehr vorhanden.

Das Merkwürdige an der Sache ist jedoch: Wenn ich an den Bodensee gehe sind da die Landmarks, Schiffe usw. 

 

Nun frage ich mich: wo zum Teufel ist das Problem?^^ die Landmarks scheinen einfach in einer gewissen Region verschwunden zu sein. Auch eine "Neuinstallation" der Landmarks hat leider keine Abhilfe geschafft.

 

Vielleicht weisst du ja, woran es liegen könnte :)$

 

MFG Asuano

 

PS: in den Files zu sehen: ein Fail am Südlichen Zürichseeufer sowie die Sicht auf Konstanz und die Alpen mit funktionierenden Landmarks :S

Car_B200_King_Air_6.png

Car_B200_King_Air_7.png

Share this post


Link to post
Share on other sites

@Asuano Ich vermute dass du in der Kachel Zürich etwas anderes installiert hast, was ein Mesh drin hat. Hast du vielleicht Aerosoft Zürich installiert? Kannst hier gern dein log.txt als Anhang posten (bitte in Zürich starten).

 

Das Mesh muss in der scenery_packs.ini ziemlich unten angeordnet werden, sonst blendet es alle Einträge darunter komplett aus, siehe FAQ auf meiner Webseite.

  • Upvote 1

Share this post


Link to post
Share on other sites
4 hours ago, PilotBalu said:

@Asuano Ich vermute dass du in der Kachel Zürich etwas anderes installiert hast, was ein Mesh drin hat. Hast du vielleicht Aerosoft Zürich installiert? Kannst hier gern dein log.txt als Anhang posten (bitte in Zürich starten).

 

Das Mesh muss in der scenery_packs.ini ziemlich unten angeordnet werden, sonst blendet es alle Einträge darunter komplett aus, siehe FAQ auf meiner Webseite.

Ich hoffe das ist der richtige Log file. Ich hab mal noch die scenery_pack Ini angehängt. 

wenn du mit Aerosoft Zürich den Flughafen meinst: ja den habe ich. Das könnte durchaus auch das Problem sein, da der XOrganizer irgendwie nicht ganz versteht wie er die Dateien a,b und c richtig anordnen muss. Ich werd mir das gleich mal anschauen. Verstehe leider nicht ganz was im Hintergrund für Prozesse ablaufen, sonst würde ich dem Problem selber auf die Schliche kommen :)

 

 

Log.txt

scenery_packs.ini.bak

Share this post


Link to post
Share on other sites

Ich antworte mir gleich selber und entschuldige mich für die Unannehmlichkeiten.

Ich wusste nicht, dass die Dateien: Aerosoft LSZH Airport Zurich V2.0 b/ und c als Meshes zu klassifizieren sind und somit garnicht zu den Airportdateien gehören. Hab sie nun oberhalb der Librarydateien hingesetzt und es klappt alles wie es sollte.£!

vielen lieben Dank dass du so schnell geantwortet hast und nochmals Entschuldigung für die scheinbar doofe Frage :)

 

Share this post


Link to post
Share on other sites

Ja, der XOrganizer tut nicht immer das richtige... Ich bevorzuge das händische Sortieren. ;) 

Deaktiviere doch mal das: "Aerosoft LSZH Airport Zurich V2.0 c", das dürfte das Mesh sein. Falls du dann Probleme hast, dass die Bodenoberfläche nicht so recht passt, dann lasse ihn aktiviert und verschiebe den Eintrag ganz nach unten. 

Share this post


Link to post
Share on other sites

Oh, da warst du einen Tick schneller. Freut mich, dass es nun klappt!

Meine Szenerien müsstest du auch darüber anordnen, sie werden von X-Organizer auch falsch (als Libraries) erkannt!

Share this post


Link to post
Share on other sites
On 18.11.2017 at 09:49, PilotBalu sagte:

Hallo Dirk, ich hab das eben im OE geöffnet, bei mir werden nur diese 6 Objekte fehlerhaft angezeigt:

 

image.png

 

Guck doch mal ob alle Objekte richtig kopiert worden sind, prüfe ob diese beiden markierten Verzeichnisse auch vorhanden sind:

 

VFR-Landmarks_folders.png

 

 

 

Hmm, hab das noch mal überprüft. Bei mir sind alle hier genannten Ordner und auch alle benötigten Dateien vorhanden (außer den auch von dir genannten).

Trotzdem findet der OE kein einziges referenziertes simheaven/xxx Objekt.

 

Kann es vielleicht sein, dass der OE 2.61 mit dem Mapping in der library.txt nicht klarkommt? Bzw. der diese Datei völlig ignoriert?

Wie gesagt, in XPlane selbst ist diese Szenerie auch eingebunden. XPlane findet jedoch alle referenzierten Objekte, bringt also keine Fehler.

 

Was könnte ich noch prüfen?

 

VG Dirk

Share this post


Link to post
Share on other sites

Mache es doch anders: erstelle eine neue VFR-Szenerie für Chemnitz, platziere deine Objekte darin und setze Exclusions für objects und facades um das Objekt. Dann ordnest du diese Szenerie über der VFR-Landmarks an und alles ist gut. :) Und du könntest noch die anderen Objekte aus dem 3D warehouse mit reinnehmen, jetzt hast du es ja drauf! ;) 

Share this post


Link to post
Share on other sites

Hey, das ist eine Super-Idee :).

Das hat sogar noch den Vorteil, dass ich das Einbinden meines Objektes nicht immer wieder neu machen muss, falls es ein Update der VFR-Landmarks gibt.

Dann werde ich das mal so angehen, Danke.

 

VG

Dirk

 

Share this post


Link to post
Share on other sites

Update VFR-Landmarks v17.12

 

Ich habe eben eine neue Version v17.12 online gestellt, alles neu erzeugt auf Basis OSM-Daten vom 15.12.2017 und den Fehler, dass manche Objekte wie Windräder nicht erzeugt wurden, habe ich beseitigt. Danke an @martin99 für den Hinweis.

 

Für ein Update von v17.10 müsst ihr das Skript NICHT nochmal laufen lassen, es reicht den Ordner "Earth nav data" in die vorhandene simHeaven_VFR-Landmarks zu kopieren. 

Share this post


Link to post
Share on other sites

Hallo Armin, endlich ist es mir auch gelungen die VFR  Landmarks zu installieren ohne dass der Sim abschmiert. Nachdem ich die Libs der opensceneryx per Hand einkopiert habe ;)

Leider hab ich aber noch folgende Fehlermeldung:

 

0:00:46.196 E/SCN: Unable to load object file: Custom Scenery/simHeaven_VFR-Landmarks/objects/X-Plane/Common_Elements/Fuel_Storage/Sm_Fuel_Tank.obj
Failed to open Custom Scenery/simHeaven_VFR-Landmarks/objects/X-Plane/Common_Elements/Fuel_Storage/Med_Fuel_Tank.obj: the file cannot be opened.

 

0:00:48.031 E/SCN: Unable to load object file: Custom Scenery/simHeaven_VFR-Landmarks/objects/X-Plane/Common_Elements/Fuel_Storage/Med_Fuel_Tank.obj

 

Leider kann ich die Objekte nicht finde. Gibt es da noch Abhilfe?

 

Danke Andi

Share this post


Link to post
Share on other sites
vor 1 hour , Christoph 1 sagte:

Custom Scenery/simHeaven_VFR-Landmarks/objects/X-Plane/Common_Elements/Fuel_Storage/Med_Fuel_Tank.obj

Das sind Objekte (nur die Tanks), die aus dem X-Plane-Verzeichnis "%x-plane_dir%\Resources\default scenery\airport scenery\ kopiert werden. Genaueres steht im Batch-File

 

Doch warum führst du denn nicht wie im ReadMe beschrieben, das Batch File einfach aus? Das macht das ganze automatisch, nur wenn Du andere Ordner hast, musst Du noch die Variable im Batch anpassen. Du brauchst bei der OpenSceneryX nicht alle Objekte reinkopieren, sondern nur die... siehe auch hier das Batch file. ;)

Share this post


Link to post
Share on other sites

genau daran scheitere ich... ich weis gar nicht wie man ein batchfile anpasst. Anscheinend bin nur ich so doof. Ich habe das Batchfile WIN als admin ausgeführt, aber hat nie funktioniert. Wo kann ich denn etwas anpassen? Sorry dass ich so dumm frage aber ich bin was das angeht echt kein checker ;)

Meine Ordner wie R2, opensceneryx usw sind alle im custom scenerie verzeichnis. Hab auch die neueste Version installiert... Trotzdemmacht das batchfile das nicht. evtl mach ich dabei etwas falsch?

Share this post


Link to post
Share on other sites

Hallo Balu, erst einmal vielen vielen Dank für deine Mühen mit simHEAVEN. Auch wenn ich noch nichts/ wenig davon in meinem X-Plane sehe...

 

Ich hoffe, ich darf hier einfach hinten dran schreiben?

 

Ich bin jetzt erst seit 5 Wochen wieder mit x-plane 11 am Start und würde natürlich auch gerne in den Genuss der tollen simHeaven-Optik kommen. Seit knapp 2 Wochen versuche ich die simHeaven-Objekte zu implementieren und erziele leider nur geringe Erfolge. Alle gelesenen Beiträge/ ReadMe´s und yT-Video´s haben mir bisher nicht geholfen.

Zu meinem Problem: Ich sehe nur bedingt Objekte aus den ganzen zusätzlichen custom sceneries/ libraries usw.

Siehe Foto´s EDDS.

5a3a8c8a618f6_Bildschirmfoto2017-12-20um16_59_42.thumb.png.41340c373e2bd2f39094115ebf038b21.png

 

Was mache ich nur falsch?

 

Ich bitte dringend um Hilfe. Vielen Dank

 

P.S. Viele Grüße von Zap  

 

 

Bildschirmfoto 2017-12-20 um 16.59.55.png

scenery_packs.ini

Bildschirmfoto 2017-12-20 um 17.21.06.png

Share this post


Link to post
Share on other sites
vor 17 Minuten, Saurik sagte:

Zu meinem Problem: Ich sehe nur bedingt Objekte aus den ganzen zusätzlichen custom sceneries

 

Der wesentliche Unterschied zwischen beiden Bildern ist dass du Standard-Szenerie und Standard-Flughafen von XP11 hast und im zweiten Bild wahrscheinlich die Kaufszenerie EDDS und Fotoszenerien verwendet werden, das sind schon per se wesentliche Unterschiede in der Darstellung. Da kannst du dann draufmachen was du willst, das zweite wird immer besser aussehen. ;) Sorry. Und im Airport-Bereich erzeuge ich nichts, diese Bereiche werden generell ausgeschlossen.

Share this post


Link to post
Share on other sites
vor 2 Minuten, PilotBalu sagte:

 

Der wesentliche Unterschied zwischen beiden Bildern ist dass du Standard-Szenerie und Standard-Flughafen von XP11 hast und im zweiten Bild wahrscheinlich die Kaufszenerie EDDS und Fotoszenerien verwendet werden, das sind schon per se wesentliche Unterschiede in der Darstellung. Da kannst du dann draufmachen was du willst, das zweite wird immer besser aussehen. ;) Sorry. Und im Airport-Bereich erzeuge ich nichts, diese Bereiche werden generell ausgeschlossen.

 

Das Zweite ist nen Screenshot von Google Maps und ich meinte eher Stuttgart im Hintergrund. Sorry für die vermeintliche Täuschung...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...