Jump to content

dima17

Members
  • Posts

    64
  • Joined

  • Last visited

About dima17

Recent Profile Visitors

1322 profile views

dima17's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. @Frithjof Vielen Dank für die Erklärung. Jetzt kann ich meine Zeit wichtigeren Dingen widmen (z.B. X-Europe zu aktualiseren), anstelle nach Problemen zu suchen, die gar keine sind
  2. Hallo zusammen, ich habe mal eine allgemeine Frage zum Verständnis von Ortho4XP. Zwar ist es mir schon gelungen, Fototapeten zu erstellen und in X-Plane einzubinden, aber irgendwie nicht mit dem gewünschten Erfolg. Aber das liegt wahrscheinlich daran, weil ich hier von einer falschen Voraussetzung ausgehe. Ich nutze X-Europe 3 und das HD-Mesh v4. Für eine einzelne Kachel wollte ich nun Orthophotos verwenden. Also habe ich mir die Kachel inkl. Overlays mit Ortho4XP 1.30 erstellt und in X-Plane eingebunden. Die Höhendaten stammen aus dem HD-Mesh v4. Die Reihenfolge in der sceneries.ini sollte passen, X-Plane startet ohne Fehlermeldungen. Nun habe ich aber den Eindruck, dass ich nicht die Fotokachel sehe, sondern X-Europe oder vielleicht sogar Standard. Vielleicht liege ich auch falsch, aber ich bin davon ausgegangen, wenn z.B. auf der Fotokachel in einem ländlichen Gebiet ein Gewerbegebiet mit sehr markanten Bodenmerkmalen erkennbar ist, dann sieht es in X-Plane ganz genau so aus. Zwar ist das Gewerbegebiet da, aber es ist mit X-Plane Objekten bestückt, die Originalgebäude, die auf dem Foto sichtbar waren, scheinen überdeckt worden zu sein. Nun gibt es 2 Möglichkeiten: Entweder es ist wirklich etwas im Argen und X-Europe überdeckt die Fototapete was es eigentlich nicht sollte. Oder aber: Es ist normal, dass zwar die Bodenstrukturen aus dem Foto kommen, Gebäude oder ähnliches aber von X-Europe (oder wem auch immer) ersetzt werden. Bevor ich mich nun weiter auf die Problemsuche mache, wäre es für mich sehr hilfreich zu wissen, ob es überhaupt ein Problem ist, oder ob ich einfach nur von falschen Voraussetzungen ausgegangen bin. Vielen Dank schon mal vorab! Dirk
  3. Soo, hab es jetzt endlich zum Laufen bekommen. Das Microsoft C++ 2005 Redistributable Package (x86) allein hat bei mir noch nicht ausgereicht. Ich habe dann hier im Forum noch einen Beitrag von Heinz entdeckt http://forum.aerosoft.com/index.php?/topic/120244-wichtige-hinweise-zu-den-c-runtimes-für-windows/ Ich habe daraufhin auch die Redistributable Packages für C++ 2010, 2013 und 2015 nacheinander in der angegebenen Reihenfolge installiert, und zwar sowohl in der x86 als auch in der x64 Variante. Das .NET- Framework war nicht erforderlich. Einige davon hatte ich zwar bereits installiert gehabt, aber wahrscheinlich in einer älteren Version, oder aber eine Version war defekt. Welches Package nun ursächlich für die Lösung des Problems verantworlich war, kann ich leider nicht mehr sagen. @Daikan: Danke noch mal für deine Unterstützung VG Dirk
  4. Hmm, ja, das ist dann schon seltsam. Dann muss es wohl doch an was anderem liegen, dass sich nvcompress auf meinem Notebook (Acer) nicht starten lässt. Vielleicht irgend eine Treibergeschichte im Windows. Aber wie gesagt, auf einem anderen Rechner läuft es perfekt und da ich nun auch weiß, dass es durchaus normal ist, dass die dds so groß werden, ist alles perfekt. Danke dir . VG Dirk
  5. Also es lag tatsächlich an der Grafikkarte. Habe also Ortho4XP noch einmal auf einem anderen Rechner installiert, der über eine Nvidia-Karte verfügt. Die Konvertierung hat hier auf Anhieb funktioniert. Und mit dem Ergebnis bin ich auch äußerst zufrieden, hab sogar mehr fps bekommen, da durch die Fototapeten scheinbar die CPU merklich entlastet wurde. Allerdings sind meine dds wieder so groß geworden, etwa 10 MB pro Bild! Ist das denn normal? Hatte eigentlich angenommen, dass ein dds kleiner als die Original jpg sein müsste.
  6. Hallo Daikan, vielen Dank zunächst für die schnelle Antwort. Ich hab mir also mal die neuen Binaries von github geholt und mir danach die restlichen deiner genannten Links mal durchgelesen. Der Aufruf von nvcompress -bc1 -fast C:\Temp\test.jpg führt zu folgender Fehlermeldung. Lässt sich also gar nicht erst starten. Und das wird wohl daran liegen, dass mein Ortho4XP auf einem Rechner läuft, der keine Nvidia-Grafikkarte hat. Ich werde nun als nächstes Ortho4XP (und natürlich den neuen Converter) mal auf einem anderen Rechner mit Nvidia-GraKa installieren und von dort noch mal testen. Melde mich dann wieder und berichte über Erfolg oder Mißerfolg
  7. Hallo zusammen, ich bin neu bei Ortho4XP. Nach einiger Zeit der Recherchen hier im Forum habe ich nun Ortho4XP zum Laufen bekommen und mir meine erste Kachel fehlerfrei erstellen können. Zumindest sagen mir die Logausgaben, dass alles perfekt verlaufen sei. Allerdings bin ich etwas stutzig geworden, dass die Konvertierung pro heruntergeladener Fotodatei nur wenige Millisekunden dauert. Fehlermeldungen gab es aber keine. Im Anschluss daran habe ich mir dann mal das erstellte texture-Verzeichnis angeschaut. Bis auf eine Handvoll png-Dateien war es aber leer. Meine 1. Vermutung war, dass er eventuell ImageMagick nicht finden kann. Also wollte ich mir die dds's manuell aus den jpg's erstellen. Bevor ich mir aber ein Batchskript mache, habe ich das zunächst mal per Kommandozeile für eine einzelne Datei probiert: Convert -format dds -define dds:compression=DTX1 kachel1.jpg kachel1.dds. Er tut dies auch, allerdings ist meine dds dann 4x so groß, wie die Original jpg. Da das einige Bildchen sind, wäre die komplette Kachel dann etliche GB groß. Damit tue ich X-Plane sicherlich keinen Gefallen, meiner Plattenkapazität im übrigen auch nicht . Ich bin dann auf einen interessanten Artikel von @maydayc vom 19.01.2016 gestoßen. Da ging es zwar genaugenommen um Artefakte, aber der Hinweis auf die Verwendung von nvcompress scheint in der aktuell zum Download angebotenen Version 1.20 wohl bereits berücksichtigt worden zu sein, so dass wahrscheinlich keine Quelltextänderung erforderlich ist. Bin mir da aber nicht ganz sicher. Ich vermute nun, dass auch dies bei mir nicht funktioniert, da ich keine Nvidia-Karte nutze. Nun bin ich etwas ratlos, wie ich zu meinen dds-Files kommen kann. Es wäre prima, wenn mir hier jemand einen Tipp geben könnte. Vielen Dank für eure Hilfe . PS: Ich habe ImageMagick, Version 7.0.3-0 Q16 x86 2016-09-05 Als Betriebssystem nutze ich Windows 10 in der aktuellen Version. Und wie oben bereits geschrieben: Ortho4XP V1.20b. Das Python-Skript ist unverändert wie in der Auslieferung mitgegeben. Ansonsten sind keine weiteren Tools installiert. Viele Grüße und schon mal vielen Dank vorab Dirk
  8. @PilotBalu @Wildkatz@maydayc@Blen und dem gesamten Team Ich möchte mich den Glückwünschen anschließen. Super Arbeit, die ihr da geleistet habt Trotz meiner betagten Hardware (AMD A10) super Performance um die 40 fps. Zugegeben, Grafikkarte habe ich mittlerweile von einer ollen AMD 2 GB- Karte auf ne Nvidia GTX 1060 geupdatet. Hat vielleicht auch ein wenig dazu beigetragen, dass ich so eine tolle Performance habe . Viele Grüße und Danke Dirk
×
×
  • Create New...