Jump to content

CumulusX! and Steam FSX problem


Recommended Posts

Hi Peter or friends of sim gliding

CumulusX! works perfectly with my boxed FSX on Windows 7-64 home premium and I am a registered user. I have a dual installation of FSX-SE with a disk version of FSX on the same computer on the same drive. CumulusX! is installed twice, once for the disk version and once for the steam version.

I have only two addons installed, CumulusX and ASN.

Problem with FSX-SE:

In FSX-SE, CumulusX! causes FSX-SE to reload terrain and default hang-glider crashes every few seconds and flight is reloaded.

  • While FSX-SE simulation is running, If I close CumulusX! (.exe), the problem goes away.
  • ASN beta works in FSX-SE
  • CumulusX! connects to FSX-SE as shown in the dialog box.
  • CumulusX! comes up in the add-on menu of FSX-SE
  • I followed this guide and installed simconnect.msi but it does not make any difference: http://steamcommunity.com/app/314160/discussions/1/627456486453737133/
  • If I try to point FSX-SE to my old CumulusX installation in FSX (boxed), I still get same problem.
  • If I disable FSX-SE dll.xml and exe.xml and load CumulusX manually by double clicking icon, I still get the problem.

I have run out of ideas for now.


Link to comment
Share on other sites


since I am using CumulusX!, same version you have, with FSX:SE, actually just re-installed FSX:SE a couple of days ago, and CumulusX! yesterday, and also have ASN ( latest beta version, I'm also a beta tester for ASN :) ), I would like to share my thoughts.

1) When installing ALL of the simconnect msi installerr, make sure you install not only the three bellow the "Legacy" folders, but the top one at the "lib" folder too!

2) When installing CumulusX!, did you point it to the FSX:SE folder ?

3) Are you using symbolic links in any of your folders ?

Link to comment
Share on other sites

Hi Harry,

the symptom you describe appears if the simulator does not find the simobject models that come along with CumulusX!. This usually happens if installation of CumulusX! is done not using "Run as Admin", in which case the installer may fails to install the models, or if you use some other folder for installation rather than the root folder of the simulator. In the second case the position of the object models cannot be reached by the simulator.

So I recommend to install CumulusX! a second time, this time pointing the installer to the root folder of FSX-SE, or copying the models from the distribution archive manually to the correct position in the simobjects tree.

Your case with two active installations is a special one. To my information, FSX-SE uses the same directory and file names as FSX-MS, if installed on a fresh computer not having seen an FSX-MS installation previously. In this case CumulusX! may work off-the-shelf.

If FSX-SE installer identifies an FSX installation (or possibly residues of a previous FSX installation) the FSX-SE installation diverts to folder and file names that are different from FSX-MS. CumulusX! will still use the FSX-MS file names and AppData directory for configuring autostart and tow plane selection.

This means there will remain a problem with the tow plane selection and configuration. Tow plane selection configuration is stored into the configuration of FSX-MS and may not be reflected during sim operations of FSX-SE. Yet you may have a look in the FSX.CFG file in the section [sIM], which contains entries for tow plane type and pitch settings. You may edit this manually in the configuration of FSX-SE, yet it remains inconvenient.

The same may happen in regard to FSX' startup files DLL.XML and EXE.XML.

best regards,


Link to comment
Share on other sites


a question I was willing to ask...

If during the install we choose not to create entries in DLL.XML and EXE.-XML, or if we later erase the CumulusX! entries from those files, will CumulusX! still work fine started manually, when FSX is already working ?

Link to comment
Share on other sites

Thanks for your help Peter and Jcomm

*****I should have read page 31 of the manual which describes the bug I had*******

Yes, it was because the folder FSX-SE/simObjects/Misc/CumulusXCloud was missing.

I copied the missing folder from my disk installation and the problem is fixed.

It is possible that I forgot to run as administer during the install.

This has been a good warm-up for when I install CumulusX into P3D in the coming months.

Thank you!

Link to comment
Share on other sites

  • 4 weeks later...

Hey, I don't want to highjack this thread but, HarryO, were you able to install CumulusX! in the latest P3D version and have it run right? The reason I ask is there is a program (FaceTrackNoIR) that has worked with all but the latest version of P3D, and we cannot figure out what has changed, but it sounds like the same SimConnect.msi procedure is being used. Is there something else that you all are doing when running the SimConnect.msi files to get CumulusX! working in P3D (latest version)?


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy & Terms of Use