Jump to content

Honeycomb throttle led update for MSFS


hawkhero856
 Share

Recommended Posts

Hi all,

 

It seems to be saving the exe.xml to the wrong path. C:\User\{username}\appdata\roaming\Microsoft Flight Simulator doesn't exist. You also have to create it manually as the installer isn't creating the directory when it can't find it either.

 

However, this is still the wrong location for the exe.xml.

 

To fix it I:

  • Create the Microsoft Flight Simulator directory in {YourDrive}:\User\{username}\appdata\roaming\ to allow it to  create the exe.xml
  • Then go to {YourDrive}:\Users\{username}\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache and see if you already have an exe.xml in this directory
  • IF NO EXE.XML ALREADY EXISTS:
    • Just copy and paste the exe.xml from {YourDrive}:\User\{username}\appdata\roaming\Microsoft Flight Simulator to {YourDrive}:\Users\{username}\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache and it will work. 
    • You're done
  • IF EXE.XML IS ALREADY PRESENT:
    • We need to merge them together by opening them up and copying the relevant section from the Honeycomb EXE.XML into the existing EXE.XML. This is a common file where all .EXEs are listed that need to be started up with MSFS. 

EXAMPLE:

 

MY EXSITING EXE.XML

<SimBase.Document Type="SimConnect" version="1,0">
<Descr>SimConnect</Descr>
<Filename>SimConnect.xml</Filename>
<Disabled>False</Disabled>
  
<Launch.Addon>
<Name>Logitech Microsoft Flight Simulator Plugin</Name>
<Disabled>False</Disabled>
<Path>{YourDrive}:\Program Files\Logitech\Microsoft Flight Simulator Plugin\LogiMicrosoftFlightSimulator.exe</Path>
<CommandLine>-r</CommandLine>
</Launch.Addon>
  
</SimBase.Document>

 

 

EXE.XML CREATED BY HONEYCOMB DRIVER

<SimBase.Document Type="SimConnect" version="1,0">
<Descr>Auto launch external applications on MSFS start</Descr>
<Filename>exe.xml</Filename>
<Disabled>False</Disabled>
  
<Launch.Addon>
<Name>AFCBridge</Name>
<Disabled>False</Disabled>
<Path>{YourDrive}:\Users\{username}\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\community\AFC_Bridge\bin\AFC_Bridge.exe</Path>
</Launch.Addon>
  
</SimBase.Document>

 

WHAT IT LOOKS LIKE NOW IVE COMBINED THE TWO TOGETHER

<SimBase.Document Type="SimConnect" version="1,0">
<Descr>SimConnect</Descr>
<Filename>SimConnect.xml</Filename>
<Disabled>False</Disabled>
  
<Launch.Addon>
<Name>Logitech Microsoft Flight Simulator Plugin</Name>
<Disabled>False</Disabled>
<Path>{YourDrive}:\Program Files\Logitech\Microsoft Flight Simulator Plugin\LogiMicrosoftFlightSimulator.exe</Path>
<CommandLine>-r</CommandLine>
</Launch.Addon>
  
<Launch.Addon>
<Name>AFCBridge</Name>
<Disabled>False</Disabled>
<Path>{YourDrive}:\Users\{username}\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\community\AFC_Bridge\bin\AFC_Bridge.exe</Path>
</Launch.Addon>
  
</SimBase.Document>

 

Thanks,

 

Mark. 

  • Upvote 2
Link to comment
Share on other sites

  • Aerosoft

 

vor 13 Minuten, highflyer525 sagte:

Hi all,

 

It seems to be saving the exe.xml to the wrong path. C:\User\{username}\appdata\roaming\Microsoft Flight Simulator doesn't exist. You also have to create it manually as the installer isn't creating the directory when it can't find it either.

 

 

Thanks for your thourough explanation...confirms my thought, that there might be a pathing issue Steam vs. MS Store version. 

We will fix it in the installer.

  • Upvote 1
Link to comment
Share on other sites

1 hour ago, BenBaron said:

 

 

Thanks for your thourough explanation...confirms my thought, that there might be a pathing issue Steam vs. MS Store version. 

We will fix it in the installer.

 

Hi Ben,

 

One more quick thing whilst you're making changes. I've noticed the Anti-ice indicator is reversed. It illuminates when it's off and extinguishes when you turn it on.

 

I found it's because the ConditionValue is set to 0 instead of 1. I've changed it on mine so it reads =1 and now it seems to be working as expected.

 

{
      "ByteIndex": 3,
      "BitIndex": 2,
      "Condition": "A:PITOT HEAT, bool",
      "ConditionValue": "=0",
      "EN": "Anti-Ice",
      "DE": "Anti-Eis"
    }

 

Cheers,

Link to comment
Share on other sites

  • Aerosoft
vor 7 Minuten, highflyer525 sagte:

 

Hi Ben,

 

One more quick thing whilst you're making changes. I've noticed the Anti-ice indicator is reversed. It illuminates when it's off and extinguishes when you turn it on.

 

I found it's because the ConditionValue is set to 0 instead of 1. I've changed it on mine so it reads =1 and now it seems to be working as expected.

 

Hi,

 

well, it depends on what you are expecting I guess :). For me it made more sense to remind me to switch on the pitot heat. And also the default G1000s give you a warning for that. Thats why I wrote it that way. But of course you can adjust it to your liking, as you have already found out.

  • Upvote 1
Link to comment
Share on other sites

24 minutes ago, BenBaron said:

Hi,

 

well, it depends on what you are expecting I guess :). For me it made more sense to remind me to switch on the pitot heat. And also the default G1000s give you a warning for that. Thats why I wrote it that way. But of course you can adjust it to your liking, as you have already found out.

ahh OK, good point! 🙂

Link to comment
Share on other sites

  • Aerosoft

There is now also a new installer available for download, which should fix the pathing issue leading to a successful autostart of the LED driver.

 

Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...