Jump to content

Cannot login to Navigraph


sholay
 Share

Recommended Posts

So, I got Navigraph subscription and tried in the A320 Pro.

The EFB says - 'NavDataProChartCloud, Please login using configurator app." In the Configurator app (running as Admin, the same as P3D itself) I am selecting Navigraph and using 'Login in browser" button.

That takes me to Navigraph API page, where I am clicking 'Yes, Allow".

 

Sadly - nothing happens :(

 

Do you have aby advice?

 

&

PS

I would prefer NavDataPro but due to the fact that this does not offer compatibility with SimBrief I picked Navigraph. And they do work together nicely. 

What I am trying to say - I prefer Lido to Jeppesen and I am AS fan, so - please, please, please - befriend with SimBrief ;)

 

 

Link to comment
Share on other sites

Hi,

Thanks for update on SimBrief part.

 

On the key issue - yes, I am running P3D as an Admin, A320 as an Admin too. Other changes made in the Configurator are in effect, I tried with Cost Index. I am also able to add/remove maps to EFB.

 

&

Link to comment
Share on other sites

  • Deputy Sheriffs
13 minutes ago, sholay said:

is the NavDataPro easier to use?

Not sure what you mean. The Navdata itself are the same (despite some minor differences) and they are used in the same way. The charts are completely different. While the Jepessen charts were the "gold" standard for decades, Lido brought something completely new: simplicity and clarity. Some people might beat me, but regarding usage it is like the difference between an Airbus and a Boeing. Both are execellent aircraft, but follow different philosophies.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...