Jump to content
besimvelic

Aerosoft A333 "Visual model could not be displayed"

Recommended Posts

I just purchased the Aerosoft A330 and installed it to my P3Dv4. When I tried to load it, I cant see the preview image and it gives me an error saying "Visual model could not be displayed". It still loads the flight but the airplane is invisible and I am not able to see anything. I have tried restarting my PC but that doesn't fix the problem either. Help!!

Share this post


Link to post
Share on other sites
11 minutes ago, besimvelic said:

I just purchased the Aerosoft A330 and installed it to my P3Dv4. When I tried to load it, I cant see the preview image and it gives me an error saying "Visual model could not be displayed". It still loads the flight but the airplane is invisible and I am not able to see anything. I have tried restarting my PC but that doesn't fix the problem either. Help!!

Are you using V4.5 with hotfix 2?

Share this post


Link to post
Share on other sites

Strange mine started fine,   I had different issues,  but been in the air a couple of times

2019-12-10_15-15-50-1.jpg

Share this post


Link to post
Share on other sites

How can u run airplane thats made for P3D 4.5 HF2 on old verison of P3D  without problems?.

Pls update ur P3D.

Share this post


Link to post
Share on other sites
4 hours ago, besimvelic said:

I have V4.1

Well, the plane was only made to be used in P3D V4.5 with the Hotfix 2. 

Share this post


Link to post
Share on other sites

Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...