Jump to content
scotth6

P3D failed to start after updating EDDK Cologne Bonn

Recommended Posts

Hi,

 

Brilliant work with EDDK, it is a masterpiece!

 

I have now solved this issue, so this is more for information.  I used P3Dv4 last night and actually did some flying around EDDK.  Today I used the Aerosoft Updater to update EDDK to the latest version, and then went about some other tasks.  I had not used P3DV4 since updating EDDK, and that is all I had done.  Tonight I just wanted to check the compatibility of EDDK with ORBX GES so I started P3D but it would not progress past the the splash screen.  I restarted my PC several times and kept trying but P3DV4 would not start.  I have had this issue before and it was caused by a minor issue with the scenery configuration, so I started investigating there.  First I removed the Scenery.cfg file and let P3D build a new one, but it still didn't start.  I then checked all the addon.xml entries using P3DV4 Addon Organizer, but they checked out OK.  I tried turning off the EDDK folder, but that still didn't work.

 

It was only when I totally uninstalled EDDK that P3DV4 started again.  I have now reinstalled it using the original installer and P3DV4 and EDDK are both working again.

 

Cheers,

Share this post


Link to post

It's not EDDK itself. I just spent an hour this morning with the exact same issue as you with version 1.0.1.0. Turns out the EDDK installer also installs another program without your knowledge which has to be some sort of data violation. Going to my ProgramData\Lockheed Martin\Prepar3D v4 folder and looking in the exe.xml and guess what is there (look below). It's their updater I presume. Was installed last night when I installed EDDK. I set it from  <Disabled>False</Disabled> to  <Disabled>True</Disabled> and now P3D starts just fine. I absolutely DETEST that Aerosoft installed this on my computer without my knowledge.

 

 

<SimBase.Document Type="AceXML" version="3,0" id="exe">
    <Descr>AceXML Document</Descr>
    <Filename>exe.xml</Filename>
    <Launch.Addon>
        <Name>Flight Recorder</Name>
        <Disabled>True</Disabled>
        <ManualLoad>False</ManualLoad>
        <Path>C:\Users\Eric\Documents\Aerosoft\General\Flight Recorder\AS-FlightRecorder.dll</Path>
    </Launch.Addon>
</SimBase.Document> 

Share this post


Link to post
3 hours ago, mopperle said:

Do you have the Airbus installed?

No, I don't. Many moons ago but uninstalled that probably well over 6 to 8 months ago. Just Aerosoft scenery. EDDK was probably like my 5th or 6th scenery installed from Aerosoft. This issue started immediately after the EDDK install, with EGLL, LEMD, LIMC, PANC and another one already installed in the Ecosystem/Aerosoft folder. 

Share this post


Link to post

Well, it looks like the AS Flight Recorder didn't got uninstalled back then, for what ever reason. 

As you don't use the Airbus you can safely remove the entire <Launch.Addon> ... </Launch.Addon> section from the EXE.XML file (or just keep it there as disabled).

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...