Jump to content

Archived

This topic is now archived and is closed to further replies.

B748_Fan

Annoying installation problems with Saitek X52 Pro, again!

Recommended Posts

Hi guys,

 

I'm sorry to ask so many questions, but I tried a lot to install my Saitek X52 Pro again, but without success :mellow:
I used this stick on my old rig, and after some research I finally found a way to install this weird software successful, but all those hints didn't work on my new rig....
The guy from MadCatz support said, because the X52 works on my old system, they can't help me. So I hope anyone out there had the same problem and found a way to fix it:

 

I've downloaded the driver from saitek, and started it with a disconnected X52. After the installer told me to connect it, I do so. (Only the LED's on the stick were on, and the display next to the trust lever was dark but on) 
And after clicking 'next', nothing happens. I can terminate the process but then its impossible to restart the system by software.
After deleting all Saitek files in programs, temp, drivers and cleaning the registry and hardware manager, I tried again and again with different USB (2.0!!) ports at the mainboard but everytime it's the same sh**.

I have an old Saitek Cyborg Evo, which works fine on the old and on the new rig as well, but its not the same like the X52 Pro ;)

Hopefully one of you can help me ! And for the future I know: 'Never change a running system' :P 

Thank you!

Share this post


Link to post

Did you ever try to use your X52 without the Saitek driver and tried to configure it through your flightsim?

I myself have the X55 and never used the Saitek drivers.

Share this post


Link to post
vor 17 Minuten, mopperle sagte:

Did you ever try to use your X52 without the Saitek driver and tried to configure it through your flightsim?

I myself have the X55 and never used the Saitek drivers.

 

 

Yes I tried, windows installed the driver automaticly with a succesful message. The LED's and the LCD backlight are still dark.

I can see the different setting possibilities via windows, but the stick doesn't accept those and the buttons didn't react

Share this post


Link to post

Do you have connected it trhrough an USB hub or directly connected at the board?

Share this post


Link to post

Uninstall the driver:

driver.thumb.jpg.5408580560ad457d61d398b

 

Unplug the stick.

Reboot.

Remove all the saitek software (it truly deeply utterly sucks)

Reboot.

Plug device in and windows should not be installing anything

Share this post


Link to post
Vor 1 Stunde, mopperle sagte:

Do you have connected it trhrough an USB hub or directly connected at the board?

 

No I've connected it direct to the MB

 

vor 58 Minuten, Mathijs Kok sagte:

Uninstall the driver:

driver.thumb.jpg.5408580560ad457d61d398b

 

Unplug the stick.

Reboot.

Remove all the saitek software (it truly deeply utterly sucks)

Reboot.

Plug device in and windows should not be installing anything

 

 

I'm not able to uninstall the driver:

Screenshot2.thumb.JPG.da1b03076303772dc9

 

 

I already have removed all Saitek Software and reboot, but windows installed this driver from 2006 and the stick still doesn't work :beatcomputer_s:

Share this post


Link to post

Thats right Mathijs I thought the same and I already contact Saitek last week. Today they wrote because the x52 works on my old pc they can't help me now :-( Thats the reason I start this thread and hope, someone have an idea.

Share this post


Link to post

Thank you Mathijs for the link and your patience as well!

The hint to try an older driver and to disconnect the pc from the internet were new to me. So after the usual procedure of deleting rebooting etc I start the old driver, and after connecting the x52, all buttons and the LCD were on and I was able to change the settings via windows. [emoji106]But its not possible to start FSX or to shutdown/reboot the PC and the explorer.exe also had some issues after the installation. :-(

Also I checked following:

USB Legacy = enabled

XHCI = enabled

I swear with WinXP I had viruses they were less annoying than this Madcatz software :-)

Share this post


Link to post

I can't believe it, but its done!! (And I'm, too :P)

 

After I had a small discussion with the Saitek support again, they told me the USB Chipset from Intel on my new Mainboard causes the problem..... (Yes the new hardware, not the MadCatz driver which is not able do handle new hardware :P:P)

So I bought a PCI USB 2.0 card with a NEC chipset on it and now everything works just fine!! Finally ....

 

By the way I noticed the announcement of the new Saitek  X 56.... It looks nice, too! ( http://www.amazon.com/dp/B01CZTSS3O )

I hope the drivers for it will be better...

Share this post


Link to post

Hello Phillip,

interesting,

I am using X52

Motherboard/ Chipset Intel !!!

The current driver is from 02.02.2016.

No Problem without PCI USB 2.0 card with a NEC chipset.

(X52/X52pro driver are identical)

 

 

 

 

 

 

Share this post


Link to post
33 minutes ago, Rick24 said:

Motherboard/ Chipset Intel !!!

The current driver is from 02.02.2016.

No Problem without PCI USB 2.0 card with a NEC chipset.

 

I am pretty sure the Saitek support said or at least meant to say that there are certain Intel chipset combinations known for causing this problem and of course not all Intel chipsets in general.

Share this post


Link to post
 I am pretty sure the Saitek support said or at least meant to say that there are certain Intel chipset combinations known for causing this problem and of course not all Intel chipsets in general.

Yes thats right Tom, they said the problem is with this Mainboard with a Z170 Chipset only. My old board had an Intel Chipset, too and the stick works fine (after the correct installing procedure of course)

Maybe they didn't adjust the driver for this chipset yet... But he also said I could try to change from Win7 to 10 which could probably help, but at this point i'm not sure if I want to change now :-)

Share this post


Link to post
16 hours ago, B748_Fan said:

By the way I noticed the announcement of the new Saitek  X 56.... It looks nice, too! ( http://www.amazon.com/dp/B01CZTSS3O )

I hope the drivers for it will be better...

 

As far as I can see that's a X55 with more colors.

Now the X55 is very good now (*the first production run was garbage) but more colors? 

Share this post


Link to post

I also had a look yesterday. Beside the colors there are two switches replaced by analog sticks, one on the joystick and one on the thrust lever. So two more axis.

The X-55 already have more axis that I can make use of, so the X-56 is at least not for me. But I assume there are games out there that can really make use out of them.

Share this post


Link to post

Maybe some combat games or similar.... But I'm happy now with my X52 Pro, enough axis, buttons and so on, which makes it possible to run FSX nearly without the keyboard or mouse.

And to be honest, as I saw the price for the X-55, I thought that this would be to expensive for me and I decided to spend the money into some great addons :D

Share this post


Link to post

×
×
  • Create New...