Jump to content
Odair Fazzio

Bad Flight Simulator X performance

Recommended Posts

Hello captains!

My name is Odair and I'm from Brazil. I'm a huge FSX fan,

but I'm dealiing with some issues regarding FSX performance...

First of all, here's my PC configuration:

Motherboard: ASUS Rampage III Extreme

Processor: Intel i7 3.46Ghz

RAM: 8GB

Graphics Card: ATI HD Radeon 5970

HD: 1 TB

O.S.: Windows 7 64bits

My Windows installation has no anti-virus. I only installed Microsoft Office, WinRAR and Adobe Reader.

And here's my issue:

I notice my FSX too "heavy". When I'm leaving an airport or when I'm arriving at one, the frame rates seem to "lag" a lot! (I don't know how to specify this...)

So, I wanted to know if there's a good configuration to make FSX run better.

I mean FSX configuration and Video Card configuration!

How can I set up my GFX card and FSX to have a better performance?

Thanks in advance guys!

Share this post


Link to post
Share on other sites

First of all: What are your graphics settings? Maybe you've set your sliders to high and that's why FSX isn't running well.

Now, which addons have you installed? Addons can also have a heavy impact on the framerates.

And at last I can recommend you a website where you can tweak your FSX.cfg file: http://www.venetubo.com/fsx.html

Share this post


Link to post
Share on other sites

Hey Emi, thanks for answering!

Actually, I don't know how to set up my graphics settings... I'm a beginner on that "anti-aliasing", "triple-buffering" and other configs...

Do you have a guide or a website that shows how to adjust the settings in the right way?

For example, for anti-aliasing setting, I don't know if FSX uses 2x, 4x or 8x better...

Share this post


Link to post
Share on other sites

I have nearly the same PC-configuration.

The FSX will run well but not with many Addons.

You have to setup your water settings to the smallest 2x.

The HD5970 isn´t good for the FSX because the FSX can´t use all the graphicmemory and only 1GPU instead of 2.

You should take 4x AntiAlias only in the CatalystControlCenter. Don´t select it in the FSX, only in CCC.

Regards Alex

Share this post


Link to post
Share on other sites

My advice: Disable Light Bloom, Ground Shadows and lower the water effects to Low 2x.

They destroy FPS for nothing ;)

Share this post


Link to post
Share on other sites

Wow! Thank you all!

I will change all these settings and test!

About ATI HD 5970. Alex, do you recommend any other graphic card? Nvidia maybe?

Just one more thing... do you guys have any guide or step-by-step on how to configure the ATI CCC?

Share this post


Link to post
Share on other sites

Thanks Emi, for the link to that fsx.cfg site. And thanks to Alex for the 4x AntiAlias suggestion. With those two things, and also harnessing the power of my multi-core PC, I was able to about double my frame rates in populated areas. I run dual moniters and was getting about 3-4FPS and am now getting 6-7.5 or more in those areas. I would definitely get more though by changing my settings a little lower inside FSX, but I can deal with the choppiness of the framerate to get good visuals.

Odair Fazzio, I'll take a couple screenshots after this post of my CCC settings. I am actually using an ATI HD 5670 on my PC, not sure how that compares to the HD 5970.

I'll hopefully be back in a few minutes with those screenshots.

Scott

Share this post


Link to post
Share on other sites

Here it is, Hopefully it's readable because I don't have a good image editing program on this PC yet.

cccsettings.jpg

Share this post


Link to post
Share on other sites

I just found this morning that if you select Box Filter instead of Edge-detect Filter in the SMOOTHVISION HD:Anti-Aliasing section, you will get better frame rates, and it doesn't seem to degrade the graphics quality that much either.

Scott

Share this post


Link to post
Share on other sites

Hey guys...

I bought a RADEON HD 6990 and installed on my PC yesterday. To be honest, I didn't notice much difference;

I'm dealing with a big issue with my frame rates...

It's been six months that I'm trying to adjust my FSX settings for a better performance, but no good.

I already tried to tweak my "fsx.cfg" and changed the Catalyst settings just like sf4JC recommended above, but the frame rates decreases too much during the taxiways or when I'm leaving or arriving at an airport.

What makes FSX so heavy?

I spent a lot of money to optimize my PC configuration, described in the first post of this topic.

Even so, I'm looking for some reason for what is happening with my frame rates...

Could anyone help me? :confused_s:

Share this post


Link to post
Share on other sites

CPU is much more relevant then GPU for the FSX.

The FSX needs a high frequenty-CPU.

The ATI 6990 is the same like 5970. Only with 2 GPU´s more (4)

FSX only use one of those.

Wait for the next Flight Simulator "Flight"

I think "Flight" can use more GPU´s And Cores of CPU.

Regards Alex

Share this post


Link to post
Share on other sites

Hi Odair,

which display mode do you use, windowed or full screen? If using windowed mode, configure the taskbar to "hide automatically" which helped me a lot (100%+ FPS).

Could you possibly post a couple of screen shots of your FSX display configuration including all the sub-tabs? This would allow us, to get an overview of your current config and give targeted advise.

Another reason could be FS9 scenery or aircraft which sometimes are brute FPS-eaters.

best regards,

Peter

Share this post


Link to post
Share on other sites

THANKS Peter! That really helped with my frame rates in windowed mode. Now I'm off to try that suggestion when running in a smaller 1280x720 window with Livestream Procaster running to record the flight as well.

Scott

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...