Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
Sign in to follow this  
DonaldT

Trouble with Autostart

Recommended Posts

I am having trouble with autostarting Cumulus X. It seems to work when I go into the modules folder and doubleclick on CumulusX.EXE

but it will not start with FSX. Simprobe does not seem to work even when I manually start it. I have a red mark next to slope database when running CumulusX. I also do not experience the ridge lift.

I have included my EXE.xml, I am hoping I did something wrong here that explains my trouble. Simprobe and CumulusX are both in Modules in FSX installation.

Thanx in advance!!! :big_boss:

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>
<Name>CumulusX</Name>
<Disabled>False</Disabled>
<Path>C://Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\CumulusX!\CumulusX.exe</Path>
<CommandLine></CommandLine>
</Launch.Addon>

<Launch.Addon>
<Name>sim_probe</Name>
<Disabled>False</Disabled>
<Path>Modules\sim_probe\sim_probe.exe</Path>
<CommandLine></CommandLine>
</Launch.Addon>

<Launch.Addon>
<Name>Addon Application</Name>
<Disabled>False</Disabled>
<Path>Modules\CumulusX!\CumulusX.exe</Path>
<CommandLine></CommandLine>
</Launch.Addon>

<Launch.Addon>
<Name>Saitek DirectOutput RadioStack</Name>
<Disabled>False</Disabled>
<Path>C:\Program Files\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
<CommandLine>-run</CommandLine>
</Launch.Addon>

</SimBase.Document>
[/codebox]

Share this post


Link to post
Share on other sites

Hello and WELCOME to SOAR! I'm not familiar enough with .XML files to tell you if you have made a mistake or not in there, but I know someone here can in the next day or two maybe. But one question comes to mind, Have you set the path to the slope file folder? You can set it from the CumulusX! - Tools -> Configuration -> Slope Database Path menu if you haven't already done so.

Scott

EDIT: I forgot to ask about if you have the Sim Probe box checked inside CumulusX! ?

Share this post


Link to post
Share on other sites

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>
<Name>CumulusX</Name>
<Disabled>False</Disabled>
<Path>C://Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\CumulusX!\CumulusX.exe</Path>
<CommandLine></CommandLine>
</Launch.Addon>

<Launch.Addon>
<Name>sim_probe</Name>
<Disabled>False</Disabled>
<Path>Modules\sim_probe\sim_probe.exe</Path>
<CommandLine></CommandLine>
</Launch.Addon>

<Launch.Addon>
<Name>Addon Application</Name>
<Disabled>False</Disabled>
<Path>Modules\CumulusX!\CumulusX.exe</Path>
<CommandLine></CommandLine>
</Launch.Addon>

<Launch.Addon>
<Name>Saitek DirectOutput RadioStack</Name>
<Disabled>False</Disabled>
<Path>C:\Program Files\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
<CommandLine>-run</CommandLine>
</Launch.Addon>

</SimBase.Document>
[/codebox]

Share this post


Link to post
Share on other sites

I got messages asking me if I wanted to trust Simprobe and my Saitek software, Simprobe starts with FSX and my joystick has more functionality but Cumulus X still is not autostarting. I have "Autostart" checked in my config. I have included my new exe.xml if it helps.

I have a few more questions... What is the IGC file? And also, can Cumulus X really interact with FSX like it says at one point in the manual or do I have to download additional files to get slope lift? If not, where should I point to for the slope database? I have FSGenisis mesh if it makes a difference...

Thanx in advance!!! :big_boss:

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Name>Addon Application</Name>
<Path>E:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\CumulusX!\CumulusX.exe</Path>
<CommandLine></CommandLine>
<NewConsole>True</NewConsole>
</Launch.Addon>
<Launch.Addon>
<Name>sim_probe</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\sim_probe\sim_probe.exe</Path>
<CommandLine>log"C:\\Documents and Settings\\igc_files\\"</CommandLine>
</Launch.Addon>


<Launch.Addon>
<Name>Saitek DirectOutput RadioStack</Name>
<Disabled>False</Disabled>
<Path>C:\Program Files\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
<CommandLine>-run</CommandLine>
</Launch.Addon>

</SimBase.Document>[/codebox]

Share this post


Link to post
Share on other sites
I got messages asking me if I wanted to trust Simprobe and my Saitek software, Simprobe starts with FSX and my joystick has more functionality but Cumulus X still is not autostarting. I have "Autostart" checked in my config. I have included my new exe.xml if it helps.

If the programs on your computer are stored on the C:drive, this line in your EXE.XML: <Path>E:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\CumulusX!\CumulusX.exe</Path>

should look like: <Path>C:\program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\CumulusX!\CumulusX.exe</Path>

Bert

Share this post


Link to post
Share on other sites

Thanx, I think that did it. Cumulus X is now Autostarting. DUH!!! I have only flown powered aircraft so far but I saw different values than 0 in Simprobe when flying in mountains, so I think ridge lift is working. I have yet to define a path to "slope database"... no idea where. At one point the website manual said Cumulus X gets elevation data right from the sim and elsewhere I saw that I needed to download special files to define slope lift... Confusing...

Best Regards, Donald T :big_boss:

Share this post


Link to post
Share on other sites

Donald,

You don't have to define the path to Slope Database since you use simprobe 2.0. Using predefined slopefiles, stored in the Slope Database is a functionality Peter build before Ian started to work on his SimProbe-project. Since SimProbe directly interacts to the scenery you are flying in, predefined slope files are no longer needed.

Just make sure that in the main cumulusX! screen the checkboxes next to <Simprobe> and <Auto Thermals> are checked and the first and third checkbox are unchecked.

Bert

Share this post


Link to post
Share on other sites

The CommandLine parameter for sim_probe looks like it's had a bit of an edit for the post - to avoid confusion for others a corrected version of the sim_probe EXE.xml entry is below.

The 'CommandLine' entry contains a 'log=FolderName' value which

(a) must refer to an existing folder on your PC

(B) the folder name must be enclosed in quotes

(.c) each back-slash in the folder name must be written as a double-back-slash

(d) the folder name must *end* in a double-back-slash

For *example* see below, - you will have to correct the log= folder name to something valid on your PC.

<Launch.Addon>
<Name>sim_probe</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\sim_probe\sim_probe.exe</Path>
<CommandLine>log="C:\\Documents and Settings\\Your Name\\My Documents\\igc_files\\"</CommandLine>
</Launch.Addon>

Ian

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...