Jump to content

Airbus x Fuel Planer error


por930
 Share

Recommended Posts

I have the A318-321 professional series...1.4.3.2 for P3Dv4 on a uptodate Win10 machine. I have not used P3D for many months. So, spent some time updating it and the various aircraft.

 

When I use the A3xx Fuel Planer, (either from the start menu or the actual A3xx Fuel Planner folder) with any of the buses, I get the error...Access to path 'C:\users\xxx\Documents\Aerosoft\General\A3xx Fuel Planer\LoadSheets\LoadsheetA320.txt' is denied sort of implying a permission issue? I have my A3xx Fuel Planner Properties permissions to 'Allow' thinking all folders have all permissions. I always have the Administrator ticked in the security box. 

 

When I look in the 'C:\users\xxx\Documents\Aerosoft\General\A3xx Fuel Planner\LoadSheets folder, I find some older Loadsheets from 2021, but not the current loadsheet I just created.

 

However, when I look in the 'A3XX Fuel Planner' folder, I find an AircraftData Folder, a Loadsheets Folder, the Aerosoft.AirbusX.FuelPlanner.exe and the file 'FuelPlannerSavedSettings.xml [which has the current fuel/cargo/pax settings for my required Loadsheet.

 

It seems the Aerosoft.AirbusX.FuelPlanner.exe is not converting the xml file to a txt file and moving it to a folder allowing the MCDU to find it.

 

What bit of config am I missing.

 

Geoff

edit...I am not a new member, but can't find my log in details, the new password email never arrived so created a new login

Link to comment
Share on other sites

  • Aerosoft

Hi por930,

Very strange issue. I have not had any issues with Loadsheet creation and just tested all aircraft again and could not recreate the issue.

Few things that comes to mind. Make sure that you are running the fuel planner as an administrator. After that, the first obvious thing to make sure is that you have all the information filled and press generate loadsheet. Secondly, try to move the .txt files from Loadsheet folder to a different location so that the loadsheet folder is empty and see if that way you can create new loadsheet. If that doesn't work as a last resort thing you could try reinstalling the busses.

Link to comment
Share on other sites

Hi Secondator, masterhawk

Yes, strange. 

I always select Administrator when invoking the fuel planner.

I moved the .txt files out of the Loadsheet folder. Made no difference

I have removed and reinstalled the buses, to no avail.

I notice in the Error report, that the first line maybe a strong clue....

UnauthorizedAccessException: Access to the path 'C:\Users\geoff\Documents\Aerosoft\General\A3XX Fuel Planner\LoadSheetA320.txt' is denied

 

For some reason, the program does not allow me access to the Fuel Planner LoadSheet. I did go into the fuel planner and added the permission for 'everyone', thinking this will give me approval. Nah...

 

I have had some success...just before my flight sim machine died, and Is away for a fortnight bring resurrected...

 

I found that the task bar short cut for the fuel planner always caused the error when used, regardless of Administrator use. I found the Fuel Planner from the Start Menu worked most times. I think the fuel planner from the C:\Users\geoff\Documents\Aerosoft\General\A3XX Fuel Planner also worked. I was in the process of eliminating the three fuel planners variations when my machine refused to post when restarted after lunch one day. When I get it back, I will continue testing and report back. But when it worked, it was rock solid. I could open the fuel planner and select any aircraft and generate the loadsheet.txt. If I re-chose the same a/c, the loadsheet would overwrite, and the a/c would have the correct data when the MCDU was loaded. So, getting closer to the issue.

Link to comment
Share on other sites

  • 4 weeks later...

OK, I got my machine back.

The fuel planner now refuses to work at all. Every time I try and generate a fuel sheet, I get the usual error, "Access to path 'C:\users\xxx\Documents\Aerosoft\General\A3xx Fuel Planer\LoadSheets\LoadsheetA320.txt is denied"

It does not matter if P3D is loaded or not,

if the A320 is loaded or not,

or if I select Administrator or not.

 

On the shortcut to the fuel planner properties, I have the 5 Permissions for everyone set to Allow, so I thought that gave permission for every one who logged in to access the fuel planner.

 

Anyway, maybe one of those things. The MCDU fuel/cargo entries work ok

Link to comment
Share on other sites

As I wrote in my post yesterday I have exactly the same problem Geoff.

 

Had a PC upgrade with W11 now I can load the fuel planner, complete the fuel plan but when I try to generate a loadsheet the same exception error comes up every time. It is a pain because even when you use the quantities and trim settings manually the MCDU screams at you the trims are not correct.

 

Perhaps someone will come along with an answer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...