Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
sho69607

Wild FPS fluctuation

Recommended Posts

I have been able to improve overall FPS by reducing settings inside P3D, but it still remains that the aircraft is quite heavy on performance. Even with my settings reduced, the fluctuating FPS problem still remains. I am getting anywhere from 30-100FPS in cruise. I have tried locking it with the frame limiter, but that only causes the FPS to dip even lower. So far I have been unable to find the cause. Turning traffic off has no impact and reducing from SSAA to MSAA actually makes my FPS drop surprisingly (maybe something with the NVIDIA settings?). The only thing that has helped is reducing draw distance.

 

CPU: i7-9700k

GPU: GTX 1070

Memory: 16GB

Share this post


Link to post
Share on other sites
On 2/18/2020 at 5:44 PM, sho69607 said:

I have been able to improve overall FPS by reducing settings inside P3D, but it still remains that the aircraft is quite heavy on performance. Even with my settings reduced, the fluctuating FPS problem still remains. I am getting anywhere from 30-100FPS in cruise. I have tried locking it with the frame limiter, but that only causes the FPS to dip even lower. So far I have been unable to find the cause. Turning traffic off has no impact and reducing from SSAA to MSAA actually makes my FPS drop surprisingly (maybe something with the NVIDIA settings?). The only thing that has helped is reducing draw distance.

 

CPU: i7-9700k

GPU: GTX 1070

Memory: 16GB

 

So the goal is to eliminate wild fps fluctuations.

 

The latest nvidia driver has a frame limit setting.  If your screen refresh is 60hz I would recommend setting in the nvidia control panel to a limit of 30 fps.  Then in P3D settings, turn vsync on, but set frame rate to unlimited.  I would not use P3D's frame limiter (other than to set it to "unlimited"), as that gives you the lower results you saw.  Verify that your sim is topping out at 30 fps (and a smooth stutter-free 30 fps it should be) using SHIFT-Z to display the fps counter.

 

A word about SSAA...I would not run SSAA at night.   At present SSAA just doesn't play well with HDR.  Maybe if you have an RTX2080ti that is not an issue, but it's definitely still an issue on my 1080ti, and I'm sure on your GTX1070 as well.

Share this post


Link to post
Share on other sites
6 hours ago, Mace_RB said:

 

So the goal is to eliminate wild fps fluctuations.

 

The latest nvidia driver has a frame limit setting.  If your screen refresh is 60hz I would recommend setting in the nvidia control panel to a limit of 30 fps.  Then in P3D settings, turn vsync on, but set frame rate to unlimited.  I would not use P3D's frame limiter (other than to set it to "unlimited"), as that gives you the lower results you saw.  Verify that your sim is topping out at 30 fps (and a smooth stutter-free 30 fps it should be) using SHIFT-Z to display the fps counter.

 

A word about SSAA...I would not run SSAA at night.   At present SSAA just doesn't play well with HDR.  Maybe if you have an RTX2080ti that is not an issue, but it's definitely still an issue on my 1080ti, and I'm sure on your GTX1070 as well.

Unfortunately limit my frames through the Nvidia control panel made my FPS much worse. It will not go over 20FPS with that turned on. As far as the MSAA over SSAA, my frames remain the same regardless. I will keep experimenting more and see what I come up with. I appreciate the help though!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...