Jump to content

Trueglass not working


aviator64

Recommended Posts

I have done a clean reinstall of Reallight and Trueglass (from the installers included with the Airbus) to fix my CTD issue. The airplane loads up and runs fine, and Reallilght seems to be working OK, but I am not getting any raindrops on the windshield even when on the ground in heavy rain.

 

The rain (generated manually via ActiveSky) does appear on the weather radar.

 

I read in another thread that there should be a menu item for Trueglass under the P3D Addons menu in-sim, but I do not have this. Maybe this is related to trueglass not working?

 

All the DLL and shader files appear to be present and correct.

 

Any thoughts would be appreciated. Is there a config file somewhere that I should be checking?

Link to comment
Share on other sites

1 hour ago, mopperle said:

As I'm away from my sim, I cant check it by myself, but when you start P3D, in the welcome screen click on Addons and IMHO there should be an entry for Trueglass, check that it is enabled.

 

Thanks - unfortunately it is not there. Neither is Reallight although that seems to be working; at least, the cockpit lights dim properly so I assume it is.

 

I am wondering if there is a config or xml file where I need to recreate some entry to make it load properly.

Link to comment
Share on other sites

Hello, 

I seem to be having the exact same issues as well. I've done a reinstall of Reallight and Trueglass, but still nothing. Both of them are not in the Addons area on the welcome screen either. 

 

Would really appreciate it if someone is able to find and help solve this.

Link to comment
Share on other sites

  • Deputy Sheriffs

OK guys, just checked it and indeed there should only be an entry in P3Ds Addon menu for Trueglass, to en-/disable it. There is no entry in the Add-On Manager and there are no entries in configfiles like dll.xml.

 

Can you please check that the following files/folders are in place:

- under ...P3D\Gauges reallight.dll and trueglass.dll

- under ...P3D\Gauges you have the following folders:

2019-01-07_10h21_32.jpg

 

2019-01-07_10h22_22.jpg

In both cases in the subfoders "Shaders" should  be one file

 

In the installation folder of each Airbus you should have the following folders and files under(A31x as an example):
...\Aerosoft A318-A319 Professional\SimObjects\Airplanes\Aerosoft A318 CFM Professional\

 

 

2019-01-07_10h49_14.jpg

Link to comment
Share on other sites

Ok, I will try and see if that helps, do I need to uninstall both the A318/19 and A320/21? 

Just now, mopperle said:

OK; maybe this is the problem. May I ask you to uninstall it , also uninstall the Bus and reinstall the Bus. Maybe the files are not created correctly.

Cant check it by myself, as not at my sim PC

 

Link to comment
Share on other sites

  • Deputy Sheriffs

@Ashrod_307 Yes, please uninstall both A318/19 and A320/21. And when you install them back the installer should ask you about RealLight and TrueGlass and install the latest version from TFDi servers. Once you run both of them there should not be any need for you to manually install them again.

 

Link to comment
Share on other sites

  • Deputy Sheriffs
13 minutes ago, Ashrod_307 said:

No, I do not have it there  

 

Hmm... I think you already confirmed that you have TrueGlass.dll in your gauges folder as this dll file is what should bring that option up on the menu. Do you have any antivirus software installed that could potentially block that file from loading up?

Also, I doubt this is causing the issue but might as well ask. Do you have any 3rd party shaders installed?

 

Link to comment
Share on other sites

Just now, Secondator said:

 

Hmm... I think you already confirmed that you have TrueGlass.dll in your gauges folder as this dll file is what should bring that option up on the menu. Do you have any antivirus software installed that could potentially block that file from loading up?

 

Yes I do, however I did disable it before reinstalling the airbus 

Link to comment
Share on other sites

  • Deputy Sheriffs

OK, I uninstalled all buses, deleted all remaining files and folders (incl. reallight/trueglass files/folders), rebooted my PC, installed the version 1.2.1.0 from my shop account, updated via ASUpdater to 1.2.2.1 and everything is as it should be:

all files in place, RealLight and TrueGlass working, entry in the Addon menu. No need to go offline while installing.

One thing I noticed is, that the TrueGlass.ini is only written, once you disable TrueGlass via the Addon menu.

 

2019-1-8_11-34-48-742.jpg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...