Jump to content

P3d V4 issues compliation issues


Mathijs Kok

Recommended Posts

  • Root Admin

To avoid multiple topics let's combine it all here. These are the issues we are looking into:

 

1) when the second fire bottle is pulled (it does not matter which is pulled first!) a clicking sound is heard that will stay audible. P3d might or might not crash (either with a CTD or a message "Breakpoint A Breakpoint has been reached.") but when it is shut down will stay in memory. This same effect can be started by other sounds (windows, fire bell etc).  This issue is most likely caused by ASC.dll and it is investigated today. The easiest way around this right now is to disable Aerosoft Sound Controls by editing the panel.cfg of the aircraft you use:

[VCockpit01]
file=$DHC6VIRTGAUGES.bmp
Background_color=0,0,0 
size_mm=512, 512
visible=1
pixel_size=512, 512
texture=$DHC6VIRTGAUGES

gauge00=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_Sys1100, 0, 0, 1, 1
gauge01=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_Sys2, 0, 0, 1, 1
gauge02=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_Sys3100, 0, 0, 1, 1
gauge03=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_Ap, 0, 0, 1, 1
gauge04=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_Ann, 0, 0, 1, 1
gauge05=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_system!TW_FDR, 0, 0, 1, 1
gauge06=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_System!TW_State, 0, 0, 1, 1
gauge07=../SimObjects/Airplanes/Aerosoft_DHC6_300_WHEEL/Panel/TW_System!Twot_vibr, 0, 0, 1, 1
//gauge08=ASC!MAIN, 0,0, 10, 10, 0

Add the two // in front of the ASC line. Of course this will remove all VC sounds but for now it is a work around that avoid the crashes.

 

3) the view selector is messed by by ChasePlane. This expected behavior and we'll add that to the manual. ChasePlane is better then our view selector anyway!

 

--------------------------------------

 

If there are more issue do report them here, but make sure you document it well.

 

Link to post
Share on other sites
  • Root Admin
5 minutes ago, jimos87 said:

Aircraft crashes entire sim when changing views, Switches switching on and off by themselves When engines shut down randomly restarts again.

 

We are totally unable to recreate any of that.

Link to post
Share on other sites

HI,

 

Downloaded ver 1.21 and installed it to P3D v4 without any problem except for I am not able to chose where I want it installed. I want it to be installed on an other drive but get a message "... no simulater was found.."

Forced to install in LM P3D directory.

On the first run I have the following errors (see attached log file). Is this error you are working on to fix? Secondly, I was looking for the file where the settings from Pilots checklist is stored but was not able to find any. Where can I find this settings?

 

One more thing, should not this path be in dll.xml instead of exe.xml?

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="AceXML" version="3,0" id="exe">
    <Descr>AceXML Document</Descr>
    <Filename>exe.xml</Filename>
  <Launch.Addon>
    <Name>Flight Recorder</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\Program Files\Lockheed Martin\Prepar3D v4\Ecosystem\Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
</SimBase.Document>

 

Richard

ContentErrors.txt

Link to post
Share on other sites
  • Root Admin

These errors are 'to be expected' at this moment and they do not affect the use (for example it feels comments in config files are errors while they clearly are not). I am not sure what you mean with those settings.

Link to post
Share on other sites

Thank's for the fast answer.

 

What I mean with those settings is I am having problem that sometimes it doesn't set the start to be Cold and Dark, it start with the engines running. Failures unchecked but occasionally they occur. So, my question was where do I find the file where those settings are stored?

 

Richard

Link to post
Share on other sites

The issue with the Twin Otter crashing the entire sim randomly when in external view  needs to be looked at. I have it as well and a friend of mine told me today it happens for him as well. Not everytime but it can definately be recreated when doing a short flight of 15 minutes or so and changing views from cockpit to outside and moving the camera around the aircraft a bit. Doing it a couple of times there is a 100% chance the sim will crash.

 

Edit: I have the version from Simmarket and I think my friend also got it from there. It's not happening with any other aircraft. 

Link to post
Share on other sites

Hi Mathijs,

 

the new ASC.dll works fine on all variants on my side - bell rings properly.

 

Also, the CTD/Breakpoint issue when pulling the levers seems to be gone - didn't happen again.

 

Thank you very much!

 

Link to post
Share on other sites

Hi.

 

I have two mixture levers on mapped to engine 1 and 2 mixture on a CH throttle quadrant and the twin otter crashes p3D V4 to the desktop every time I try to shut down the engines using the mixture throttle quadrant. Trying to move the mixture levers in the VC with the mouse does not seem to work either.

Link to post
Share on other sites
12 minutes ago, pinepix said:

Will give the new dll a go. Do I just rename the file from ASC.7z ro ASC.dll ?

 

No, its a zipped file, so you unzip it, and copy the content(the content being a single file only named ASC.dll) to the panel folder of all the Twotter variants.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...