Jump to content

Archived

This topic is now archived and is closed to further replies.

matteuspoiss

Text in brackets missing

Recommended Posts

Hello

Since the other topic on the same issue has been closed, I will start a new one. Purchased the Airbus bundle and the right MCDU won't show the text in brackets that should be under the menu items. I have gone through the forum and followed different instructions (reinstalled a number of times, checked fonts, run the Simconnect.msi, etc) and so far I have been unsuccessful in making the text show. 

 

If you have any further advice, I would be ever so greatful. The last resort seems to be a compete reinstall of the simulator and I would not want to go down that road, if at all possible. 
My system is Windows 8.1 and I run Prepar3D v3.1
 

Share this post


Link to post
Share on other sites

Hello Matteus, 

 

what SimConnect packet have you installed? It needs to be this one:

 

P3D Mainfolder\redist\Interface\FSX-SP2-XPACK\retail\lib\SimConnect.msi

 

Share this post


Link to post
Share on other sites

Hello Tom

Yes, I have installed this exact one, as it has been mentioned in various topics on this forum. So far no good.

 

Share this post


Link to post
Share on other sites

Have you installed the bus, simconnect and P3D as administrator, and are you running P3D as administrator?

 

Share this post


Link to post
Share on other sites

Check that you ran the install as administrator.

Some fonts may not have been installed correctly to the OS.

 

Share this post


Link to post
Share on other sites

The fonts would have been my next question/guess as well.

 

If you have the Steam client installed and running you have to make sure, that it is not running while installing the bus. Please check in the Windows task manager to make sure, that no steam task is running. Steam prevents 

 

Also make sure that your Windows firewall is not disabled. On Windows 10 a disabled firewall also causes problems when installing fonts. Just to be sure, enable it :-)

 

Share this post


Link to post
Share on other sites

I have installed the buses as administrator and I am running P3D as admin. With simconnect I cannot even select "run as administrator", there is simply no option like that when I right click on it, so I simpli click "Install". I am pretty sure that P3D was installed as administrator as well. Is there a way to check and make sure I have the fonts correctly installed? I did check the Windows/Fonts folder (as specified in some of the other topics) and it seems like all the necessary fonts should be installed. I will add a screenshot of my Fonts folder, maybe that will help clarify. 

windows_fonts.PNG

Share this post


Link to post
Share on other sites

Could you switch to the "details" list in your file explorer please, so that file extension, size and date will be displayed?

 

Share this post


Link to post
Share on other sites

Certainly I can!
Included a new screenshot with "details" selected. Seems like there is no information about the file sizes or dates, though. Am I missing something?

fonts_detail.PNG

Share this post


Link to post
Share on other sites

I am a little bit confused by the "Normal" and "Regular" strings in the file names of the airbus fonts. I don't have them...

 

EDIT: forget that. when using the default file explorer (which I don'T do by default) I also see those additional strings in the file names.

 

So from my point of view the font problem can be excluded. But that leaves me with no further idea as you say you have installed the bus and running P3D as admin...

Share this post


Link to post
Share on other sites

I know. I read in another topic that the fonts should be named "Standard"?
Is there a way to simply get the fonts pack and install them separately?

Share this post


Link to post
Share on other sites

These are specific Airbus style fonts. I don't think I can find them from a font database (at least I don't see them on that page). 

Share this post


Link to post
Share on other sites

Try the attached files e. g. extract those to your Windows\Fonts directory and replace/overwrite existing ones.......

 

Regards,

Hanse

Airbus Fonts.zip

Share this post


Link to post
Share on other sites

So I copied/installed these fonts and restarted and after restart they are again named "Normal" or "Regular", just as before. They seem to be the correct files, though, because I cross checked the "Date modified" and the installed files have the same date and time as the Fonts you provided for download. So they should be the same. For some strange reason Windows adds the "Normal" and "Regular" to their file names... And no change as to the missing text on the MCDU.

 

Share this post


Link to post
Share on other sites
3 hours ago, Tom A320 said:

I am a little bit confused by the "Normal" and "Regular" strings in the file names of the airbus fonts. I don't have them...

 

EDIT: forget that. when using the default file explorer (which I don'T do by default) I also see those additional strings in the file names.

 

So from my point of view the font problem can be excluded. But that leaves me with no further idea as you say you have installed the bus and running P3D as admin...

Tom, would you say doing a clean install for P3D from zero would help here? I guess the flight sim with different add-ons from different developers may get somehow corrupted? I just need a reassurance that going through the trouble of a clean install would really help, otherwise I might not bother. It's sad, since everything else seems to work just fine and the buses fly quite nicely. The MCDU 2 items seems to work, for example, clicking on the "cabin crew" item in the Sound menu activates the cabin crew announcments, etc. But it's still like being blind and not able to see the actual status of the options. 

Share this post


Link to post
Share on other sites

In lack of having any other suggestions at the moment, re-installing everything is of course a valid option.

 

But maybe one final test if the fonts are really installed correctly. In order to do so, you need a file manager other than the Windows File Explorer. Within that file manager go into the Windows\Fonts folder and double click the first Airbus font. A window opens and in the top row you have a button "Install". Click that, and repeat these steps for every Airbus font.

 

It is important to use a different file manager and not the Windows File Explorer, as if you open the font from there the "Install" button is disabled.

Share this post


Link to post
Share on other sites

Tom, could you recommend a different file manager to try? After a quick google search I tried Explorer++ which has the "install" button for the fonts disabled as well.
 

Share this post


Link to post
Share on other sites

I am using "Total Commander".

Make sure to start what ever file manager you chose as Administrator.

Share this post


Link to post
Share on other sites

Ok, interestingly I do not see the Fonts folder in the Windows directory with Total Commander. Why might that be?
I did get a shot with FreeCommander, but it shows all the files divided into several parts? Perhaps this has some useful information to you?

 

fonts3.PNG

EDIT: Ok, the Fonts folder was hidden in Total Commander, I got TC to show it now. I will go through all the Airbus related files and manually install them. Is a restart needed after that? Probably.

Share this post


Link to post
Share on other sites

Interestingly, this is what happens when I install one by one in TC. It seems to start adding files with numbers at the end, such as AirbusDisp_4, 5, 6, etc.
Is that supposed to happen? Looks weird. I will add a screenshot. 

TC_fonts.PNG

Share this post


Link to post
Share on other sites

I don't know the details of the Windows TTF management. The more interesting question is: did that changed anything in your bus???

Share this post


Link to post
Share on other sites

I'm afraid not. I guess a clean reinstall of the simulator and all addons is the only option. When I have enough free time I will give it a try and also report back here whether that helped or not. Thanks for your effort!

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...