Jump to content

Activation Check Failed for WOS 3


Recommended Posts


I have World of Subways Vol 3, which I purchased from the Aerosoft store on 28 May, 2011, installed on my Windows 7 box. I haven't played it in a long time, in fact I might not have done more than install the game on my current PC. When I try to launch the game, I get "Activation Check failed". I uninstalled the game, downloaded the latest update from Aerosoft site, and reinstalled... still the same error. I loaded the Aerosoft Launcher v1.2, and it showed the game as activated, I tried launching the game from the Launcher... same error. I noticed an earlier forum topic about this error from 2011, that suggested uninstalling the game within the Launcher, and then reinstalling the game within the launcher (although that suggestion used an earlier version of the Launcher). I tried this, uninstalled from within Launcher 1.2, but when I closed and opened the launcher, the game did not show, so could not even install from here. I'd like to now start playing this game, please advise me how I can overcome this activation error


Link to comment
Share on other sites

  • 2 weeks later...
  • Deputy Sheriffs

Hello David,

im sorry that I've missed that post until now. Please send us the launcher_log.mp either via support@aerosoft.com or as a private message to me. I will forward this issue then and will sort it out as soon as possible. Once again sorry for the inconvenience.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...