Shomron

Stutters lead to loss of control

Recommended Posts

Hi,

First, congratulations on the release! I am really enjoying the aircraft!

Today I got a strange behavior with the Airbus - when descending into FSDT KDFW I got the "normal stutters" when the airport scenery loads about 10 miles out.

However, during this time the aircraft lost control (pitched up/down violently) - seemed the stutters affected the aircraft directly!

What could have caused this? This hasn't happened to me with other complex aircraft addons no matter how heavy the stutters got.

 

Thanks,

 

Shom

Share this post


Link to post
Share on other sites

You'll experience this anytime your frame rates go below 18fps.  I believe it's in the manual.  The former Aerosoft Airbus was the same way.

 

I recommend changing your settings to ensure you're able to maintain at least 20fps on your flights.

 

Best wishes!

 

 

Share this post


Link to post
Share on other sites
13 minutes ago, DaveCT2003 said:

You'll experience this anytime your frame rates go below 18fps.  I believe it's in the manual.  The former Aerosoft Airbus was the same way.

 

I recommend changing your settings to ensure you're able to maintain at least 20fps on your flights.

 

Best wishes!

 

 

Thanks for the quick reply Dave!

However no matter what my frames are throughout the flight whenever a complex airport loads the fps will go down significantly (even below 18), do you not experience the same?

 

Shom

Share this post


Link to post
Share on other sites

No sir, but I don't get stutters in my sim.  Whatever is causing those needs to be addressed because when they occur your frames are either stopping (stutters) or going very low.

 

Share this post


Link to post
Share on other sites

Hi Dave,

I have had a few cases of the stutters and losing control last night and this morning, but a flight just before had no stutters. My machine was showing 35plus fps, but for some reason, on initial climb out, the stutters start..and it is all over. Resetting and trying another flight does not fix the issue. Maybe one of those things and some code issue not happy in my setup.

On my last flight, I had an issue with CL "signs" being repeated on approach and a loud clicking noise... Looking at file: AB_ND_GDI.log, it shows fps of 57-60 and all things normal...

and I noticed in Immersion.log, the last 50+ readings were all saying AB:FOOTREST_CPT+: 0.20 TO 10.20, and rset itself several times...sort of locked in a loop...about the same time I was having the "signs" being repeated.

 

Any how, maybe put this in another post in the correst area, as I am having a few issues, always with rocket ship climbs...unless I take it out of managed climbs... 

 

Share this post


Link to post
Share on other sites
On 8/9/2018 at 11:32 PM, DaveCT2003 said:

No sir, but I don't get stutters in my sim.  Whatever is causing those needs to be addressed because when they occur your frames are either stopping (stutters) or going very low.

 

Happy to update that by assigning all of the addons to cores other than core 0 I am getting much smoother performance!

So I guess it was the CPU and not the GPU being a bottleneck.

Share this post


Link to post
Share on other sites
4 hours ago, Shomron said:

Happy to update that by assigning all of the addons to cores other than core 0 I am getting much smoother performance!

So I guess it was the CPU and not the GPU being a bottleneck.

Great hear you seem to be on top of it. When you say, "by assigning all of the addons to cores other than core 0 I am getting much smoother performance!" How did you achieve this?

My stutters never came back, though still have the very aggressive climbs/descents.

Share this post


Link to post
Share on other sites
10 minutes ago, por928 said:

Great hear you seem to be on top of it. When you say, "by assigning all of the addons to cores other than core 0 I am getting much smoother performance!" How did you achieve this?

My stutters never came back, though still have the very aggressive climbs/descents.

There is the dirty way of right clicking every add on process in the task manager and under affinity remove them from using core 0.

I plan on purchasing Simstarter NG which I understand does this automatically when set up correctly.

How did you get rid of the stutters? LMK if this helped you as well I'm interested to know.

 

Shom

Share this post


Link to post
Share on other sites
19 minutes ago, Shomron said:

There is the dirty way of right clicking every add on process in the task manager and under affinity remove them from using core 0.

I plan on purchasing Simstarter NG which I understand does this automatically when set up correctly.

How did you get rid of the stutters? LMK if this helped you as well I'm interested to know.

 

Shom

Hi Shom, I have no idea why the stutters stopped. I did nothing different...I think... Despite rebooting, on that day/night, I had that issue every load of the A319/A318 regardless of stock or addon scenery. I had the latest update at the time as well. It was like the video card had gone crazy and I was getting 1 frame every 3 or 4 seconds, but looking at the top of the screen where I had frames displayed, it was saying 35+

When I loaded the bus again a few days later, same scenery, route, load, fuel...no stutters? hate that when the machine self fixes with no clue why.

Share this post


Link to post
Share on other sites

Sometimes (more often than people realize) it's a matter of other software accessing the disk which causes stutters. One of the greatest offenders in this area is the Windows Update which typically occurs on Tuesdays (for us here in the US).  I've personally seen this several times.  Of course there is other software that can cause this as well.

 

 

Share this post


Link to post
Share on other sites
11 hours ago, DaveCT2003 said:

Sometimes (more often than people realize) it's a matter of other software accessing the disk which causes stutters. One of the greatest offenders in this area is the Windows Update which typically occurs on Tuesdays (for us here in the US).  I've personally seen this several times.  Of course there is other software that can cause this as well.

 

 

Yeah Dave, Agree. When the Windows update happens, or for that matter one of the virus updates, I notice the machine grinds to a halt. Where possible, I always fly when all updates done or are to be done later on closure, though, no doubt, some sneak through....

Share this post


Link to post
Share on other sites
20 hours ago, DaveCT2003 said:

Sometimes (more often than people realize) it's a matter of other software accessing the disk which causes stutters. One of the greatest offenders in this area is the Windows Update which typically occurs on Tuesdays (for us here in the US).  I've personally seen this several times.  Of course there is other software that can cause this as well.

 

 

In win 7 I turn off the automatic updates, not sure this is a possible solution in win 10?

Share this post


Link to post
Share on other sites
2 minutes ago, Shomron said:

In win 7 I turn off the automatic updates, not sure this is a possible solution in win 10?

No it is not. You are unable to turn off updates. Win 10 can update pretty well when it feels like, but often on certain days...Tuesday in the US.

 

One of Win 10 latest bright ideas updates, causes programs that were last used on the platform to be reloaded when you boot. Many times when I boot my P3D machine, P3D loads and AS load automatically..Too bad if you have some confidential document in a  program that automatically loads....Anyway, don't get me going on Win10....

 

My FSX machine has a load of Win 7 that is virtually unchanged from original build and has updates turned off since install. FSX always reliable with no constant changes in code.

Share this post


Link to post
Share on other sites

Unless something has changed, you can schedule or disable updates in Windows 10 PROFESSIONAL, but not with the Home version.

 

Best wishes.

 

 

Share this post


Link to post
Share on other sites
22 minutes ago, DaveCT2003 said:

Unless something has changed, you can schedule or disable updates in Windows 10 PROFESSIONAL, but not with the Home version.

 

Best wishes.

 

 

This not to update the Windows 10 is the version that is, I do not recommend it to anyone ever, is more whenever I can recommend having it updated to the day, and I have installed the professional Windows 10, so if I have is disabled many things that affect my privacy policy D in everything, even Windows defender, I use the ESET, although many applications I installers recommend disabling the Firewall and antivirus, I never do and I have never had problems with applications, that if everyone does what they want with their PC.

Share this post


Link to post
Share on other sites
1 minute ago, Miguel_V said:

This not to update the Windows 10 is the version that is, I do not recommend it to anyone ever, is more whenever I can recommend having it updated to the day, and I have installed the professional Windows 10, so if I have is disabled many things that affect my privacy policy D in everything, even Windows defender, I use the ESET, although many applications I installers recommend disabling the Firewall and antivirus, I never do and I have never had problems with applications, that if everyone does what they want with their PC.

 

Miguel, I think your translator struggled with what you wrote above... I just don't understand.

 

Regardless, let's see if we can guide this conversation back to the actual topic.

 

Best wishes my friend!

 

Share this post


Link to post
Share on other sites

You are very right, I use the Google Translator, both to read and write, and so I put or Google errors inadvertently, my language is Spanish

My apologies for that.

Share this post


Link to post
Share on other sites
Just now, Miguel_V said:

You are very right, I use the Google Translator, both to read and write, and so I put or Google errors inadvertently, my language is Spanish

My apologies for that.

 

No apologies necessary my friend!  Many in our community here uses translators (including me from time to time).  I was just letting you know that the translator didn't work well in that one case (otherwise you may not have known).

 

Best wishes for Happy Flights Miguel!

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, DaveCT2003 said:

Unless something has changed, you can schedule or disable updates in Windows 10 PROFESSIONAL, but not with the Home version.

 

Best wishes.

 

 

Yes Dave, I think you are correct. I have the Home edition, so,  stuck with updates...Getting back on topic....This could be "one" of the reasons why many of us have different issues with the bus. We have different flavours of Win 10, Win 7 and the different builds of P3D and the buses mean the slight differences trip us up...

 

Be great if some one could develop a simple debug to validate the load of the buses and see what the ideal load is for so called similar win10/P3Dv4.3 builds is. I recall seeing Mathijs saying they validate a checksum to look for differences

 

I am also loading the step by step tutorial faithfully...I must agree that I have really never done it to that degree. I just popped in the flight plan, fuel and loads and offffff. So I will see how this goes and report as per Mathijs request. 

Share this post


Link to post
Share on other sites
35 minutes ago, por928 said:

I just popped in the flight plan, fuel and loads and offffff.

 

It is altogether reasonable, maybe even probable, that you just don't have the FMGS fully programmed.  This has proven to be the case with at least 7 people I've helped with this issue.  I'm not saying that others may not be seeing something as reported, just what my experience has been.

 

Best wishes!

 

Share this post


Link to post
Share on other sites
10 minutes ago, DaveCT2003 said:

 

It is altogether reasonable, maybe even probable, that you just don't have the FMGS fully programmed.  This has proven to be the case with at least 7 people I've helped with this issue.  I'm not saying that others may not be seeing something as reported, just what my experience has been.

 

Best wishes!

 

Hi Dave,

Probably correct, as this is the heart of the flight....The tutorial is not that easy to follow as it jumps about a lot between explanations about different facets and or choices of the requirements and configuration and the actual flight plan load info.  I guess Aerosoft are trying to provide lots of information about each part to be loaded and the base configuration underneath. I also think there is a potential confusing point in section 5.4 FMGS/MCDU - Data Insertion, item 8. FROM/TO.. it says Enter FRALHR1 into the scratchpad then press LSK1L...Ummm, The use of FROM/TO implies I am looking at LSK1R, but of course, that format (FRALHR1) is wrong, and FRALHR1 does go into LSK1L but into CO RTE, and not FROM/TO as the paragraph lead word says....Anyway, I will work through the step by step and note any divergences I make.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now