Jump to content

Blank Screens


Recommended Posts

I uninstalled FSX and later reinstalled it with all addons uninstalled, later reinstalled Aerosoft Airbus A318 to A321 (all 4) v1.3 which worked well with the known issues, but when I added v1.3F files, the ND, upper and lower ECAM, and MCDU left all go blank. Also the Load sheet seems to have no path to the fuel loader.

I thought it may be my FSX playing up and so decided to convert to FSX steam edition, the same issues have occurred on steam edition and has left me a bit confused at to what's happening.

v1.3F was working before I uninstalled FSX, and like in FSX after uninstalling FSX, FSX steam addition also doesn't ask me to grant permission to run systems within the airbus like it did before the uninstallation of FSX when reinstalling the airbus.

Would this be linked to simconnect and if so how can I fix it please?




Link to post
Share on other sites

SOLVED! This is to do with the DLL trust policy, in my case somehow FSX automatically mistrust DLLs or EXEs. To enable them manually (default) follow these steps

First you must remove the trusted entries in the FSX_SE.cfg under the [TRUSTED] section, I only removed the ones that apply to the Aerosoft Airbus and Active Sky which where both not working properly.

After that go to Start-> run-> type "regedit"-> click enter, now click on Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Provider\Software Publishing all in turn.

Now right click on state, then click on Modify

0x63c00 Allow only items in personal trust database (Automatically)

0x23c00 Is the default manual mode

Change the value back to "23c00" (I previously had the value 63c00)

FSX should now manually ask you for permission to run DLLs etc as normal.


Link to post
Share on other sites
  • 10 months later...


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...