Jump to content

Honeycomb profiles - some work/some don't, JSON formatting (?)


Recommended Posts

See attached two screenshots - the PC12 profile (arranged vertically like a LUA typically is), which WORKS properly (loads into Honeycomb software etc) and then the TBM900 profile (arranged in a string, like a typical XML/JSON), this profile DOESN'T WORK properly (will not load into Honeycomb software etc). 

I've just gotten my hands on the Bravo so I apologize if this is a new guy stupid question, but I'm looking to see what I need to do here to fix the string format profiles so I can load & run them - any advice from the veterans would be hugely appreciated!

 

PC12.PNG
 

TBM900.PNG

Link to comment
Share on other sites

Did you try "Best JSON Formatter and JSON Validator: Online JSON Formatter" ?

here  https://jsonformatter.org/

 

Each time I modify (manually) a profile, I use this validator. And each time the Bridge is not happy, the validator find errors....

 

I use several reformated profiles and they work as long as the validator is OK.

 

My two cents

 

Gérard

  • Upvote 1
Link to comment
Share on other sites

  • Aerosoft

Hi Jim,

 

I don't think the "visual" formatting of the .json file should cause any issues...but any small syntactic error definitely will.

So, I suggest you follow what Gérard was adivising to do and see if there is any syntactic error in the .json file.

 

If that does not help, I will take a further look next week.

Link to comment
Share on other sites

@BenBaron thanks for the reply - I ran the profiles in question which the Honeycomb software does not recognize, through the JSON validator linked by Gerard (Thank you!) and they all check out clean, there are no syntax errors visible.

The only common thread here I can see (with latest version Honeycomb software for XP11) that might lead anywhere for further troubleshooting is that the JSON files which do successfully get parsed by the Honeycomb software are all Unix (LF) format JSONs, while the ones that do not load are Windows (CR LF) format.

Screenshot for reference showing the profiles (left) which do successfully get loaded by Honeycomb, and the list of JSONs (right) which I've downloaded from the Aerosoft forum index for XP11.

I went back through my downloads to make sure I wasn't an idiot, to ensure I didn't try to load MSFS profiles or something dumb etc - but these all appear to be XP11 profiles....

profiles.JPG

Link to comment
Share on other sites

Just a stupid question ...

Did you first "import" the files using the Configurator (don't remember the exact option...)

 

Gérard

 

Edit : Action/Open Settings/Import Profiles

The Configurator don't browse the profile folder but uses a "userconfig" file listing the profiles imported..

 

 

  • Upvote 1
Link to comment
Share on other sites

  • Aerosoft

Hi Jim,

 

I think Gérard correctly pointed out your issue: it is always best to use the dedicated import function of the Config tool instead of just putting a downloaded .json directly into the honeycomb_profiles folder. This way you can be sure that the profiles are formatted correctly and will load as expected.

image.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...