Jump to content

X56 Flight Controls

Graham Young

Recommended Posts

Hi All,


I have found a rather interesting issue and need some help in resolving it, please bare with me:-


I received a new X56 flight control and I use FSUIPC and have tried following the manual to set up the throttles and it won't work at all, no matter how much I have tried. I the stumbled across an LUA (AirbusX_Thr1 and AirbusX_Thr2) and have used them to set the throttles up which works great but when I move the throttles at all (any aircraft), the frame rates drop by 30-40, only whilst it is moving? I posted on several other forums without success and thought I would try removing those entries today and low and behold it doesn't do it with those lua's not being used. By the way the lua simply is (ipc.writeLvar("L:AS_FADEC_0", ipcPARAM*-2)


So whilst I have found what is causing it and I get to use my new controls, I can't use them with the bus as I can't get the throttles working.


Any help appreciated so I can get airborne with my new controls :)




Link to comment
Share on other sites

  • Root Admin

Is there any reason you want to use FSUIPC to setup the throttles? They should work perfectly using the standard inputs and you will avoid all kinds of problems. In FS2004 it made good sense as the input channels were crummy but in P3d V4 they are rock steady.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...