Jump to content
Peter Lürkens

CumulusX! 1.5

Recommended Posts

Hi schermvlieger,

maybe we've got to the bottom ground at the end.

Indeed, in the SDK there is a remark, that for development you have first to install .NET and then the SDK, in order to register the SimConnect.dll with the managed code wrapper and to have support for the object browser.

Apparently this seems necessary for end-user software, too, but, thanks MS, not mentioned in the SDK, as simple as that.

Glad to here it working with you,

best regards,

Peter

Share this post


Link to post
Share on other sites
Hi schermvlieger,

Maybe we've got to the bottom ground at the end. Indeed, in the SDK there is a remark, that for <b>development </b>you have first to install .NET and then the SDK, in order to register the SimConnect.dll with the managed code wrapper and to have support for the object browser.

Apparently this seems necessary for end-user software, too, but, thanks MS, not mentioned in the SDK, as simple as that. Glad to here it working with you,

best regards,

Peter

Wow great stuff; no more frustrated people because of this one (if they can find this thread with google)! Thanks and if maybe I can help you in the future let me know.

Sandor

Share this post


Link to post
Share on other sites

I have just joined this forum, so I hope I'm not asking an old question. i couldn't see my problem mentioned elsewhere.

I have installed CumulusX! 1.5 on my laptop (FSX/SP2) Vista without any problem, although on first run I didn't see any clouds, and debug showed thermals but no lift (time set to July). Haven't tested that further yet.

However - big problem - I tried to install CuX on my main FS PC (FSX/SP2 Windows XP SP2 .NET 3.51 FSUIPC4.40 paid version) and I got the error message "CumulusX! 1.5.4.0 has encountered a problem and needs to close. We are sorry for the inconvenience." I redownloaded - same again. The installer gave that message, so I manually placed the files in the right places. Still rthe same message. Reboot PC no difference. I was advised by a fellow UK VGA member to look in the registry and delete any references to Peter Lurkens and start again. There were none to delete.

Clearly CuX is failing to even start to install on this PC. There is no anitivirus software on this PC either. Any help much appreciated.

Peter

UK VGA

Share this post


Link to post
Share on other sites

I have just joined this forum, so I hope I'm not asking an old question. i couldn't see my problem mentioned elsewhere.

I have installed CumulusX! 1.5 on my laptop (FSX/SP2) Vista without any problem, although on first run I didn't see any clouds, and debug showed thermals but no lift (time set to July). Haven't tested that further yet.

However - big problem - I tried to install CuX on my main FS PC (FSX/SP2 Windows XP SP2 .NET 3.51 FSUIPC4.40 paid version) and I got the error message "CumulusX! 1.5.4.0 has encountered a problem and needs to close. We are sorry for the inconvenience." I redownloaded - same again. The installer gave that message, so I manually placed the files in the right places. Still rthe same message. Reboot PC no difference. I was advised by a fellow UK VGA member to look in the registry and delete any references to Peter Lurkens and start again. There were none to delete.

Clearly CuX is failing to even start to install on this PC. There is no anitivirus software on this PC either. Any help much appreciated.

Peter

UK VGA

Later: I have now found a similar problem reported higher up this topic. I had a look in WinSxS and the 3 Simconnect files are there OK as I would expect as i have no problem with other Simconnect applications.

In the Event Viwer, I have the line .NET Runtime 2.0 Error Reporting. Event 5000 many times. (I tried the install many times).

I attach a screenshot of my search on ".NET" in Windows

One further thought. I have in the past manually edited simconnect.xml and i wonder if I have inadvertantly changed one of the entries which may be relevant. (There are only 2 sets of .comm entries) Could that cause a problem?

Peter

UK VGA

post-28179-125733620474_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Peter,

meanwhile there is one additional issue known, which prevents CumulusX! from proper loading, even if the FS service pack 2 and the doten runtime 2.0 are installed correctly. This has to do with how FSX registers the SimConncect library in the dotnet runtime.

If you have installed FSX before installing dotnet 2.0, FSX fails to register the SimConnect library with the dotnet runtime. This holds true for all versions of FSX (RTM, SP1, SP2, and AXP)

If you only want to run CumulusX! and WinchX! and you had SP2 or AXP already installed, go back to SP1 by uninstalling AXP or SP2. Make sure that dotnet 2.0 or higher is installed on your system, and reinstall SP2. If you want use AXP, uninstall again SP2 now and install AXP.

If you have other add-ons that rely on dotnet and earlier FSX releases, you may have to reinstall FSX entirely ands start all over new.

best regards,

Peter

Share this post


Link to post
Share on other sites

As far as I know Dotnet 2.0 was installed when I bought the PC. I certainly have never installed it myself. So FSX should have been installed later. Because CuX works on my laptop, I wonder if it would be possible to copy a file or registry entry over to my main FSX PC. But which file or which registry entry?

Reinstalling FSX is something I cannot face, I'm afraid. I have too much accumulated activity/scenery/planes etc. etc. Simconnect is at the heart of so many troubles with FS. FSUIPC is far more stable. I wonder could you use that interface instead. Tim Arnot's Plan-G Flight Planner ran into the same problems, and he added FSUIPC functionality and all his "customers are now happy - they can use either Simconnect or FSUIPC.

Peter

Share this post


Link to post
Share on other sites

As far as I know Dotnet 2.0 was installed when I bought the PC.

If it is Windows XP this is highly unlikely (unless it was a used one). Usually dotnet comes with application software. If it is Vista, then Dotnet 2.0 is built-in.

I have no answer on which files or entries to manipulate to "repair" the missing link. Registry entry of CumulusX! itself is recreated automatically if missing or defect, so there is no reason to copy that from some other machine.

Reinstalling FSX is something I cannot face, I'm afraid.

Too bad. You still may try de- and reinstalling SP2 which should leave you all your addons. You can also make a copy of your FSX directory (in order to keep texture patches etc.) and overwrite again after reinstalling SP2. CumulusX! should not be affected by that, but you regain proper function of simconnect.

regards,

Peter

Share this post


Link to post
Share on other sites

I think it will be a DotNet 2.0 issue then, because CuX1.5 runs on my laptop which has the Vista OS. It is my XP machine which fails. Can I uninstall DotNet 2.0 and reinstall it without doing anything else? If I also uninstall and reinstall FSX SP2, will this upset all my addons?

Peter

Share this post


Link to post
Share on other sites

Uninstalling and reinstalling SP2, which was simple, and didn't destroy anything, fixed the problem, and CumulusX now runs on my system. Many thanks Peter for the pointers to the solution.

Peter

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...