Jump to content

Dedizierter Server nicht funktional

Recommended Posts


ich versuche den dedizierten Server von Notruf 112 (https://steamdb.info/app/1480080/) zum laufen zu bewegen.


ich habe bereits in verschiedenen Umgebungen getestet (Docker & VirtualBox).


Das Basissystem ist immer Ubuntu 20.04 LTS oder auch die aktuellste Version mit steamcmd.


Das Dockerfile z.b.:

FROM ubuntu:latest

RUN apt update -y && apt upgrade -y 
RUN apt install software-properties-common -y
RUN add-apt-repository multiverse \ 
    && dpkg --add-architecture i386 \
    && apt update -y \
    && apt install -y lib32gcc1 lib32stdc++6 libc6-i386 libcurl4-gnutls-dev:i386 libsdl2-2.0-0:i386 sudo vim
RUN echo steam steam/question select "I AGREE" | debconf-set-selections \
    && apt-get install -y steamcmd \
    && ln -s /usr/games/steamcmd /usr/bin/steamcmd
RUN useradd -s /bin/bash -m steam \
    && usermod -aG sudo steam \
    && echo "steam ALL=(ALL) NOPASSWD:ALL" >> /etc/sudoers.d/steam
USER steam
WORKDIR /home/steam/


Die letzten Outputzeilen sind immer:

[S_API] SteamAPI_Init(): SteamAPI_IsSteamRunning() did not locate a running instance of Steam.
[S_API] SteamAPI_Init(): Loaded '/home/steam/.steam/sdk64/steamclient.so' OK.
[S_API FAIL] SteamAPI_Init() failed; create pipe failed.dlopen failed trying to load:
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API] SteamAPI_Init(): Loaded '/home/steam/.steam/sdk64/steamclient.so' OK.  (First tried local 'steamclient.so')
CAppInfoCacheReadFromDiskThread took 1 milliseconds to initialize
Setting breakpad minidump AppID = 785770
[S_API FAIL] Tried to access Steam interface SteamNetworkingUtils003 before SteamAPI_Init succeeded.
Setting up 8 worker threads for Enlighten.
  Thread -> id: 7f9800fe2700 -> priority: 1 
  Thread -> id: 7f9771e6d700 -> priority: 1 
  Thread -> id: 7f977166c700 -> priority: 1 
  Thread -> id: 7f9770e6b700 -> priority: 1 
  Thread -> id: 7f96c37f3700 -> priority: 1 
  Thread -> id: 7f96c2ff2700 -> priority: 1 
  Thread -> id: 7f96c3ff4700 -> priority: 1 
  Thread -> id: 7f96c27f1700 -> priority: 1 
src/tier1/fileio.cpp (5086) : m_vecRegisteredWriters.Count() == 0
Segmentation Fault


Ich hänge den kompletten Output mal als TXT an.


Ich hoffe, dass jemand da eine Idee hat :)



Michael Maag


Link to comment
Share on other sites

  • 1 year later...
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy & Terms of Use