Jump to content

AN-2 in P3D


briancar89
 Share

Recommended Posts

Good morning,

 

In the fall I had downloaded the AN-2 (P3D v4 version) and it was working fine in P3D v5.  This weekend I had an issue with my computer and had to reinstall P3D v5, and when I downloaded the AN-2 again to reinstall it doesn't seem to work.  I had set it to go to the P3Dv5 Addons folder, I did notice in the installer some of the folders were set to P3Dv4 but it doesn't allow me to change that.  I'm just not sure why it worked once, but now won't?  Maybe I'm missing something.  

 

Link to comment
Share on other sites

8 hours ago, masterhawk said:

Then it is most likely in the add-on.cfg not registered. Has to be done manually.

Maybe it doesn’t support that method and you have to create the required add-on.xml yourself.

Thanks, would that be a copy and paste or having to open a file and add the line somewhere?

Link to comment
Share on other sites

  • Deputy Sheriffs

In the add-on.cfg you have to register the add-on.xml. Just few lines, similar to all other registered ones in the cfg.

 

I don’t know which components the addon is installing and where they are placed…effects, sounds, simobjects, dll.

These components have to be registered in the add-on.xml.

 

Maybe you should check how it’s done for other addons, to get a understanding of the process.

 

Link to comment
Share on other sites

Just took a quick look and compared it to the Aerosoft A320 Professional, they both appear pretty similar inside the .xml file, similar paths though the Airbus has a bit more.

I've looked in the P3D folder, add on folder, and P3D files folder but don't see the add-on.cfg file.

Link to comment
Share on other sites

  • 3 weeks later...

I think I may have found a part or maybe all of the issue.  Since I had originally downloaded P3D in late November it appears a new version was released, with some slight updates, when I went to download it again in January after the issue I had with my computer it downloaded this new version, perhaps the AN-2 installer was not compatible with that new version?

I did try to copy the aircraft folders from the P3DAddons folder, and place them in the simobjects folder in the main P3D directory, that did work to a point, I now have access to maybe 5 or 6 different liveries of the AN-2, I'm not sure why all the variations did not copy over however.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy & Terms of Use