Jump to content

Problems with starting P3D - probably due to Aerosoft Airbusses


Recommended Posts

Good evening dear Aerosoft Crew and Users,

I hope this section of forum is appropriate for my issue, if not I apologize, because this is my first post in this forum, despite simming for quite a few years, initially FSX with Airbus X, now P3Dv4.5 with A318/A319/A320/A321/A330 Professional, and why I mention this, because through years I've had, like everybody simming I guess, many various issues, I've solved many of them with huge help of this forum or sim one by reading threads. As I fly  mainly during summer, I try to constantly keep everything up to date, so when an update comes, I check if everything works (by starting the sim, and loading quick scenario). Since moving to P3D from FSX in 2020, I've bought my beloved Airbusses, GSX, REX SF 3D, and a few sceneries, everything ran smoothly  - both 'playing around' aswell as VATSIM and IVAO flights (BTW all busses are AWESOME, congratulations on them :)). Till yesterday, I wanted to check if everything is ok, because of downloading A330 update last week AFAIR, and REX Sky Force 3D update... I've clicked on P3D icon as always, it started loading, but after a minute or two splash screen dissapeared, I've tried Alt+Tab - nothing (no windows), checked Process Manager, P3D was there running, I've ended the process and clicked on P3D again - the same thing happened, when I click one P3D icon again (the first process still runing) whole screen turns black. So I've started looking what could possibly be wrong, firstly I've uninstalled all busses, the sim started, so I could manage scenery, I've checked one by one (removed all, and added gradually, and started P3D every time to check if it's ok), P3D worked with all the sceneries. Next I've installed busses and tried running, firstly without only GSX, then REX, still crashed... I've spent almost the whole sunday trying to find what's wrong, I've searched this forum, aswell as P3D, tried many options (Delete Generated File option, deleting cfg files etc.) possibly everything I've found on P3D forums and here - nothing. Today I've uninstalled everything, yes it hurts, but I thought it might solve the issue (including deletion of files from AppData, ProgramFiles etc. folders), all addons. I've made a clean install, firstly P3D, after installation I've checked if it runs - was ok, then sceneries, one by one, started sim - everything works, next GSX and REX - worked, after installing Airbus A318/A319 Professional; Airbus A320/A321 Professional; Airbus A330 Professional), I've tried, and again - P3D disappears on splash screen  :(

As I wrote, I've never posted in forums, because always I was able to fix the issues, but at this point it surpassed me greatly, I am tired, sad, and a bit mad :( Due to symptoms, I suspect that the busses are the issue and that's why I decided to post here, BTW all drivers, BIOS and everything is up to date - I check for updates every day.

I know, what I wrote might sound a bit desperate, is a bit long, I'm just tired of it and out of ideas ;). Therefore I kindly ask for HELP!!! I will provide all the files You need in order to help me, just tell me which ones :).

 

Kind Regards

Michael

 

Link to post
Share on other sites
  • Deputy Sheriffs

Michael,

 

which graphic card and driver you are currently using? If you are using NVIDEA then your problems might be related to their newest driver. Did you recently updated your driver? There are a lot of problems using this driver in connection with P3D and currently the only suggestion is to roll back to a previous driver version.

 

Kind reagards,

Rolf 

Link to post
Share on other sites

Hello Rolf,

Thanks for reply, yep, I've updated Nvidia Geforce Game Ready Driver recently to 465.89, released 30th of March, my GPU is GTX1050Ti, thanks for this hint, but I've got more news: just a while ago I've tried once again this 'solution': I've removed scenery.cfg from %ProgramData% and clicked 'DeleteGeneratedFiles', then tried to launch P3D, I've chosen not to load add-ons, to my surprise it started, the thing is that the busses were not in the addons list, I've enabled all other addons, and restarted, but buses were still not there (screenshot). I'm happy that finally something moved ;), so my question considering current state, are busses also dependent on the graphic driver, or You reffered to sim only? because I'm afraid, that next reinstall of busses will result the issue to repeat 😕. It's so weird to me, as back in February everything ran perfectly.

1710243961_Screenshot(556).thumb.png.0733ca302a47036be6042e9d6febabdf.png

ASU shows them right, installed and updated, all other tools like fuel planner, CRM etc. work right

1638636036_Screenshot(557).thumb.png.1cfdae2b6528f72ae67fc97a03aea27f.png

Additionally I did notice, that all liveries in livery manager disappeared, both default and added, despite being in aircraft location, and added to aircraft.cfg. Interesting thing is, that when P3D kept crashing (before removing scenery.cfg + 'DeleteGeneratedFiles' option), the liveries were displayed in LM... 

1586537876_Screenshot(558).thumb.png.b162cf6a6cab594333bb322bc6dbd50e.png

Cheers

M

Link to post
Share on other sites

Good news, I have no idea how this happened... I've reinstalled all busses once again, then made backup of add-ons.cfg and scenery.cfg from %ProgramData%, used 'DeleteGeneratedFiles' option, and the replaced newly created add-ons.cfg and scenery.cfg with backup ones, appears to be ok now :).

Link to post
Share on other sites

After I've managed to get it working, I've discovered that after installing RAASPRO for Airbuses, it happens that after loading, instead of scenario selection I've got black screen (same way as previously, before reinstall) - can't do anything but close the sim via process manager, but I did notice that disabling RAASPRO in dll.xml from %ProgramData% by changing <Disabled> value to True, makes P3D start (without RAAS working ofc)...

Quote

<?xml version="1.0" encoding="UTF-8"?>

<SimBase.Document Type="AceXML" version="3,0" id="dll">
    <Descr>AceXML Document</Descr>
    <Filename>dll.xml</Filename>
  <Launch.Addon>
    <Name>RAASPRO</Name>
    <Disabled>True</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>.\RAASPRO\RAASPRO.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
</SimBase.Document>

Any ideas what might have caused this issue? RAAS is quite nice, and I'd like to bring it back...

Link to post
Share on other sites

Ook bij mij problemen na installatie NVIDIA driver update.
Installatie naar NVIDIA Studio Driver en probleem opgelost.
Nu geïnstalleerd NVIDIA Studio Driver Versie; 462.31
Releasedatum; 04/14/2021

 

installatie via het NVIDIA keuze stuurprogramma.
(rechts boven 3 stippen)

 

Hoopt het helpt ook anderen

Prepar3D is geen spel?
Groet
Bart

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...