Jump to content
Akos Bohus

Strange Behavior (TOW and others)

Recommended Posts

Installing the CumulusX! never worked me by clicking the .cmd file (due to reporting an error always), so I always decided to install it manually.

Here are my 'AppData\Roaming\Microsoft\FSX' files necessary to run this program properly attached into a zip file:

CMX.zip

Debug mode tells CumulusXDLL.dll = False, however it was added as trusted software into the sim.

Tow plane works, however sometimes it is allowed to turn in the opposite way (direction changes between right or left turns inflight), sometimes does not.

After a tow process the plane returns to the field. When I approach the airport at low altitude, the tow plane starts to roll low speeds and does not stops, that stuff is some kind of funny but I am sad about it.

 

As you can see I use manual load of the program. Check lights are green, orange, and red from the top to the bottom.

 

 

2020-4-10_12-46-28-833.jpg

Share this post


Link to post
Share on other sites

Hi Akos,

 

What error message was displayed?

 

Please check, if the dll exists at the given path:

 

C:\Program Files (x86)\Steam\steamapps\common\FSX\Modules\CumulusX!\CumulusXDLL.dll

 

Please the actual FPS by Shift-Z, and lower to an even fraction of 60 (20, 15 ...) below what is shown by the FPS indicator (I saw that you have set 30), but when the CPU is overloaded, it has weird effects.

 

Not all plane models are fully compatbile with smart tow, but it looks like the Husky which is.


In any case, please install by right click the CMD and select "Run as Administrator", and the choose the FSX Steam base directory for installation.

 

best regards,

Peter

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Might be the .cmd installation error message was because of FSXSE version, I could not imagine other issue.

There was no other specific error message but the CumulusXDLL.dll's status was false, which probably means inactive.

Although I have a licensed version, debug checkings keeps in false the dll.

What is your recommendation? Do I have to change the UPPER_FRAMERATE_LIMIT?

 

Sincerely,

Ákos

Share this post


Link to post
Share on other sites

Sorry, In my previous post I meant the Maule of Course.

 

Yes, the it is the upper_frame_rate_limit parameter in the FSX.CFG,  but "Target frame rate:" in the GUI. But you may check before, what FPS you achieve in unlimited mode, to get an idea about performance margins.

 

I saw also in the DLL.xml , that you installed some A2A package and the DX 10 fixer. So far I haven't got any feedback on trouble with CumulusX! with these two, but it might be worth a try to deactivate the two other dlls, to see if there is any difference. If so, I'd suggest to move the CumulusXDLL-entry before the others (once there was such interference with ActiveSky, but fixed meanwhile on their side).

 

You may change line 5 in your dll.xml from

  <Launch.ManualLoad>False</Launch.ManualLoad>

To:

  <Launch.ManualLoad>True</Launch.ManualLoad>

 

to decide on loading of each DLL separately.

 

On different turning, the circuit pattern direction is not active anymore approx. 300 m AGL, the tow plan targets the next recognizable thermal then which results into any required turning direction.

 

best regards,

Peter

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank You Peter for your time! Now everything depends on me to make my best and solve it.

 

 

Share this post


Link to post
Share on other sites

Hi Akos,

 

I checked the A2A with the free P40, seems to be their DLL. Move this section to the end of the list, just before </SimBase.Document>:

 

<Launch.Addon>
        <Name>A2A Service</Name>
        <Disabled>False</Disabled>
        <Path>A2A\Shared\A2A_Service.dll</Path>
        <DllStartName>module_init</DllStartName>
        <DllStopName>module_deinit</DllStopName>
    </Launch.Addon>

 

BR,

Peter

  • Upvote 1

Share this post


Link to post
Share on other sites

Birds and thermals are working, also the TOW plane finds them and reacts well to given commands. 

Two things remained buggy, sometimes the TOW aircraft has it's lights sometimes not, "vacating from the runway, stopping and disappearing" doesn't seems to be work. 

Might be the limited compatibility of FSXSE or custom airport missing .bgl entries? 😕 Still don't know it.

Share this post


Link to post
Share on other sites

Actually I have no clue. I'd suggest to selectively switch off other addons to exclude interference with those.

 

Btw, I got into contact with A2A, they are going to check the DLL-installation isse. I'll keep you posted.

 

BR,

Peter

  • Upvote 1

Share this post


Link to post
Share on other sites

I can confirm that. As you said there must be a problem with A2A service dll's. Using CumulusX! impacted with J3 Piper Cub's physics and I could not take off.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...