Support overload. We are currently seeing 65% more demand for support then we normally see. We can only assume this is because more people are at home due to the corona crises. Our complete support staff is online and they are working flat out, but it will take some days before we can scale up resources. Please be patient.

Jump to content
David Tinker

Yaw Damper, Flight Director won't engage

Recommended Posts

Tried several times to takeoff in tutorial flight, autopilot won't engage.  Saw previous posts on that, tried pushing AP button with neutral yolk, still won't engage but noted in your reply that the yaw damper must be engaged.  I cannot get yaw damper to engage at any time during the checklist.  Hydraulics on, only warning left on screen is "Yaw Damper".  Also, pressing FD button has no effect.  Help help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...