!! Windows 7 no longer supported !!

As Microsoft will stop supporting Windows 7 on Jan 20th we will be unable to test any of our
products on that platform. It may work, or it may not, but no guarantees from our side. 

Jump to content
David Tinker

Yaw Damper, Flight Director won't engage

Recommended Posts

Tried several times to takeoff in tutorial flight, autopilot won't engage.  Saw previous posts on that, tried pushing AP button with neutral yolk, still won't engage but noted in your reply that the yaw damper must be engaged.  I cannot get yaw damper to engage at any time during the checklist.  Hydraulics on, only warning left on screen is "Yaw Damper".  Also, pressing FD button has no effect.  Help help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...