RotateSimulation

Extremely Long Stutters

Recommended Posts

Hi its me again. I have no idea why this addon seems to hate me so much but I am having another problem with it. I am experiencing stutters of approximately 1 second which in turn makes the aircraft go bezerk, I assume this is the fly-by-wire trying to catch up. It is 100% the addon as I decided to do a test flight with every setting reduced, all scenery default and I am still getting these stutters which make the aircraft un-flyable. I have never experienced this before with any addon aircraft. Additionally the fps are still rather low for what I am used to (30fps and above) whereas this aircraft I am lucky to get a steady 25fps. Any advice?

I don't want to say I am disappointed in this addon as I am sure its something I am doing as I have seen people with lower specs getting a lot better performance than me.

 

Many thanks!

 

My specs if they help;

CPU - i7 4790K Overclocked to 4.7GHZ

GPU - Nvidia GTX1080 8GB

 

My settings are also attached in case they help.

1.jpg

2.jpg

3.jpg

4.jpg

Share this post


Link to post
Share on other sites

I can see multiple problems with you settings, but need some additional information from you before I make recommendations.

 

Other than the Airbus Professional, which other addon aircraft do you fly and what are your frame rates for those?

 

 

 

Share this post


Link to post
Share on other sites
17 minutes ago, DaveCT2003 said:

I can see multiple problems with you settings, but need some additional information from you before I make recommendations.

 

Other than the Airbus Professional, which other addon aircraft do you fly and what are your frame rates for those?

 

 

 

Hi Dave,

 

PMDG 777 Series - Average 35fps or above

PMDG 737 - Average 30fps or above

PMDG 747(-8) - Average 35fps or above

 

Please note all these are at payware sceneries. 

 

 

Share this post


Link to post
Share on other sites
13 minutes ago, RotateSimulation said:

Hi Dave,

 

PMDG 777 Series - Average 35fps or above

PMDG 737 - Average 30fps or above

PMDG 747(-8) - Average 35fps or above

 

Please note all these are at payware sceneries. 

 

 

 

Okay, the changes I'm going to recommend should increase the frame rates running those other aircraft.

 

- Unless you've already done so, please use DDU to wipe your graphics drivers and then install the latest NVIDIA Driver.

- Under the Display Options, select "Reset Defaults".

- Check to ensure that your Display Resolution matches the monitor you're using.

- V-Sync to On

- Triple Buffering to On

- FSAA (your choice, unless you're running a 4K monitor you may wish to set this to on).

- AA  4xMSAA

- Texture Filtering to 8x

- Resolution to 2048x2048 (I don't think you'll notice a difference).

- Uncheck "Simobjects" under Casting and Receiving

- Remove any NVIDIA Inspector settings and go with default.

- Clear (delete) your P3D Shaders (located in your C:\Users\[YOUR USERNAME]\AppData\Local\Lockheed Martin\Prepar3D v4, and do this after you wipe and reinstall your NVIDIA drivers and have changed the above settings.

-Delete your Prepar3d.cfg file located in your C:\Users\[YOUR USERNAME]\AppData\Roaming\Lockheed Martin\Prepar3D v4 and refrain from making any changes to the CFG file.

 

One thing to remember that as far as I know, the Airbus Professional is the only third party aircraft to be compiled for P3DV4. This means that the Airbus Professional is using parts of the base sim that other aircraft aren't using.  This is one reason why you're seeing a difference between the Airbus and other third party aircraft.

 

I would also ensure that all your system drivers are up to date, and run Scan Disk on your hard drive (unless it's an SSD).

 

Looking forward to hearing back from you after testing the above on your system.

 

 

 

Share this post


Link to post
Share on other sites
Just now, DaveCT2003 said:

 

Okay, the changes I'm going to recommend should increase the frame rates running those other aircraft.

 

- Unless you've already done so, please use DDU to wipe your graphics drivers and then install the latest NVIDIA Driver.

- Under the Display Options, select "Reset Defaults".

- Check to ensure that your Display Resolution matches the monitor you're using.

- V-Sync to On

- Triple Buffering to On

- FSAA (your choice, unless you're running a 4K monitor you may wish to set this to on).

- AA  4xMSAA

- Texture Filtering to 8x

- Resolution to 2048x2048 (I don't think you'll notice a difference).

- Uncheck "Simobjects" under Casting and Receiving

- Remove any NVIDIA Inspector settings and go with default.

- Clear (delete) your P3D Shaders (located in your C:\Users\[YOUR USERNAME]\AppData\Local\Lockheed Martin\Prepar3D v4, and do this after you wipe and reinstall your NVIDIA drivers and have changed the above settings.

-Delete your Prepar3d.cfg file located in your C:\Users\[YOUR USERNAME]\AppData\Roaming\Lockheed Martin\Prepar3D v4 and refrain from making any changes to the CFG file.

 

One thing to remember that as far as I know, the Airbus Professional is the only third party aircraft to be compiled for P3DV4. This means that the Airbus Professional is using parts of the base sim that other aircraft aren't using.  This is one reason why you're seeing a difference between the Airbus and other third party aircraft.

 

I would also ensure that all your system drivers are up to date, and run Scan Disk on your hard drive (unless it's an SSD).

 

Looking forward to hearing back from you after testing the above on your system.

 

 

 

I am going to try this right now and then get back to you. Thank you greatly for this. I will let you know how testing goes.

Share this post


Link to post
Share on other sites
1 hour ago, DaveCT2003 said:

 

Okay, the changes I'm going to recommend should increase the frame rates running those other aircraft.

 

- Unless you've already done so, please use DDU to wipe your graphics drivers and then install the latest NVIDIA Driver.

- Under the Display Options, select "Reset Defaults".

- Check to ensure that your Display Resolution matches the monitor you're using.

- V-Sync to On

- Triple Buffering to On

- FSAA (your choice, unless you're running a 4K monitor you may wish to set this to on).

- AA  4xMSAA

- Texture Filtering to 8x

- Resolution to 2048x2048 (I don't think you'll notice a difference).

- Uncheck "Simobjects" under Casting and Receiving

- Remove any NVIDIA Inspector settings and go with default.

- Clear (delete) your P3D Shaders (located in your C:\Users\[YOUR USERNAME]\AppData\Local\Lockheed Martin\Prepar3D v4, and do this after you wipe and reinstall your NVIDIA drivers and have changed the above settings.

-Delete your Prepar3d.cfg file located in your C:\Users\[YOUR USERNAME]\AppData\Roaming\Lockheed Martin\Prepar3D v4 and refrain from making any changes to the CFG file.

 

One thing to remember that as far as I know, the Airbus Professional is the only third party aircraft to be compiled for P3DV4. This means that the Airbus Professional is using parts of the base sim that other aircraft aren't using.  This is one reason why you're seeing a difference between the Airbus and other third party aircraft.

 

I would also ensure that all your system drivers are up to date, and run Scan Disk on your hard drive (unless it's an SSD).

 

Looking forward to hearing back from you after testing the above on your system.

 

 

 

Firstly thank you very much. You have fixed my problem but also given me a solid 10fps more on what I normally get with my other aircraft! I have been out of the simming world for about 8-9 months due to work commitments so evidently I had forgotten something or messed something up with my settings... just trying to make excuses here lol!

I followed all your steps except the HDD one as I run an SSD and it worked perfectly however just in case anyone else is following. I made a few anti aliasing tweaks in Nvidia Inspector as I had a few jaggies and did not use V-SYNC as I run a G-SYNC monitor. If you do change anything in Nvidia Inspector i'd advise you change one setting at a time, testing each time just to make sure it doesn't effect anything negatively. 

Once again, many thanks @DaveCT2003!

  • Upvote 1

Share this post


Link to post
Share on other sites
52 minutes ago, RotateSimulation said:

Firstly thank you very much. You have fixed my problem but also given me a solid 10fps more on what I normally get with my other aircraft! I have been out of the simming world for about 8-9 months due to work commitments so evidently I had forgotten something or messed something up with my settings... just trying to make excuses here lol!

I followed all your steps except the HDD one as I run an SSD and it worked perfectly however just in case anyone else is following. I made a few anti aliasing tweaks in Nvidia Inspector as I had a few jaggies and did not use V-SYNC as I run a G-SYNC monitor. If you do change anything in Nvidia Inspector i'd advise you change one setting at a time, testing each time just to make sure it doesn't effect anything negatively. 

Once again, many thanks @DaveCT2003!

 

 

Most welcome my friend.

 

Best wishes for Happy Flights!

 

Share this post


Link to post
Share on other sites

I do not want to ruin your party guys, but if you do exactly as Dave outlined in a sequential order, you have your settings back to default... Problem: if you put VSYNC, MSAA, resolution, shadow settings and all this stuff and delete your prepar3d.cfg AFTERWARDs, all is reverted back to default. No wonder, you get more FPS then... I hope the topic starter realized this and adjusted the settings only AFTER deleting the prepar3d.cfg.

 

Besides that, I will never understand why people still suggest 8x for texture filterting, even a 1050 is nowadays powerful enought to run 16x. The days were high anisotropic filtering resulted in lower FPS is over since 2010...

Share this post


Link to post
Share on other sites
8 hours ago, Querer said:

I do not want to ruin your party guys, but if you do exactly as Dave outlined in a sequential order, you have your settings back to default... Problem: if you put VSYNC, MSAA, resolution, shadow settings and all this stuff and delete your prepar3d.cfg AFTERWARDs, all is reverted back to default. No wonder, you get more FPS then... I hope the topic starter realized this and adjusted the settings only AFTER deleting the prepar3d.cfg.

 

Besides that, I will never understand why people still suggest 8x for texture filterting, even a 1050 is nowadays powerful enought to run 16x. The days were high anisotropic filtering resulted in lower FPS is over since 2010...

 

Correct, I set him back to default.  As for the rest, I disagree and I simply too busy to argue or educate my friend (I have a Hurricane getting ready to hit).  If you're happy with your system, then that's great.

 

Best wishes.

 

Share this post


Link to post
Share on other sites

Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.