This topic is now archived and is closed to further replies.


Hours trying and still Saitek yoke throttles still will not work

Recommended Posts

I have been trying to fly the 318/319-320/321 for weeks and still am unable to get any movement with throttles. Even the mouse will only make them jump forward an inch and then pop right back.

I have read and reread Vol7 Thrust lever setup and tried everything except fsuipc.

Also reversed controls, changed Configurator setting, etc. Still no luck.

I wasted another two hours today going through it again and have not flown a single fsx flight. Sorry to be so blunt but when a lot of money is spent on a product, it should work. I just do not have unlimited hours to troubleshoot this problem.

Surely someone has a fix for this. Please post it for those like me who really want to fly this plane.

Best regards to all

Neal Howard

Share this post

Link to post
Share on other sites

I have the Saitek yoke and throttle and it works just fine. I am not passing the controls through FSUIPC. What is not working? How have you got the levers assigned? Have you defined separate levers for each engine, or one lever for both? I assume the throttle is working ok for other aircraft? Have you assigned the levers for other aircraft? Any other addons could interfere- it'll be hard for AS to respond if you don't give them some information on your system.

Also note that the Saitek throttle quad that comes with the yoke MUST be plugged into the yoke, it is not a PS/2 plug on the throttle quad and will not work without the yoke. This is why I configure my yoke as the tiller when flying the airbus and attach a joystick.

The product works for me, even after three full FSX reinstalls and a number of Airbus reinstalls after upgrades, it has always worked fine. I suspect you would know by now if lots of people were having problems with this commonly-used hardware as Aerosoft would have responded with a fix. Please do not give up yet - give them the info they need to help you :)

Share this post

Link to post
Share on other sites

I have the Cessna Yoke and quadrant plus an additional Saitek quadrant and have used this system for several years.

This unit is used mostly for twins so each engine has its own throttle, propeller and mixture lever (naturally, only two of them are needed with the airbus).

Quadrants are plugged in correctly. Naturally, the one quadrant is plugged into the yoke-----that is the only place the connector will fit.

As i said above "I have read and reread Vol 7 Thrust lever setup and tried everything except fsuipc." I have tried fsuipc in the past but usually found that my controls worked just as well usinf FSX to set them.

Only Saitek drivers are used and not their software.

I agree that it might not be a common problem but it must be for some, Please look at the VOL 7 Thrust Lever Setup which adresses, but does not fix the problem.

This is a new one for me...never happened on any other planes. Every other lever, button, control axis works just fine. It is just ths FADEC thing that seem to be the problem source (according to VOL 7) whatever that means. :confused_s:

Will give it another try today, maybe fsuipc will work.

Neal H

Share this post

Link to post
Share on other sites

Thanks Graham

I just bookmarked the thread and downloaded files and JPGs.

I spent another two hours on it today and SUDDENLY the throttles worked.

Happy simmer---for about one minute. Then elevators/ailerons/rudder pedals quit.

Went back through everything again. Restarted fsx about a dozen times and finally (believe it or not) everything worked!!

Maybe tomorrow I can figure out just what I did to get it going. In the meantime I plan to study your fsuipc fix.

Btw....By the time everything worked it was too late to set up a flight :(

Ain't this a great hobby? :mallet_s:

Thanks again

Neal H

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.